A very strange saving behavior with vectors and embedded images upon save

New Here ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

I have stumbled upon a quite bizarre issue when saving a file with large embedded images (totaling around 0.5-1GB) combined with vectors.

 

When saving with the images only, there is no issue, quick and painless, but after adding 2 distinct vector logoss, created by a partner, saving the file takes about 20-30ish minutes and has managed to reach 30GB of memory usage with a constant 10% CPU usage (have in mind that the machine is beefy with lastest updates). I would assume that the issue is somewhere in the vector logos but I have never encountered anything like it before, nor had I read about one. I will indeed try and see what the issue might be with the vectors, but has anyone seen something similar?

TOPICS
Bug , Performance

Views

70

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

I've noticed something similar after the latest update. Working on a doc with multiple linked images, a few artboards, and vector graphics, the CPU spiked so hard that Illustrator disabled GPU preview and forced me to use CPU preview. This has happened in the past, albeit rarely, and normally restarting Illustrator would fix it and allow GPU preview once again. However this time it took multiple system restarts before it came back. 

Also with the latest update, saving files similar to above seems to be taking wayyy longer and there are overall way more glitchy issues. I believe there's some kind of critical error with the latest update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

This has been an issue with various versions of Illustrator since CS4 I think. I might be imagining, but it's getting worse. And yes, while saving Illustrator is completely unresponsive, blinking, black-screening and all the good stuff.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

Can you perhaps show something?

Tell us about the nature of those artworks?

 

It sounds like there is some rasterization and/or transparency involved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

No transparency on anything. Vectors are vectors, images are just embedded and no processing on them whatsoever. I have narrowed it down to one of the vectors that I paste into the file, but it is still bizarre that a vector transferred from one file to another causes such issues. On its own, the vector logo is saved with no issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

LATEST

Files and go corrupt and so can single objects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines