Artboard Rotation while using touchpad for zoom in Illustrator 25.3

New Here ,
Jun 12, 2021 Jun 12, 2021

Copy link to clipboard

Copied

Hi, recently I faced a new problem. When I use the trackpad for zoom-in/out the artboard keeps rotating. I don't know how can I fix this problem.Screenshot 2021-06-12 at 23.27.43.png

TOPICS
Bug , How to

Views

69.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 4 Correct answers

Adobe Employee , Jul 08, 2021 Jul 08, 2021

Hi all,

 

Sorry about the trouble this feature has caused. We are working on the feedback shared by all of you and will be sharing all the updates related to this issue on our UserVoice page ( https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/43637925-canvas-rotation-feature-is-obstructing-regular-pin ).

 

Till the time it is fixed, please try one of the workarounds already shared on this post, i.e.:

  • Press the Esc key.
  • Double click the Rotate View tool.
  • Press
...

Likes

Translate

Translate
Adobe Community Professional , Jul 27, 2021 Jul 27, 2021

Anyone reading this today may be glad to know that updating to Illustrator 25.4 introduces this option in preferences:

 

Screenshot 2021-07-27 164829.png

Likes

Translate

Translate
Adobe Employee , Aug 03, 2021 Aug 03, 2021

Hi all, 


We have tried to address this issue in our latest release. Update 25.4.1 is live for all the countries. Please update Illustrator to the latest version to get access to this option (Trackpad Gesture to Rotate View).

 

SrishtiBali_0-1628011831408.png

Please feel free to reach out if you run into any other questions or issues in the future, we'd be happy to help.

 

Regards!

 

Likes

Translate

Translate
New Here , Apr 10, 2022 Apr 10, 2022

Hi I solved this problem by going to macbook System Preferences> Track Pad >Scroll and Zoom > Rotate and uncheck rotate with two fingers .

 

Hope this helps if there isn't already another solution that i have missed. 

Jo 

 

Likes

Translate

Translate
replies 167 Replies 167
Community Beginner ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

This new feature is DRIVING ME CRAZY! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Screenshot 2021-06-10 at 10.17.05.pngAs you can see i accidentally rotated my workspace (not just my artboard, the ENTIRE workspace) and i can't rotate it back to 0 deg. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Either double-click on the rotate view tool in the toolbar, or View > Reset Rotate View

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

This is so annoying, please look at adding a disable rotating function,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Yes indeed,  having the same Irritation; I Cant get it back to 0°. I have to create a new doc and after 45 min I carefully tried to zoom in... BAAM again the flip flop feature.


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

You can use the View > Rotate view > 0 sequence to reset it and keep from creating a new document.  And I agree it is very annoying. Needs to be fised. ASAP.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

thank you for this simple fix.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

Thank you, Thank you , Thank youuuu! This was driving me crazy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

My artboard rotates in the newest version when I make a slight rotation gesture on my touchpad, like 5° and it seems impossibel to bring it back to 0°. Anynone solved this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

For now I deactivated the rotation function for the touchpad in the Mac settings, so it wont happen again 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

Thank you! I don't see the point of this function and why it would be made SO easy to initiate that it interferes with basic work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

I'm guessing (because I assume my touchpad doesn't support this) that the gesture is activating the rotate view tool.

You can use the tool itself to rotate back to 0 (hold shift to rotate in increments), double-click the tool in the toolbar, or go to View > Reset Rotate View

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Thanks! Thats it 😄 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2021 Jul 10, 2021

Copy link to clipboard

Copied

command + shift + 1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

OMG TY!!!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

When I zoom in & zoom out on Adobe Illustrator 2021, my artboards automatically rotate, how to prevent this from happening? Can I disable rotate for artboards? It is very frustrating I will be thankful for any tips.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

Is this when using a trackpad?

What hardware are you using, to narrow it down? It may be possible to disable that particular gesture in your system settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

My canvas on illustrator is getting rotated again and again and I am unable to fix it. please help.

Screenshot 2021-06-21 at 5.38.31 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

While selecting multiple objects holding down Shift key and then also panning holding down Spacebar, the Rotate View tool is activating and rotating the canvas in the middle of my action of selecting as I pan.  I don't understand this as these are not the short cut keys assigned to the Rotate View tool.  I went into keyboard shortcuts to delete any associated keys with Rotate View tool, but it is still engaging when I select (Shift) and pan (Spacebar).  How can I disengage the Rotate View tool altogether?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

I suspect this is an unalterable shortcut, much as the spacebar activating the hand tool cannot be changed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

I'm having this same problem. Please allow us to lock the rotate view. I'm having to reset it every single time I zoom in and out, which is A LOT! It's so sensitive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

I am having the exact same problem and I really, really, really hope they fix this soon. I use my MacBook Pro touchpad to zoom in and out almost exclusively and the fact that the only solution is "turn off rotation for your entire computer" instead of just being able to lock the artboard orientation is kind of ridiculous.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

PLEASE add a feature to disable or lock the rotation. I use a trackpad and this is slowing my workflow like crazy. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines