Artifacts after pathfinder operations driving me insane

New Here ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

Hi everyone,

I'm having an infuriating issue that I can't seem to get to the bottom of, and that is happening with increasing frequency.
When I build shapes using the Pathfinder tools I get these weird artifacts as shown below, that do not show up in outline mode. They also disappear if I rotate the object to ANY degree. I've "solved" a lot of these issues by rotating an object 0.1 degrees but I hate doing that. Now I'm working on a logo and I want it to be a solid piece without any half-assed solutions.

The issue can also go away, or transform, when I move the object around the artboard. When dragging and dropping it the artifact has a 10% chance of disappearing.

I want to have an english and norwegian version of the logo but if I bottom- or top-align them at least one will have an error.

Any tips or tricks for fixing this stuff? I have concluded that Illustrator just doesn't like cutting with the Lucida Sans font (made into outlines of course).

I'm using the latest version of Illustrator, on Win10 64.

Screenshot_4.pngScreenshot_1.pngScreenshot_2.pngScreenshot_3.png

TOPICS
Bug , Draw and design

Views

353

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 05, 2021 May 05, 2021
There are a couple of things you can try: Increase the Pathfinder precision (set a very small number) in the Pathfinder panel options. But I suspect GPU/CPU preview problems. Try if switching between the two helps: Cmd-E or Ctrl-E

Likes

Translate

Translate
Adobe Community Professional ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

There are a couple of things you can try:

Increase the Pathfinder precision (set a very small number) in the Pathfinder panel options.

But I suspect GPU/CPU preview problems. Try if switching between the two helps: Cmd-E or Ctrl-E

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

Ctrl-E fixed it. Holy moly that felt good. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Do you find it runs slow in CPU preview and has your GPU preview been resovled? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Hi, this isnt a fix as CPU preview is REALLY slow to work in. So what is the other option please? I have also reduced precision to its lowest and no change. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

GPU preview is fast but not always accurate. I work in GPU preview. If you don't trust the GPU preview, quickly switching between GPU/CPU will confirm if it is just a preview artifact.

It will not show in print or export.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2022 May 11, 2022

Copy link to clipboard

Copied

LATEST

True it's slower,  but at least I can check what it really looks like. I would prefer that GPU preview was more accurate though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines