• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Auto-Kerning on selection not allowed, since when!?!!

New Here ,
Nov 06, 2017 Nov 06, 2017

Copy link to clipboard

Copied

The newest version of Adobe Illustrator seems to have a problem with auto/optically kerning my font's. Can someone tell me if something's broken or if I did something wrong. It seems like something is broken because I can't even click ok to clear the alert that pops up. This is a screen grab of the error I am getting. I totally understand what it is saying I have just never had this problem before in the old Illustrator.

I don't even get a chance to hover over the auto selection and this pops up.Screen Shot 2017-11-06 at 3.33.05 PM.png

Views

10.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Dec 12, 2017 Dec 12, 2017

We have a fix and is available in the pre-release build. Please visit http://adobe.ly/1Q3rCPI and get the latest build titled Adobe Illustrator CC 22.0.2  - Hot Fix.

This build is of production quality. Please feel free to use / recommend it for your day to day activity.

Warm Regards,

Ashutosh Chaturvedi | Sr. Quality Engineering Manager – Illustrator

Votes

Translate

Translate
Community Expert ,
Nov 06, 2017 Nov 06, 2017

Copy link to clipboard

Copied

Hi. Please let us know which operating system you're using. For me, on MacOS 10.12.6 Sierra, it works just as expected:


Adobe Community Expert / Adobe Certified Instructor

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 06, 2017 Nov 06, 2017

Copy link to clipboard

Copied

You are highlighting characters rather than selecting them where you see the baseline. You need to press escape in order to get out of this and yes it happens to me as well. This did not happen in older versions of Illustrator, but you are supposed to select, not highlight the text when changing the auto-kerning/optical/metrics. You will get this same waring if you highlight individual letters that you are trying to kern, even in older versions of Illustrator.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Try manually kerning your type first and try to change to Auto or Optical Kern. Let me know if that works, cause you could be on to something.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2017 Nov 11, 2017

Copy link to clipboard

Copied

Did you happen to figure this out? I paste graphs from Excel into Illustrator and have always used the Auto or Optical Kern option. With this update 22.0.1, I can't do it no matter how I select the type. I'm getting the same error message you received and extremely frustrated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2017 Nov 11, 2017

Copy link to clipboard

Copied

So. I manually kerned some letters, and then I went to click the Auto, Metrics, or Optical button to reset. I have not been able to find a way to reverse my manual kern by clicking the obvious buttons. My best solution so far is reverting to ver 21 of Adobe until they have this sorted.

The reason I don't think this is some new feature or possible an OS is because when I open Photoshop, InDesign and even After Effects the option to return to a preset kern works.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2017 Nov 11, 2017

Copy link to clipboard

Copied

So in short, I haven't been able to find a fix except choosing a legacy version of the software.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2017 Nov 11, 2017

Copy link to clipboard

Copied

Thank you.

I did find that this has been reported as a bug to Illustrator and as of Oct. 26, Adobe is looking into the issue.

A workaround posted by Ankit from the Illustrator team:

Thank you for reporting the issue.This is Under review.
We are able to reproduce this issue in house.
I would request you to use the below steps and see if this resolves your issue as a workaround:
Step1: Press Escape,Spacebar or Enter Return to dismiss the dialog.
Step 2: Set cursor in field, type 0, then use dropdown to choose Auto.

Regards
Ankit Goyal

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

We have a fix and is available in the pre-release build. Please visit http://adobe.ly/1Q3rCPI and get the latest build titled Adobe Illustrator CC 22.0.2  - Hot Fix.

This build is of production quality. Please feel free to use / recommend it for your day to day activity.

Warm Regards,

Ashutosh Chaturvedi | Sr. Quality Engineering Manager – Illustrator

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

I'm sorry to say, this is still an issue and its 3 years later... I was using illustrator regularly earlier this year (On a mac) and wasn't having any problems. Now I'm on a PC and I've just started up using illustrator again, How can I fix this?

(added my own screenshot)Untitled.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

still an issue, 3 more years.... Just happened to me. 😞 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

Exactly what did you select?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

Hello @captainredbeard,

 

We apologize for any frustration you may be experiencing with technical issues. Could you please provide us with more information such as the specific version of your OS/Illustrator, system configuration (CPU/GPU/Memory), a sample file (https://community.adobe.com/t5/illustrator-discussions/share-your-files-in-6-simple-steps/td-p/12967...), and a screen recording of the issue (accessible through https://community.adobe.com/t5/illustrator-discussions/screen-record-an-issue-on-windows-amp-macos-f...)? This will allow us to investigate the matter further. We appreciate your cooperation and look forward to hearing back from you.

 

Thanks,

Anubhav

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

LATEST

It can only be Auto, Optical or Metrics for an extended selection. If you try to enter a value you will get that message.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines