CEPHTML Engine CPU usage Illustrator Mac 2021

Community Beginner ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

Of late I have noticed several errors of CEPHTML Engine unexpectedly quit, or it going into CPU overdrive and sucking an entire CPU, and since I'm still stuck on a crappy Intel chip, this puts the fans into overdrive. Killing the process in Activity Monitor did the trick, quitting Illustrator alone was insufficient.

 

I found this Adobe support note:

https://helpx.adobe.com/in/x-productkb/global/high_cpu_usage_cephtmlengine.html

 

I've tried the first fix, but the note only refers to Illustrator 2015, despite being updated in 2021, so I'm guessing the second fix, which recommends replacing the com.adobe.DesignLibraries.angular component of the app with downloaded content, is probably out of date, but I'm not sure!

 

Does anyone know if this works? And Adobe Support, why is this issue still not fixed 6 years later?

TOPICS
Bug , Performance

Views

117

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry about the trouble. You can try the suggestion shared on the help article. If that doesn't help you may try creating a new user Account and reinstall Illustrator from the Creative Cloud Desktop app there. Let us know how it goes.

 

We will be looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

Hi Anshul, my specific question was: where's the updated version of this document? I don't want to install a 2015 library replacement onto a 2021 installatin of Illustrator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 12, 2021 Oct 12, 2021

Copy link to clipboard

Copied

Thank you for clarifying your query. That help article was updated last on 16 May 2021. However, you can try that library as it is a general library, and the location address mentioned are just sample addresses for older CC versions. Also, you may try creating a new user account as mentioned above and see if that helps with high CPU usage due to CEPHtmlEngine.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

Did you ever try Adobe's fix? I'm aslo very skeptical that a fix first published in 2015 is still relevant, even if it says it was updated on Jan 4, 2022. There are files in the designated folders within the apps that do not have replacements in the DL224.zip package. Are we supposed to delete everything from the folders in the app and then replace with the full contents of DL224.zip? The instructions need clarification.

 

Elsewhere on here someone mentioned just fully deleting the CEP folder from inside the app and it's working for me, though I'm not super confident in it. All apps apear to be able to function without the CEP folders, but are they missing some core functionality? What does the CEPHtmlEngine even do? I'm considering restoring the CEP folders and try Adobe's fix mentioned above just to see if there's a difference.

 

I just started getting this problem a few days ago in InDesign and then in Illustrator and Photoshop. A coworker's slightly older MBP had been overheating from this issue so consistently that the battery blew and popped the whole body case open. This is a seven year old issue (minimum) and very clearly shows that Adobe doesn't care. If they did then they'd fix it.

 

MacBook Pro Intel 16-inch 2019 / macOS 12.1 / Most current versions of Adobe apps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

Hi Adam, sorry to say I don't think it ever got resolved (and I don't know
why this only just came to my inbox when it appears you posted in
September!) but it was resolved by replacing my Macbook Pro 2019 Intel with
a Macbook Pro M1 2020 - total game changer!

Sorry that's not terribly helpful!

Cheers,
Mike

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

LATEST

Glad to hear it's not an issue for you any more!

 

I mentioned that all programs seemed to function without the CEP folder, but I decided to restore them and do the content replacement fix that Adobe outlines here. After navigating to the respective folders for Ps / Id / Ai and replacing the contents with that of DL 2.2.4 I am no longer getting overheating issues due to CEPHtmlEngine. There are a ton of processes open (see screenshot), but they aren't getting stuck on 100% CPU usage and they go away when you quit the programs.

 

I also tried quitting the parent CEPHtmlEngine processes after replacing the folder contents, just to see what would happen. Adobe apps already open continued to function, but the CC Libraries panel would close. When I tried to open the panel it would show the last library I had used, but none of the interface was working. Quit and reopen the app and the CEPHtmlEngine processes would start again and the CC Library panels functioned as usual. I will likely just leave the CEP processes alone as I use the CC Libraries frequently.

 

Here's hoping this fix stays fixed and that Adobe actually addresses this issue in the next release.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines