Choppy import from Illustrator to Photoshop

New Here ,
Mar 12, 2022 Mar 12, 2022

Copy link to clipboard

Copied

Hello everyone, I'm having a problem and I can't find an answer anywhere online.
I color all my illustrations in Illustrator with the Live paint tool, and then I import everything in Photoshop for the shading. However, it started looking really choppy, like the paths are not closed, even though everything looks normal in Illustrator. Does anybody know how I can fix this?

TOPICS
How to , Import and export , Tools

Views

74

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2022 Mar 12, 2022

Copy link to clipboard

Copied

Did you try Object > Live Paint. Expand before importing in Photoshop?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2022 Mar 12, 2022

Copy link to clipboard

Copied

And do you import as Smart Object? At what resolution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2022 Mar 12, 2022

Copy link to clipboard

Copied

LATEST

The issue arises because of the way Photoshop rasterizes your artwork (I've been complaining about this for ages). It's rendering each object in your file separately (in much the way a RIP would), starting with the bottom-most object all the way up to the top-most, and it adds anti-aliasing on each render. Where this is a problem for you is that your colour areas aren't overlapping, they're butting up against each other, so the anti-aliasing is causing a smidgen of transprency around the edge of each area, allowing what's behind it to show through.

The lower the resolution of your document, the more it'll show.

One way to get around this (since there are no options in PS to change the way it rasterizes), is to export your artwork from AI as a PSD file, making sure that your resolution is appropriate (or HIGHER than you need, 'cause you can always scale down later) and that anti-aliasing is set to Art Optimized.

You will see a huge diffrence.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines