• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
1

Exporting as PNG in Illustrator won't export as transparent

New Here ,
Mar 22, 2019 Mar 22, 2019

Copy link to clipboard

Copied

Hello Everyone, I was hoping to get some assistance.

Right now I'm in the process of editing some company logos and I need to export them as PNG's with different backgrounds.

I make my edits with the logo and make sure that there is no background by showing the transparency grid:Adobe Issue 3.PNG

As shown above there is no background behind the logo, so when I go to export the AI file, I select export as -> then select PNG from the file list -> I don't select anything from the artboards option:

Adobe Issue 1.PNG

Then I get the preview in Adobe Illustrator for my export, I select transparent from the drop down and it shows in the preview that it will show up transparent:

adobe issue 2.PNG

But when I go to the file, no matter what I open it with, it has a white background only. This also happens when I select black background. Adobe Issue 4.PNG

Any help would be hugely appreciated because this is very frustrating.

Views

3.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Mar 31, 2022 Mar 31, 2022

It's working on my system--however, it didn't work the first time even though the settings were set to "Transparent". The second time, I changed the background to white and then back to transparent, which worked. 

Votes

Translate

Translate
New Here , Apr 25, 2022 Apr 25, 2022

Hi, if you have still this issue - disable an Overprint Preview (Alt + Shift + Ctrl + Y) in View tab before you export png with transparency.

Votes

Translate

Translate
Community Expert ,
Mar 22, 2019 Mar 22, 2019

Copy link to clipboard

Copied

kyler,

For crisp and clear artwork, it is important that you create the PNG at exactly the final pixel x pixel size, and the safest way to do that is to use the Legacy Save for Web because you can see the Image Size.

And that may rid you of the issue as a pleasant side effect.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2019 Mar 22, 2019

Copy link to clipboard

Copied

the white background even appears when I do the save for web option when transparent is selected and the preview shows it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 22, 2019 Mar 22, 2019

Copy link to clipboard

Copied

  schrieb

the white background even appears when I do the save for web option when transparent is selected and the preview shows it.

Which application do you use to view your PNGs?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

i have the same issue, tried all exports, same as you the transparancy shows on the preview but white backround when exported. Other things ive tried include opening in photoshop which shows as transparent and yet when saved as is a white backround. Have tried all illustrators exports, use the gear wheel to select transparent but no luck. Opened the PNG in all sorts of different software but still a white backround, i even opened In design and dropped it on a photo but its still white, going for a drink now , good luck kroy2393 .

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 22, 2019 Mar 22, 2019

Copy link to clipboard

Copied

What do you open it with? Did you try Photoshop?

Did you try to place the PNG in Illustrator on a colored background?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

Hi there, did you ever figure out a solution? I'm having the same issue now and it's super frustrating.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

It's working on my system--however, it didn't work the first time even though the settings were set to "Transparent". The second time, I changed the background to white and then back to transparent, which worked. 

David Creamer: Community Expert, Adobe Certified Instructor, and Adobe Certified Expert (since 1995)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Hi, if you have still this issue - disable an Overprint Preview (Alt + Shift + Ctrl + Y) in View tab before you export png with transparency.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

Yes, set it in Pixel Preview instead.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2023 Feb 03, 2023

Copy link to clipboard

Copied

LATEST

I had this same problem too. When I exported from Illustrator, the preview was fine but when I opened the file, the background was black not transparent. So I opened in photoshop, background transparent, beautiful!! But resaved as a  out of Photoshop? Black background again. So I ran a basic test print, no black background printed, which tells me...the problem is NOT the Adobe software, but the Apple Preview software we use to view the PNG file.

Easy fix!!

Go to Preview->Preferences->General tab, you'll see background color, click the rectangle of the background color swatch so it has a white box around it, and when the color changer pops up? Slide that opacity slider all the way to the left. Make sure you have the black background PNG file open when you do this and it will end up changing in tandem with you adjusting the slider and you'll see a white background, but its actually transparent. I hope this helps everyone experiencing issues. Sure is a lot easier than some of the solutions posted here. Good luck!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines