Fill colour is displayed outside of compound path

New Here ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

Hi,

 

I get this strange display error showing fill colour outside of the path of an object I am working on (please see attached image in the top of the letters P, E and N). The text is around 1 mm (0.04 in) in height and this display issue changes when I enlarge it to a larger size (it still remains, but is less visible as the fill does not stretch as far outside the path), so it seems to be related to the size of the paths. The text is not white paths placed on top of the purple rectangle, but rather a subtraction in the rectangle using the pathfinder.

 

I have tried to to expand the paths, unite it with the pathfinder and I have also tried to compound the paths. None of those actions solves it. I don't know if it's very visible in the attached image, but the edge of the fill that ends up outside of the path is not compltely smooth, but rather have a pixelated transition as if you would draw a diagonal line with the pen tool in Photoshop (that's the best explanation I can think of), so it looks more like it is an software issue as edges normally never display like this in Illustrator otherwise.

 

I have attached the document file so you may have a closer look (I received a content type error whe...

 

I just updated Illustrator to 25.4.1, and the issue still remains. One of the attached images shows what computer I am using if that have any relevance. 

 

AlexanderNorrthon_1-1639394756773.png

 

AlexanderNorrthon_0-1639392057348.png

AlexanderNorrthon_3-1639395366138.png

 

 

 

TOPICS
Bug , Performance

Views

60

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

Does turning off GPU preview (View > Preview on CPU) affect it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

Yes, that was the solution I found in another thread just when you wrote this. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

I found this thread where someone suggested that I should change View to "View using CPU", and that actually solved this. 

https://community.adobe.com/t5/illustrator-discussions/odd-fills-showing-up-outside-of-path-points/t...

 

But do anyone know what it happens when I view using GPU?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

LATEST

It happens because it's a bug in the GPU preview. If there's a more specific 'why' than that I would love to hear it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines