• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

How to exclude visible layers from export

Participant ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

Is there a way to exclude layers from export?

Certain layers are only used as visual guides and should be visible but not exported.

Application: We create tray bar icons and use a bitmap image of the Windows tray as a visual guidance:

tray.png

However, the layer option lack an option to be "excluded from export":

layer.png

Any idea, except toggling layer visibility over and over again?

Views

5.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 26, 2017 Jun 26, 2017

seems like a bug/oversight. exporting to PNG, using either Export for Screens or Export As, template layers are included.

JPEGs seem to work correctly in both; template layers are excluded

non-printing has no effect on export, to raster files at least.

the old Save for Web dialog seems to work correctly for both JPEG and PNG (template layers are excluded).

Likes

Translate

Translate
Community Expert ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

make them into template layers. i don't know the german translation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

Doesn't work. Template layers seem also to be exported if set visible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

how are you exporting things, and to what file type?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

File > Export > Export for displays

export.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

seems like a bug/oversight. exporting to PNG, using either Export for Screens or Export As, template layers are included.

JPEGs seem to work correctly in both; template layers are excluded

non-printing has no effect on export, to raster files at least.

the old Save for Web dialog seems to work correctly for both JPEG and PNG (template layers are excluded).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

Thanks, will issue a bug report.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 25, 2020 Apr 25, 2020

Copy link to clipboard

Copied

I see that this issue is still not resolved, just tried exporting a PNG with template layer used and it was included… any updates on other methods that might work?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

What happens when you make the layer non-printing?

Also, confirm that the objects are actually on the correct layers.

Can you just turn off visibility when you export to an image?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 26, 2017 Jun 26, 2017

Copy link to clipboard

Copied

What are you abel to do different to the items that you do not want to export.

  1. Lock what you do tho want to export
  2. Select All
  3. File >> Export Selected

Setting the layers to not print will work only for .PDF if you change this setting to visible layers, and meal the layers you want hidden to no print. Yes this work son .pdf the stein is not labeled well.

Screen Shot 2017-06-26 at 9.05.31 AM.png

You could then run a batch action in Photoshop to convert .pdf to bitmapped format you like.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

LATEST

I am using Illustrator 2023. If you want to see a layer on your canvas but don't want it to show when you print then try this (which worked for me): 

 

1) Double Click Layer (you should then see "Layer Options"

2.) Uncheck "Print". 

If you also don't want to see your layer when exporting file (to screen), then I would try this (which also worked fine for me): 

1) Double Click Layer (you should then see "Layer Options"
2.) Check "Templates". Make sure "Dim Images" is unchecked.


This will make layer non-printable and also will not export layer. 

 

In German this would be "Vorlage" (Template) and "Drucken" (Print) and "Bilder abblenden auf"  (Dim Images).

Hope that helps. 

NOTE: There is a bug in Illustrator when checking "Templates" and unchecking "Dim Images". For some reason, when you reopen the "Layer Option" dialoque, it will have "Dim Images" checked again and set to 50%. It keeps bouncing back. But it does seem to keep the layer visibility at 100%. You can also set Dim to 100%, that will work as well. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines