How to fit an artboard to an object with a drop shadow?

Community Beginner ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

I'm trying to export a vector object with the dropshadow included. When I select Object<Artboards<Fit to Selected Art" the artboard cuts off the drop shadow. Is there any way to have it include the drop shadow?

 

Thank you

TOPICS
How to , Import and export

Views

128

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Feb 14, 2022 Feb 14, 2022
Aimee, How about your ticking Use Preview Bounds in the General Preferences?

Likes

Translate

Translate
Adobe Community Professional ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

I would make a copy/paste in place of the object and rasterize it. With the rasterized copy still selected, do your Fit To Selected Art, then delete the copy. 

 

BUT

I just tried it in the latest version and Fit To Selected Art doesn't chop the shadow. What version are you running?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

Have you tried to Object>Expand Appearance? It will make the drop shadow basically a separate rasterized object grouped with the original shape. It can be selected and therefore you should be able to select it as what you want to fit the the artboard.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

Aimee,

 

How about your ticking Use Preview Bounds in the General Preferences?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

quote

How about your ticking Use Preview Bounds in the General Preferences?

 

Ah yes, I often forget about that because I pretty much never turn it on. But apparently somehow it was enabled when I tried it earlier, and that's why it worked for me without chopping the shadow. Thanks Jacob.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

LATEST

That worked!! Thank you so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

I thought about the Preview bounds too, but even without them I get the desired behaviour, in 2022 and 2021.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

As Ton already said, in the latest versions of Illustrator it should work with or without the Preview Bounds option.

 

It used to be an issue in some older Illustrator versions, as far as I can remember.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

It seems that all the answers here are governed by different (lacks of) version assumptions.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

In the latest version of Illustrator there are still some issues if appearance attributes from the Effect menu are applied at higher object levels (Group level (including clipping groups), Layer level and Sublayer level).

 

In those cases the additional spaces are still ignored by the Fit to Artboard Bounds or Fit to Selected Art commands.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines