Illustrator 2019 - File Type Association (WIN) *Bug*?

New Here ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

No matter what I try I cannot change the default file type .ai to always open/be associated with Illustrator 2019.

The files always show up as blank icons and I have to now always right click and 'open with' and choose Illustrator 2019.

Bug with the new updated?

Views

13.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 21, 2018 Nov 21, 2018
Hi there,All the users on this thread have a similar issue but not the same. Every situation here has a different fix.XD defaulting to AI on Windows Please update to latest version of XD (13.1.32) to resolve the issue.PS defaulting to AI on MAC Please update to latest version of Illustrator (23.0.1) to solve this issue.For other issues: Please try these steps to correct general File association errors: How to fix broken file type associations for Creative Cloud appsIf you have tried all of these...

Likes

Translate

Translate
replies 108 Replies 108
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

I´ve installed Illustrator and XD in another pc with windows 10 (as the first one), and the association isn´t broken.

I will try to find why and report back with my findings.

[The last solution doesn´t work]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Hi there,

In case it is showing XD as the default app for .ai files then please uninstall both XD and Illustrator.

Install Illustrator first and then install XD this should fix the issue.

In case it is showing blank or Coral Draw then try above-mentioned methods.

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Just did that. The problem persist.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Same problem! Persists after all the procedures you have adviced...
Need a fix really fast!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Hi,

I guess there are more People out there with the same Problem.

Please get a hotfix for that and not a regedit….

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Immediately noticed this issue yesterday after updating. Have gone through every suggestion on this thread multiple times to no avail. Every attempt to re-associate the file type is ignored. I have uninstalled the programs, restarted my computer, and reinstalled Illustrator first, then XD yet the associated type for .ai files is still XD.  This isn't a deal breaker, but quite the inconvenience for the time being as I use these files every day for work and have to consistently go through extra steps just to open my work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Same problem here, none of the solutions suggested so far work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Had the same problem on my PC. Fixed it by installing Illustrator 22 from the CC Apps panel, removing 23, then upgrading to 23. Seems to be working fine now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

johnp42  wrote

Had the same problem on my PC. Fixed it by installing Illustrator 22 from the CC Apps panel, removing 23, then upgrading to 23. Seems to be working fine now.

Thank you for posting the workaround and helping the community. In windows world the last program to associate to a file type wins. I am expecting a simple uninstall - install of version 23.0 should also have worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Had the same problem too (Win 10), can confirm that uninstalling and reinstalling Illustrator 23 solved it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

This worked for me. I had to wait a moment after the the re-install of 23 for the defaults to auto update in settings and for individual .ai files to show their icons. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

I'm solved same problem this way.

Open regedit as admin. Find this path "C:\Program Files\Adobe\Adobe Illustrator CS6 (64 Bit)\Support Files\Contents\Windows\Illustrator.exe" and replace all matched path as "C:\Program Files\Adobe\Adobe Illustrator CC 2019\Support Files\Contents\Windows\Illustrator.exe"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Hi there,

It is indeed a serious and impacting issue. As a workaround, would it help you to Open Illustrator first and the open Ai files from within Illustrator?

To help narrowing down the issue, those having problems on Windows, please let us know the Windows version you are using? I found that on Win 10 RS4 V1803 b17134.345  for example I cannot change the associate app of an bmp file  to Notepad.

Thank you,

Letitia Antohe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Windows 10 Pro v1803 b17134.345

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Windows 10 Pro

V1803

17134.345

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Windows 10 Enterprise 1803 17134.345

My laptop is running the same Windows version and it didn't have this issue with Illustrator files after upgrading to 23.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Same problem, same Windows 10 build - everything above hasn't worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Starting to see this issue in other areas as well. Photoshop files have the correct icon, but filetype is not associated with Photoshop program. Looking at the properties of the Photoshop file shows "Unknown application" and I am unable to change the program associated with it. It is similar to the issues with Illustrator, only the icon is correct. What is going on? Something is broken somewhere and I am hoping there is a fix soon. My work flow has greatly decreased due to these issues across the board!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Thanks for noticing that. I rolled back PS as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

I've tried the "Correct Answer" but it is still a problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

I am reporting the same problem. The biggest obstacle are smart objects in PS that can not be opened in AI. PS does not associate the program in which the object is to be opened. It completely blocks the work of the team. All the above solutions do not work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Same here. Affinity or XD were taking over Illustrator no matter what. I went back to the 2018 version and I'm just gonna wait for a while to install the 2019 one, after a few more updates. I feel like Adobe only cares about the Apple users and doesn't five a damn about Windows users, hence the myth: "Oh, but you need an iMac to do graphic design...Macs are sooo much better". Well of course they are when the software rolls out on Windows untested (or so it might seem).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Found an easy solution

Open the registry editor and navigate to HKEY_CLASSES_ROOT\.ai

The value of the Default key is Adobe.Illustrator.22. After chaning it to Adobe.Illustrator.23 and setting Illustrator as the default program the file association worked correctly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

it works! Thanks alexanderas

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

however, it does not really work AI files have been assigned to Illustrator 2019 but still smart objects from PS do not want to open in AI

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines