Illustrator 26.4 Font issues

Community Beginner ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

Hi I've just updated Illustrator to 26.4 and I'l experiencing issues with my files. I have certain Fonts that I use as brand fonts in my work and now only part of the font family is working, for instance I'm using a Book version of the font and it works fine, but If I change it to Bold the Type just disapears with no preview, then trying to select the type that has dissapeared it has changed each character to different fonts, Rendaring my files completely broken and unusable. I've tried running validation on all my font, unloading and reloading them up in Font Book, re starting illustrator and unistalling illustrator, reset prefrences, looked at Plugin files all to no success. This has completely disabled my work flow and I need to get this work out so any help here would be appreciated!!!

 

TOPICS
Bug , Type

Views

218

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jul 28, 2022 Jul 28, 2022

Hi All

An update on my issue - I'm working from home today and illustrator has updated to 26.4 on my home mac which is a newer model and I'm having no issues as before. I've opend the same file and using the same fonts with font book. So that must mean the problem is with my Machine at work which is a late 2014 imac. I'm running the same OS on both machines. Work machine is MacOS Catalina 10.15.7 on an imac5K late2014, 3.5gb Quad-Core, i5 processor, 32gb Memory. Home Machine is MacOS Catalina 10.

...

Likes

Translate

Translate
Community Beginner ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

I Just unistalled 26.4 and reinstalled the older version 26.3.1 and My files are back to normal....... Fonts all working fine. So Don't know about this New Update..... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

Can you upload a sample file using typefaces in question? 

 

and what are the typefaces and where did they come from? Local/Cloud, etc?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Hi Brad

Thanks for replying. I've uploaded a sample file (Test.ai). I've dropped in some outlined and live artwork and a list of the fonts bellow that I was having issues with. The fonts are loaded up locally on my Mac using Font book for management. It was mainly the bold version of the font family I was having problems with. All are working fine in Indesign/Photoshop etc. I've since unistalled illustrator 26.4 and reverted back to 26.3.1 and not having the problem on the older version. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

I just happened to have the typeface used, and I'm having no issues with it with 26.4 (I'm on Mac as well, albeit Big Sur as this moment. I will try Monterey in a bit), so I have no insight at this point.

I assume the fonts were purchased from a legitimate source?

Since you are using Font Book and not a third party manager, you might want to clear your font caches in case something got corrupted there.

Read this page foir info on that:

https://helpx.adobe.com/ca/x-productkb/global/troubleshoot-fonts-mac-os-x.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Are you by chance using font management?

 

Another user reported an issue with font management not updating correctly, which caused an issue with version 26.4

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Hi Monika
I'm just using Apple's Font Book for font management.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Can you reinstall that font?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Hi @–- FINN -–,

 

We are sorry for the trouble. Another user has reported the same issue. Would you mind sharing a few details along with the ones asked by Monika:

  • Did that happen with the specific document? If yes, would you mind sharing the document with us? You can upload it to the Creative Cloud (https://helpx.adobe.com/in/creative-cloud/help/share.html) and share the download link. We'll check at our end.
  • Are there any changes made to your system after updating to v26.4? For example, any antivirus, system updates, plugins, or web extensions installed.
  • Would you mind confirming the font name & family?

 

We are here to help. We just need more info.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Hi Anshul, Thanks for your help with this.....

To answer your Questions...

• No it wasn't document specific, I first noticed it on existing documents created in older versions, then I tried creating new documents and the result was the same. 

• There were no changes to my system at the time of updating to 26.4. I'm running MacOS Catalina 10.15.7 on an imac5K late2014, 3.5gb Quad-Core, 32gb Memorey.

• Font Family is Neutraface 2 - it is an otf font. Book & Demi seemed to work, the problem kicked off when I changed to Bold. The font would dissapear and when I tried to select it I noticed some really weird things in the Charater Pannel, The Horizintal scale changed to some random number Like 1324.2% and each character changed to different random fonts,(not Neutraface. This issue happened when trying to use Neutraface 2 Text - Bold and Neutraface 2 Condensed - Bold. Once this happened I couldn't fix that particular line of text no matter what I did to try and fix it, It was like it was corrupt.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Hi All

An update on my issue - I'm working from home today and illustrator has updated to 26.4 on my home mac which is a newer model and I'm having no issues as before. I've opend the same file and using the same fonts with font book. So that must mean the problem is with my Machine at work which is a late 2014 imac. I'm running the same OS on both machines. Work machine is MacOS Catalina 10.15.7 on an imac5K late2014, 3.5gb Quad-Core, i5 processor, 32gb Memory. Home Machine is MacOS Catalina 10.15.7 on an imac5K 2017, 4.2gb Quad-Core intel i7, 48gb Memory. Maybe it's a processor issue???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Since all things considered there shouldn't be any difference in your setups, I'm going to say it mught still be a font cache issue on the Catalina, especially if you have been repeadetly moving fonts around; it's easy for the system to get confused.

 

There are a couple utilities that can help you clear font caches. I personally use Cocktail, but Onyx is also good.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 05, 2022 Aug 05, 2022

Copy link to clipboard

Copied

LATEST

Glad to hear that the issue got resolved with the update. Please feel free to reach out if you run into any other questions or issues in the future. We'd be happy to help. Thanks!

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines