Illustrator and Photoshop 2022 EXTREMELY slow

New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Recently updated to the 2022 apps. I use Illustrator and Photoshop at my business. Both have become almost unusable. I'm on Windows 11 with 16GB RAM, i7, nVidia Quadro P400. Every single thing I try to do is extremely laggy, more in Photoshop but also in Illustrator. One thing I did notice when I did this update was the fans on my PC fired up like a jet. Anyone else ran into this and found a solution?

TOPICS
Bug , Performance

Views

2.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , May 20, 2022 May 20, 2022
This will sound super stupid but I pulled my graphcs card out then put it back in and the slowness is now gone. I didn't even clean it, I was intending to take it to a computer store to get it checked... The guy at the store says sometimes they need reseating because they lose contact with the pins or something. Worth a shot.

Likes

Translate

Translate
New Here ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Windows 11 128GB RAM, Ryzen 9 5950x, nVidia RTX 3070Ti.  Performance is terrible.  Moving the mouse over the menu system results in the jankiest movement.  This software has become trash.  Thinking of unsubscribing to Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

By build is very close to yours and the past few update cycles have killed performance. 3+ seconds and a stutter to align items in Illustrator. I'm considering alternatives as well - this is destroying my workflow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

This will sound super stupid but I pulled my graphcs card out then put it back in and the slowness is now gone. I didn't even clean it, I was intending to take it to a computer store to get it checked... The guy at the store says sometimes they need reseating because they lose contact with the pins or something. Worth a shot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

LATEST

Thanks, I will give it a shot. I'll go rent a forklift to remove the 300lb RTX card.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

Hi @patricks44769834 & @notacyborg

 

Sorry about the trouble. I would suggest you both try the following steps and let us know how it goes:

  • Rename the CEP folder to CEP.old from the following location:
    C:\Program Files (x86)\Common Files\Adobe
  • If that doesn't help, rename the UXP folder to UXP.old in the following locations:
    C:\Program Files (x86)\Common Files\Adobe
    C:\Program Files\Common Files\Adobe\
  • If that doesn't help either, uninstall the application using the CC Cleaner tool and restart the system (most important) reinstall from the Creative Cloud Desktop app.

 

Let us know how it goes. We'll be looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

Latest Adobe updates seemed to fix it for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Hi 

 

Eversince I updaed adobe I have horrable performans issue - Moving the mouse over the menu system results in the jankiest movement mouse is laging a lot... help 

 

I have 64GB DDR 4 Speed 3600mhz ram Intel i9 10980XE and grafic card RTX 3090 24GB DDR5

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Hi @Hakan5E0E,

 

Sorry about the trouble. I would like to know if you have tried the steps mentioned above, especially the AMD article? Note: The steps on this AMD help article are not relevant to AMD or Intel CPU. You must try the steps suggested there.

 

If that doesn't help, please make sure GPU performance is enabled in Illustrator Preferences. If you are still facing the issue, you may try the steps suggested in this community post (https://community.adobe.com/t5/illustrator/resolve-slow-performance-and-unexpected-behaviors-in-illu...). If that doesn't help either then, I'd recommend you to connect with our technical support team (https://helpx.adobe.com/contact.html?rghtup=autoOpen). The team here would be able to perform remote troubleshooting and assist you accordingly.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

What do these folders do or have in them and how can I find out what mine have so I don't delete anything I need/use? I have the same problem, both programs are unusable and lag for well over 3 seconds for every one command in IL, PS is even worse. It does it for everything, even if that's clicking a tool or pressing an arrow key and if I let go of say control it doesn't apply the action like control was pressed resulting in weird things happening.

 

This is a recent change. I notice cloud says it updated my programs 3 days ago and I wonder if this is a new bug or error causing this. Also I do not have the second folder so unsure if that's moved? I'm not going to create a new user account that's crazy.....do you have any updated instructions I can give a go? I will try uninstalling and reinstalling also.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

Uninstalling and reinstalling hasn't worked. Updating my nVidia drivers didn't help either :(.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

Resetting preferences and cleaning didn't work. I was about to give up when I decided to uncheck the only performance option in IL which was GPU performance. It's working better but still lagging. What does this mean? My graphics card is comptible. Can you please help me fix this? 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

Being unable to edit my posts here is a little annoying lol.

 

To be clear it's picking up and moving groups of objects better but it's taking 5 seconds to "drop" them where the cursor takes them. Before it took 3 seconds to pick up, to move, and to drop.....so when I say better it's not really great and still unusable.

 

It's not my file, this happens with all files new or old. It does seem to be okay at first then goes sour, regardless of the file open (whether it's big or small).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

Did you manage to fix it? The performance is horrible for me as well on Illustrator... scrolling, zooming out and in, using the menus... EVERYTHING is just unusable.


My specs: i9 9900KF / 64 GB DDR4 / Nvidia RTX 2060 6GB.


It was everything normal before updating to 2022 version. I tried all steps listed above from the Adobe support...

Nothing changes, thinking of downgrading to a older version of illustrator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

Hello!

I have not. Interestingly I have the same card but worse PC Specs, but it's always run beautifully for me.

 

So there were some developments. Firstly I think the latest driver was corrupt for me as it didn't uninstall the old version and was crashing the Nvidia control panel and the GeForce Experience app showed both last two installed.... so I had to go and wipe all graphics drivers and reinstall this one in safe mode. Secondly I am not 100% certain but I suspect my graphics card is broken. If I turn off all noisemakers (fan, aircon, etc) and do a userbenchmark test when it does the 3D animation I hear noises like faint metal screaming but the fans move just fine, I think the fans can't rev up leading to this issue.

 

So I reinstalled the drivers after that and deleted all my Nvidia and IL preferences which is going to really hurt later on and it did get better but it's still unusable....I don't know if it's actually IL and PS at this point...I'm really thinking it's Nvidia drivers, or my card is broken. But I could be wrong. I'll know in a week if it's my card. I'll let you know. I encourage you to clean yours and maybe double check it's not failed too. If it has please let me know. Mine is only 2 years old, under a 3 year warranty. Also for what it's worth there was a recent Microsoft and Nvidia update and either or both may have played a roll in this....so there's a lot of things to troubleshoot :(.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

Hi @Besnardm@paulosilvano,

 

I am sorry to hear about your experience. I would request you to share a few more details like:

  • The exact version of OS & Illustrator
  • Does Illustrator lag or slow down while working on a specific file or all?
  • Does this happen while working on new files or old files?
  • Where are you saving the files (Network Drive/ System HDD/ Shared Folder on System/ External HDD)?
  • Are there any recent changes made to your system? For example, any antivirus, system updates, plugins, or web extensions installed recently.

 

We are here to help. We just need more information.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines