Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Illustrator default RGB black is gray

Community Beginner ,
Oct 14, 2009 Oct 14, 2009

Copy link to clipboard

Copied

Group, I just got CS4 and I am working in RGB and when I hit D to set default colors the black is not black... It is a dark grey.  Basically the same if you take something that is black in a CMYK document and paste it into an RGB document.  The black becomes gray.  Can't figure out what color setting to change to set blacks as "Rich Black."  Under Edit - Preferences - Appearance of black, it is set to Rich Black.

Any help would be greatly appreciated.

Views

47.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Oct 14, 2009 Oct 14, 2009

Copy link to clipboard

Copied

"D" sets default stroke and fill (Unlike Photoshop)

Define a new swatch R0 G0 B0. That is RGB black.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 28, 2011 Apr 28, 2011

Copy link to clipboard

Copied

I'm sure the OP is aware of what the "D" key does - hence his question.

The question refers to figuring out how to make the black that goes into the stroke swatch when you press "D" RGB 0,0,0 rather than RGB 35,31,32.

The answer is to change the colour inside the Black swatch. If you look at your Swatches palette, you will see that the fourth swatch in is Black. By default, Illustrator ships with this Black being equivalent to CMYK 0,0,0,100, which makes sense if you're working in CMYK a lot.

If you find yourself doing web work and you wish to change the default Black to RGB 0,0,0 just edit this swatch colour.

To do this on a one-off basis (you have to repeat this for each document), then just double-click the swatch in the Swatches palette and edit the colour. It's not a Global colour swatch by default, so this will NOT change any existing items in your document that have been filled with that colour. However, if you press "D" now on your keyboard, your default stroke will get set to RGB 0,0,0 black.

If you're doing this often, you'll want to set this up as your default colour going forward - every time you open a new document. To do this, you need to edit the default document profile. This process is outlined in Adobe KB article documented here: http://kb2.adobe.com/cps/400/kb400732.html

But for convenience, I'm reposting the information (note these are an AI CS3 instructions, so be sure to check for your version):

To create a custom New Document Profile

To create a custom document profile in Illustrator CS3:

  1. Open the New Document Profile file you want to customize in the New Document Profiles folder located in the below directories.
    • Windows: Documents and Settings\(User)\Application Data\Adobe\Adobe Illustrator CS3 Settings.
    • Mac OS: Users\(User)\Library\Application Support\Adobe\Adobe Illustrator CS3
  2. Delete any existing swatches, graphic styles, brushes, or symbols you dont want to retain.
  3. Do any of the following:
    • Create any colors, patterns, and gradients you want, and save them as swatches. You can also import swatches using the Swatch Libraries command and then move the swatches you want in the Document Profile file into the default Swatches panel.
    • Save any graph designs that you want available in your files using the Graph Design dialog box.
    • Create any graphic styles you want and save them to the Graphic Styles panel.
    • Create any brushes you want and save them to the Brushes panel.
    • Create any symbols you want and save them to the Symbols panel.
    • Select the options you want as default settings from the following: View preferences (from the View menu), ruler origins, page origins, print settings (in the Print dialog box, File > Print), and actions.
  4. Save the Document Profile file and restart Illustrator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2011 Sep 28, 2011

Copy link to clipboard

Copied

Thank you for the detailed response. I found that the only way I could resave any existing gradients with black so that they re-opened with a proper 0,0,0 rgb black was to delete the gradients and recreate them from scratch for the new document profile. Maybe I missed something.

This whole black issue is very annoying. And print-centric.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 28, 2011 Sep 28, 2011

Copy link to clipboard

Copied

This happens when you open a CMYK document, then change the color mode to RGB. If you start with an RGB document profile RGB Black is 0,0,0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2011 Sep 28, 2011

Copy link to clipboard

Copied

I was starting from modifying the "Basic RGB" new document profile. The black swatch in that profile is rgb 0,0,0 but not the basic black gradient that opens in the swatches panel.

The black gradients are made with that black in which the RGB numbers are around 30. I couldn't get it to stick at 0,0,0 black in the gradient swatch for a new profile until I actually deleted the gradient and built it from scratch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2011 Sep 29, 2011

Copy link to clipboard

Copied

THe black in the gradients actually is a grayscale swatch, which converts to a dark grey in RGB.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

Right, I feel like it never used to do that and I just started noticing it and its driving me insaine

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

Sooooo I have a surface book 3 (windows) and changing the swatches didnt work, is there anything else I can do

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

LATEST

If your issue is with a newer version, then please create a new thread, because things have changed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2014 Mar 26, 2014

Copy link to clipboard

Copied

♥ Hope this will help!

reset.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 23, 2014 Jan 23, 2014

Copy link to clipboard

Copied

Does anyone have a solution? I'm having this same problem (with CS3) and it's very annoying.

I think aside from Photoshop and Reader, Adobe products are VERY unintuitive and error-prone. And this is coming from a professional designer... and usability engineer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 24, 2014 Jan 24, 2014

Copy link to clipboard

Copied

The solution is to always work with the correct document profile (that is an RGB document profile when you want to do RGB work) and to not use a greyscale swatch, but the black one when in RGB mode.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 07, 2015 Sep 07, 2015

Copy link to clipboard

Copied

I know this is technically thread necro and I don't mean to dredge up dead threads, but this was one of the first suggested results in a Google for this issue, and it was relevant to my issue.

I've been experiencing the same symptoms, but changing the swatches in the document to RGB black did not work. It would show the adjusted settings of 0,0,0 of the swatch on inspection, but every time I hit D, it would revert to CMYK black, but that black wouldn't appear in the swatches menu.

I realised it was because I created a new document using the Print profiles, and changed color profiles to RGB instead of CMYK. Even though it's set for RGB, it defaults to CMYK swatches, so if you go to create a new document and need it in RGB, make sure not to start from a Print profile.

Hope this helps someone!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 01, 2015 Dec 01, 2015

Copy link to clipboard

Copied

Suffering from the same problem. I think Adobe should skip the separate 'Document Color Mode' menu-item. The actual solution should be in the Document Settings panel, where should be a possibility to switch to RGB, with all things that belong to that, such as 0,0,0 RGB black in swatches and default fill/stroke.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 01, 2015 Dec 01, 2015

Copy link to clipboard

Copied

What document profile did you use when you opened a new file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines