Illustrator shows dull colors in RGB mode

Community Beginner ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

Hello,

Illustrator is showing dull colors in RGB mode of imported images.

It doesn't matter if it's a screenshot that is pasted in Illustrator or an image that has been drag-and-dropped into illustrator (same happens with the Place option). The colors of the image always come out dull compared to the original that has been found online.

I didn't have this issue on my old laptop (Asus N551JX with Win 10). The colors have always been accurate. I got this issue only on my new laptop (Asus ROG Zephyrus G15 with Win 10).

 

Unfortunately, this issue is also present in Photoshop. I'm using the same color settings as on my old laptop (shown below), but for some reason, the colors aren't managed in the same way.

 

Does anyone here have a clue on what could be causing this issue and how to solve it?

Thank you!

 

nikolam_1-1658306686948.png

 

 

TOPICS
Performance

Views

116

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

You have a specific monitor profile and are not using it for the proof preview. Check the relevant options in the View menu and also check your system screen settings.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Thank you everyone for the tips and suggestions! I tried to calibrate it, went through all settings and everything was set as on the screenshots Anubhav provided. Unfortunately the issue was still there.

However, as Mylenium mentioned to check the options in the View menu, I clicked on Proof Setup on noticed that it was set to Working CMYK, even though the document is in RGB mode.

 

After setting it to Monitor RGB, the colors are as they should be, for imported and screenshotted images.

 

nikolam_0-1658403356945.png

 

What is bothering me however is that it seems as if it isn't using sRGB, but the monitor's profile.

nikolam_1-1658403701826.png

This ASUS_GA503QM... appears where the document's name is displayed.

ASUS_GA503QM is the laptop, but the Illustrator window is opened on my BenQ monitor. Is the monitor now using the laptop's profile?

This makes me worry because I'm afraid that, when creating graphics for my clients, I might see one color on my display thinking that this is how the colors should be, but the client might see completely different colors on their monitor 😕 

Is there any way to get around this and make sure we both see at least very similar colors? I know that it's difficult and almost impossible to achieve the same color across all monitors, displays, and devices.

 

Also, when going to Proof Setup's settings, it's possible to choose sRGB or BenQ LCD profiles.

The colors are still different from images I see online (e.g. opened in Chrome or Brave browser). I wonder now which profile should be used now?

nikolam_2-1658404550514.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

You are using "Monitor RGB" as your proofing profile.

Try sRGB.

 

There's a Color Management training on LinkedIn Learning. You might want to watch it (it's not for free, but some public libraries provide LinkedIn.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

I'll try to find this training, thanks for the suggestion. Did you mean that I'm using Monitor RGB as a proofing profile only in Illustator (or other Adobe products) or generally on my PC? I went to Windows settings and am able only to pick the ASUS profile on the dropdown menu. There aren't any other profiles to choose. Can I download an sRGB profile from the internet and install it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

As a setup in your system you will need to use an individual profile for your monitor. Best would be to calibrate the monitor.

In Illustrator for the proof you need to use the profile that will be used in the output. Which in the case of printing is the profile the printing service uses and in the case of screen design it usually is sRGB.

 

sRGB should be installed in your system already.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

When I went to Settings > Display, I've been able only to see ASUS as the profile.

Then I went to the bottom of the Display settings window and opened Additional display settings. Then in the new window went to Graphic cards settings for monitor 2. In the new window I clicked on the third card called Color management. In another new window I chose, under Device, the Generic PnP Monitor. The only profile available there was ASUS_GA503QM... But it was possible to add new profile so I added sRGB.

Unfortunately, I wasn't able to choose a new profile also for the BenQ monitor as the Add option is disabled in this case.

However, after setting the sRGB as the profile as the default one, all colors appear as they should also on the BenQ monitor. Also, in the Display settings, it is now possible to choose between sRGB and ASUS_GA503QM... profiles which previously wasn't the case.

After opening Illustrator I'm getting the color that I've been previously getting on my old laptop so I assume everything is fine now. Thank you, your answers helped a lot 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

LATEST

You're welcome - glad you could solve it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

Hello @nikola.m,

 

Sorry to hear about this experience. As suggested by Mylenium, I would request you to check and re-calibrate your display by following these steps in order:

 

  1. Use the Windows key + I keyboard shortcut to open the Settings app.
  2. Click DisplayMake sure you're using the recommended screen resolution for your display.
  3. Click the Advanced display settings link.
    AnubhavMajumder_0-1658329350874.png

     

    Now click on the link for Display Adaptor properties.
    AnubhavMajumder_2-1658329350894.png

     

  4. Click on the option for Color management.
    AnubhavMajumder_4-1658329350864.png

     

  5.  Go to the Advanced tab and ensure all profiles are set to the System Default (sRGB). Then, click on Calibrate Display.
    AnubhavMajumder_6-1658329350792.png

     

  6. The wizard will now walk you through the steps to access the on-screen display menu on your monitor to set specific color settings. Click Next to continue. 
    - Adjust the gamma settings by moving the slider up or down until the small dots are barely visible.
    AnubhavMajumder_8-1658329350852.png

     

Find the brightness controls on your monitor and adjust the brightness higher or lower until you can distinguish the shirt from the suit with the X barely visible.

AnubhavMajumder_10-1658329350776.png

 

Find the contrast controls on your monitor and set it as high as possible without losing the ability to see the wrinkles and buttons on the shirt.

AnubhavMajumder_12-1658329350798.png

 

- Move the Red, Green, and Blue sliders to remove any color cast from the Gray bars.

AnubhavMajumder_14-1658329350778.png

 

Note: You can optionally start the ClearType tuner at the end of this calibration to make text on-screen more legible.

 

After the calibration is complete, kindly restart the computer and then check if the colors are consistent with Windows on your Adobe apps.

 

Looking forward to your response.

 

Thanks,

Anubhav

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

Can you open the image file in an image editing application such as Photoshop and does it show as expected?

If so: Convert it to Adobe RGB color space and then save it including the color profile. Set up Illustrator so that it shows all the profile warnings. WHen the warning pops up, make sure you preserve the profile.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines