My Illustrator files opens as XD files and I can't change it

New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

All of my Illustrator files force to open in Adobe XD even after I change the default app for .ai files to Illustrator. illustrator problem.PNG

Views

8.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Oct 22, 2018 Oct 22, 2018
JinaF First check wether you have all the newest updates from adobe CC and if you indeed have Illustrator version 23 installed. You can check this in the about info in the help menu!! Be aware that making the wrong changes trough regedit can be harmful to your Windows installation !! Press start button + R at the same time Type in Regedit and press ok. You will probably get a Yes / No Windows security question > select yes Regedit opens Browse to Computer > HKEY_CLASSES_ROOT > .ai Check the entr...

Likes

Translate

Translate
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

nicks10963186​, you're a lifesaver. This worked for me too, although it's not ideal to not be able to use Adobe XD. @Evil, if you take the extra step of manually designating Illy as the default program for .ai files after reinstalling, you should also get the icons back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

I just noticed this was happening to me as well. Hopefully a bug fix is inbound. Adobe, are you listening?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Having the same problem here. It started when I updated the programs last October 18, 2018. The correct answer above is not working for me either. Any answers from adobe?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

I have had this problem since the update from 2018 to 2019, Nothing fixes this issue.  I uninstalled and reinstalled twice, rebooting etc; manually set the file associations several times and illustrator file extension still is set to XD CC; not only that but windows will not even let me change any file association of any Adobe file extensions; would not even let me associate Illustrator with the .AI extensions when Illustrator was the only Adobe app installed; spoke with live chat an hour ago, and they actually told me that no one else has ever had this problem. ermm  this is so obviously a bug in the 2019 update and a very detrimental to production times; this is an update that is industry crippling and deserves a rapid public response, not a denial of its existence.   (yes industry crippling, so if it takes 3-4 additional steps to complete a task, and those additional steps take 5-10 seconds to complete each time they need to be executed, you could be looking at a lose of several hours a day on production, which means lose of money) but i am just angry that the chat support actually told me I was the only one in the world to report this problem, and that he was an expert in Windows and Adobe asking me "have I tried to reboot my computer", I told him yes I know where the power cord is.....  ( FYI: all the answers to resolve this problem in this forum would work if there was no problem with Adobe )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2018 Oct 27, 2018

Copy link to clipboard

Copied

I completely agree, and so glad I found this thread. I am technically literate, and no WIn10 (64) registry hacks or reinstalling in any order, will fix anything. At one point I had XD and Illustrator correctly working - then installed Acrobat and watched in real time as my .ai files changed to XD icons.....and I wasn't even installing XD!

Adobe charge us every month for this, after taking way our ability to pay outright for these tools - the responsibility to keep this paid for service running and not impact our earning and time is theirs, not ours.

Legal action, if this doesn't get fixed in next week. Straight to the Adobe directors taking a big bonus for shoddy performance.

Very, very angry. Adobe, I really hope you're listening....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

As a test, I uninstalled Illustrator leaving XD installed. I then reinstalled Illustrator and it changed the file associations for ai files to Illustrator. So far so good.

Can someone else try this and see if they can repeat my results.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

I uninstalled AI and then reinstalled. Files switched automatically from XD to AI. I didn't uninstall XD.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

I checked my registry files > Computer\HKEY_CLASSES_ROOT\.ai and it said Adobe.Illustrator.22 but Adobe.Illustrator.23 is installed... changed that registry key to the latter and it seems to be fixed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

This registry fix actually worked and nothing has to be reinstalled. I just changed the value of the entry from Illustrator22 to Illustrator23 and now everything works as it should. Thanks, joosdm, saved me from uninstalling and reinstalling everything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Can you (or anyone, really) post step-by-step instructions for changing the registry key for us non-tech-savvy folks? I've been trying to figure out how to do that ever since I saw joosdm20559267's post earlier this morning, with no luck.

Thanks in advance!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

JinaF​ If you're asking me, I didn't edit my registry.  I just used Windows FIle Association through Properties.

Right click on a file that should open with AI.

Scroll to bottom and select properties.

Hit CHANGE

Select AI from the list.

Hit OK.

Hit Apply.

Thats what I did and worked for me.  Not sure if it will work for you but I hope so.

Best,

Karl

Untitled-2.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Hi Karl,

I was actually referring to 's post Thanks for responding, but I've tried that several times so far with no luck, it just goes back to "Pick an app" after I select Illustrator. Same thing happens when I try to choose default apps in Windows settings > Default apps > Choose default apps by file type.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

JinaF First check wether you have all the newest updates from adobe CC and if you indeed have Illustrator version 23 installed. You can check this in the about info in the help menu

!! Be aware that making the wrong changes trough regedit can be harmful to your Windows installation !!

  • Press start button + R at the same time
  • Type in Regedit and press ok.
  • You will probably get a Yes / No Windows security question > select yes
  • Regedit opens
  • Browse to Computer > HKEY_CLASSES_ROOT > .ai
  • Check the entry called: (Default)
  • If it says Adobe.Illustrator.22 you can try changing it by double clicking the entry
  • After you made the changes click ok and close regedit and try clicking an Illustrator file

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Changing the registry key to 23 did the trick for me.

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 31, 2018 Oct 31, 2018

Copy link to clipboard

Copied

Changed to 23 worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Thanks so much, changing the registry worked for me too!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Thank you, Changing the registry to 23 did it for me.

cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

The regedit worked or me, thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

This worked for me as well.  Sure wish Adobe would get their act together

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

Regedit worked for me. Thanks to you and the previous poster who suggested it.

What a silly bug.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

It actually worked for me! Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

This worked perfectly for me. I just had to right-click on any Ai file / select properties / Change "Opens with:" to Adobe Illustrator and all the files converted back to Adobe Illustrator. Thanks for the great suggestion.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

This is it, thanks so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

confirming this worked, immediately after applying.

Note that the .ai file will open illustrator once reg edit is applied, the icon may take a while to update. No reboot required

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 15, 2018 Nov 15, 2018

Copy link to clipboard

Copied

Fixed!!!!! Thank you so much for the help, was really annoyed by the issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines