My Illustrator files opens as XD files and I can't change it

New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

All of my Illustrator files force to open in Adobe XD even after I change the default app for .ai files to Illustrator. illustrator problem.PNG

Views

8.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Oct 22, 2018 Oct 22, 2018
JinaF First check wether you have all the newest updates from adobe CC and if you indeed have Illustrator version 23 installed. You can check this in the about info in the help menu!! Be aware that making the wrong changes trough regedit can be harmful to your Windows installation !! Press start button + R at the same time Type in Regedit and press ok. You will probably get a Yes / No Windows security question > select yes Regedit opens Browse to Computer > HKEY_CLASSES_ROOT > .ai Check the entr...

Likes

Translate

Translate
Explorer ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

I just noticed this.

I right-clicked on an offending file

Went to properties

Hit change next to Open with

Selected AI

All better. 

Doesn't sound like it is working for most, but fixed mine.

Shouldn't have happened in the first place.  There are more and more of these little "issues" getting pushed to the public.  Too bad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Well, this morning, none of the fixes are working for me. When I booted up, all the .ai associations had gone back to .xd. I tried the regedit change, no love. I uninstalled and reinstalled AI, no love. I again tried the regedit fix (reinstalling AI had changed it back to version 22), again no love.

To heck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Well now I'm afraid to reboot. Crud.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

I have since rebooted and all of my file associations are still proper.

Windows 10 64-bit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

Changing the registry to 23 didn't work for me in itself. However, when I did that, I was able to change the file association in settings to ai, which I wasn't able to do before. It has stuck through several reboots, so I feel that I have solved the problem on my system.

Thanks everyone who helped on this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

Had exactly the same problem in Windows 10 and this fixed it for me.  My problem:

  • I copy/paste vector information in Illustrator and paste it into Photoshop as a smart object.
  • When I double-click the smart object layer, it opens in Adobe XD (which I recently installed) instead of Illustrator.

To open smart vector objects from Photoshop in Adobe Illustrator:

  • Hit the Windows Key and type default, and select Default Apps
    :AdobeHelpDefault.png
  • Click on Choose default applications by file type at the bottom of the window that opens:
    AdobeHelpChoose.PNG
  • Find all your common vector file formats and select Adobe Illustrator as the preferred software (in my case, .ai & .svg😞
    AdobeHelpFiletype.PNG

Really hope this works for you.  Worked a treat for me ^_^

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

I'm on windows 10 BTW..

1. Uninstall both illustrator and XD

2. Reinstall illustrator

3. Restart you PC (additional step)

3. Check your illustrator files.. should see the ai icon now - don't proceed to step 4 until you do. ( if not restart again or go into windows as instructed above)

4. Reinstall adobe XD

Hope it helps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

You don't have to necesarilly uninstall Ai and XD, I just followed the last steps from this comment and the issue was fixed, ty!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

Same issue here (windows 10) with Adobe Illustrator opening by default in XD, and I've just found that all Photoshop files are also opening in XD by default and changing the option to use the correct program by default doesn't work either! Come on Adobe, where's the fix?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

This solution doesn't work for me. Now it's trying to open my AI files with the photo viewer. Ugh. I hate Windows. Only using it cause that's what they give us at work...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

So in my case, my psd and ai files were opening in xd. So the first thing I did was to uninstall all three apps and install them back again. That didn't work. So after following this thread, I tried changing registry and that also didn't work so, in the end, I did this:

1. I left XD instaled

2. uninstall PS and AI

3. instal PS and AI back again

And it worked. So hopefully it will work for someone else. Good luck.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

Same thing happening to all our machines company wide and each of us designers workstations at home. It doesn't seem to be isolated but 100% an issue for 100% of us. All the "fixes" in this thread have not worked for any of us. For now everything has to be right clicked open with Illustrator or opened directly from illustrator. If this doesn't get fixed I would actually condone some sort of legal action towords Adobe. It would sure be interesting to track over all users, how much time over the duration this problem persists is waisted because of this fault.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

Just to confirm with you the fix that has worked for us on your windows 10 machines here:

You do have to do them in this order.

Edit the file association in the registry for ai from 22 to 23.

If necessary, change the file opens with association in control panel to ai.

If doing those doesn't work, I am out of ideas.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 07, 2018 Nov 07, 2018

Copy link to clipboard

Copied

I was having trouble with the Illustrator file association, too. I had tried all the steps in the post below to no avail:

How to fix broken file type associations for Creative Cloud apps

I discovered, like nicks10963186 said, you have to do them in that order. However, if you install Illustrator 23 and uninstall 22, Windows forgets about 22, so you can't make that change.

In order to finally get it to work for me, I had to reinstall Illustrator 22 while keeping Illustrator 23. Windows re-associated my .ai files with 22, and then the registry change from joosdm20559267 worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

Adobe personnel is not always on these forums. Therefore, I have submitted a bug fix request to Adobe. You may wish to also.

Feature Request/Bug Report Form
Alternatively, you can vote what I submitted. It is titled: Illustrator 23 Not Updating Version in Registry on Windows 10, Therefore Associates to XD

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

Here's the link so everyone can go vote on it in the official bug report threads:
XD / PS defaults to open .ai files - AI files should open with Illustrator only – Adobe Illustrator ...

Looks like Adobe is aware of it and working on it. But like many of you, I thought my head was going to explode with how infuriated I was to have my workflow (jam-packed with deadlines) interrupted to troubleshoot this stupid issue. That said, my temporary fix was this:
1) Did the registry hack where I changed it to Illustrator23
2) I uninstalled XD, cause it still seemed to be picking it up (MIGHT not be necessary), and this disassociated the AI extension from using that program.
3) Right-clicked on AI file and changed the default to Illustrator 2019. FINALLY WORKED.

I haven't tried restarting my computer, so I don't know if it will keep, but I'm fine leaving my computer running until Adobe sorts this out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Changing the Illustrator's version number on registry worked here, thanks to joosdm20559267 for the fix tip.

Throughout last years, Adobe has been screwing our lives up instead of helping. Next time I'll think twice about proceeding with a freaking update, because they're not releasing updates, they're releasing ISSUES.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2018 Nov 12, 2018

Copy link to clipboard

Copied

Settings > Apps > Default Apps

Scroll to the bottom and choose the "Set defaults by app" link.

Then choose Adobe XD from the list and click the "Manage" button.

In the File type and protocol associations select the .ai extension and choose AI from the list.

If AI is not in the list (this was my experience) open the windows registry editor and search for the .ai file type and see that the Illustrator version number corresponds to what is installed on the computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 03, 2019 Jan 03, 2019

Copy link to clipboard

Copied

LATEST

I have to uninstall both and reinstall them again. Adobe is something that screw up with our lives but we still need them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines