• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Need help with Illustrator lagging after isolating groups

Explorer ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

I recently upgraded my work Mac from iMac Pro (2017) to a Mac Studio (2022) and I notice a few quirky differences. Most are minor but this one really interrupts my workflow because of the lag (or delay) it causes. I want to see if anyone knows what is causing it so that I can stop interrupting myself when I work!

 

Ok, so the issue is when I want to edit something within a group. Typically I isolate the selected group so that it's easier to select the items I need to. Well, on the new Mac, Illustrator does this: https://youtu.be/kKAssq74X7E. This is just a sample document to show as I can't show our customer's artwork, but as you can see, even with simple shapes there is a noticeable lag after isolating the group.

 

I am working locally, no network issues should cause this. I have tried switching from GPU to CPU and that does seem to eliminate the problem, but everything else is slow to work with. So that's not a feasible option for me either. I have uninstalled and reinstalled Illustrator as well and no improvement. I don't really know what else to try! I am really leaning towards it being a computer problem rather than Illustrator but theoretically this Mac should be way faster than my old iMac. Just to be thorough, here is the info on both computers:

iMac Pro (2017)

Processor:3.2 GHz 8-Core Intel Xeon W
Graphics:Radeon Pro Vega 56 8GB
Memory:64GB 2666 MHz DDR4
MacOSSonoma Version 14.0

 

Mac Studio (2022)

Chip:Apple M1 Max
Memory:64GB
MacOSSonoma Version 14.4.1

 

Does anyone have any ideas on how to remove this lag (if possible)?

TOPICS
Performance

Views

86

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Community Expert ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

Is "Displays have separate spaces" turned on?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Hello @chris g,

I'm sorry to hear about your experience. I hope Monika's suggestions helped resolve the performance issues. If not, kindly try the suggestions shared in this help article (https://adobe.ly/3yHbUsA) to see if they help.

Looking forward to hearing from you.

 

Thanks,

Anubhav

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2024 Jun 11, 2024

Copy link to clipboard

Copied

Thank you for the suggestions but none of them worked unfortunately.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

LATEST

Hi there, 

 

I'm sorry that none of the suggestions provided were helpful. Could you please share a few more details, such as:

 

  • Exact Version of Illustrator 
  • When did this issue start occurring? Was it after installing the latest release?
  • Is the problem specific to this particular file?
  • Is it a cloud document?
  • Did you try resetting Illustrator Preferneces? If not, please try the steps shared here


Regards,

Srishti

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2024 Jun 11, 2024

Copy link to clipboard

Copied

Sorry, I didn't get an email response letting me know there was a reply to this. 

 

"Displays have separate Spaces" is not turned on.  I do not use Mission Control at all.  Are you suggesting I turn it on to fix the lagging problem?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines