Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Plug-in failed to be loaded in Illustrator 2022

Explorer ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

Hi

 

I'm trying to prepare my plug-in to support Illustrator 2022.

For that, I use the SDK CC 2022

 

When I'm using the plug-in EmptyPanel provided in the examples, this plug-in is correctly loaded in Illustrator.
But when I'm adding  Qt 6.2 with only QtCore and make a simple qDebug() << "Hello World", it fails to load it. It displays a message into Illustrator that there is an error when loading the plug-in.

In the console, it complains that it cannot find QtCore, but I have correctly copy it into Frameworks folder of the plug-in. I even copy it into the MacOS folder. I have also checked the install name.

It is also correct @rpath/QtCore.framework/Versions/A/QtCore

 

I have also added in the Info.pList the following entry to authorize loading external libraries 

<key>com.apple.security.cs.disable-library-validation</key>
<true/>

 

What am I missing ? Is there any additional requirements about loading external libraries ?

TOPICS
SDK, Third party plugins

Views

68

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Any advices ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

LATEST

I have updated my Illustrator beta to the final customer version and also the sdk.  But I still have the issue.

In the SDK, I looked if there is something to help me about my issue. But there is nothing.

They is nothing about handling loading external libraries or dealing with  code signatures  on the plugin or libraries

 

Can someone help me ? It seems that Illustrator prevents loading external libraries from the plug-in.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines