"Select Same" only works in isolation mode

Community Beginner ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

This has been going on for a while. Randomly, there are days when the "select same ___" commands (keyboard and using the dropdown menu) don't work. So if I have a bunch of items the same color and I try to select same fill color, nothing happens. Same for any of the other select commands. However, if I enter isolation mode all of the commands work. I've tried restarting AI and it only sometimes helps. Current version of Mac OS and current version of AI, but it's been happening for months. 

 

Any help on getting this very annoying and time-consuming bug worked out?

TOPICS
Bug , Tools

Views

137

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 15, 2022 Jul 15, 2022
It's a remarkable sample file. As far as I can see there are two rotten eggs that cause the stoppage of the Select > Same > Fill Colour command: The two point type objects whose names start with "Option 2 …" and "Option 1 …", both located in the main layer called "info". You can do a couple of things to somehow fix the issue in the actual file. It's rather mysterious, for example: - Hide both type objects - Lock both type objects - Completely remove both type objects - Convert both type obje...

Likes

Translate

Translate
Adobe Employee ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Hi @AreliMedia,

 

Sorry to hear about your experience. Would you mind trying resetting your preferences (https://helpx.adobe.com/illustrator/kb/troubleshoot-preference-issues.html#:~:text=on%20your%20devic...) and see if that helps?

 

Also, would you mind confirming sharing a few details like:

  • The exact version of macOS & Illustrator
  • Is this happening with a specific file or all? Would it be possible for you to share a sample file with us?
  • Are there any recent changes made to your system? For example, any antivirus, system updates, plugins, or web extensions installed recently.

 

We are here to help. We just need more info,

 

Thanks & Regards,
Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

Hey @Anshul_Saini,

 

Tried resetting preferences to no avail. 

 

Specs are: Mac OS Monterey 12.4, AI v26.3.1. No antivirus or other third-party plugins or any other extensions. 

 

It comes and goes on files, sometimes it's a problem when I open it, sometimes not. I was having it on this file so attaching, not sure if it will persist but it's attached to try.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

If the file you are trying to attach is an .ai file it won't work. Please use a file sharing site like Dropbox and post the link here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

@Larry G. Schneider @Anshul_Saini try the file above.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Thanks for sharing the file @AreliMedia. I am unable to replicate the issue in a new file. However, with your file, the issue is replicable. So, I went ahead and opened the file in v24.0 and found out that layers have a clipping path. That's why "Select Same" was not working. I have corrected that in the attached PDF file.

 

Anshul_Saini_0-1657855024360.png

 

 

Would you mind sharing your workflow of how you are creating these files?

A small recording would be really useful.

 

Also, I would recommend you follow the suggestion of @MikeGondek mentioned below.

 

Looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Try using Select >> Same >> Appearance. That works for me on your file. The other way that works for me is to copy all and paste into a clean new file. You must have some bad code in the headers, or either yourcomputer adds some bad code when creating a new file.

 

Do not edit in .pdf, use .ai for editing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

When you say, for a while, do you mean since an update?

Try creating a new user on your mac and install there... I'm not on a mac but I see this solution to a lot of mac problems on the forum...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

LATEST

It's a remarkable sample file. As far as I can see there are two rotten eggs that cause the stoppage of the Select > Same > Fill Colour command: The two point type objects whose names start with "Option 2 …" and "Option 1 …", both located in the main layer called "info".

 

You can do a couple of things to somehow fix the issue in the actual file. It's rather mysterious, for example:

 

- Hide both type objects
- Lock both type objects
- Completely remove both type objects
- Convert both type objects to paths
- Convert both type objects to symbols
- Apply one unique colour (e.g. only black) to both type objects
- Drag the layer "info" below the layer "Artwork"
- Drag the rotten eggs below the circles inside the "Artwork" layer

 

In all cases the Select > Same > Fill Colour command will work again as expected.

 

Strange occurrence.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines