S.O.S.! Weird thing happening in Ai with pointer tool.

Community Beginner ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

I'm on a brand new iMac with the M1 chip. Also on the latest version of Ai. I'm currently in a course learning Ai - I have been merrily working through the course for two weeks clicking and dragging every line, circle, square and leaf imaginable as I am learning Ai from the ground up. No problems at all.  Then three days ago out of the blue i'm getting strange symbols attaching to my pointer tool (gray square, + sign, green circle) and the object I'm selecting will not move.  It is not locked. After clicking on and off several times I find a sweet spot and I can again move the object.  It's as if the smart guides are detecting or snapping to something. Actually more like repelling something.  It is really slowing me down.  The course experts I'm in have never seen this and referred me to you.  I have images and video of the problem. Please help!! The video shows the problem very well but I don't know how to share it here - it's on Loom.

IMG_8973.jpegIMG_8972.jpeg

TOPICS
Bug , Performance , Tools

Views

251

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Mar 17, 2022 Mar 17, 2022
Hi @Carla23616442rbu5 , Apologies for the inconvenience caused to you due to this issue. Can you help the Illustrator team to isolate this issue further so that we can nail this down? If yes, then please share the following information: 1) What is the MacOS version of your machine? (From the Apple menu  in the corner of your screen, choose About This Mac. You should see the macOS name, such as macOS Monterey or macOS Big Sur, followed by its version number.) 2) Are you using Apple Magic Mouse o...

Likes

Translate

Translate
Adobe Employee , Apr 05, 2022 Apr 05, 2022
Hi @Carla23616442rbu5 @mvheim  I am glad to inform you that this issue has been fixed in the latest Illustrator update, v26.2.1, released yesterday. I would request you to update and let us know if the issue persists. Regards, Anshul Saini

Likes

Translate

Translate
Community Beginner ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

See Video of the problem below.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Monterey 12.3?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

I don't know what that is.  What do I do about the problem??

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

This seems to be a bug introduced in version 26.1 on Monterey Macs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

So what do I do??

It has been suggested to me that I delete and reinstall Ai.

If i delete and re-install Ai will I loose everything? I have been backing up to cloud instead of desktop, but I am very, very new to all this and am struggling.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

You won't lose your files. You could try installing the previous AI version (26.0.3) from the CC app:

DougARoberts_0-1647447444775.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

Hi @Carla23616442rbu5 ,

Apologies for the inconvenience caused to you due to this issue.
Can you help the Illustrator team to isolate this issue further so that we can nail this down?
If yes, then please share the following information:
1) What is the MacOS version of your machine? (From the Apple menu  in the corner of your screen, choose About This Mac. You should see the macOS name, such as macOS Monterey or macOS Big Sur, followed by its version number.)
2) Are you using Apple Magic Mouse or any other external mouse?


Thanks and Regards,

Shivangi

 

Note: Marking this as correct to highlight

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2022 Mar 18, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

I am having this exact problem with the green "+" cursor. Just came up with the new 26.1 update. But I am NOT using Monterey — I am on an Intel iMac with Catalina 10.15.7, with a Magic Mouse.

 

I was wondering if drag-copy was triggering some kind of MacOS accessibility feature, but I couldn't find anything in Apple Preferences that looked like this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

I should have stated, this oocurs only when attempting to drag-copy or drag-constrain-copy. The object, although remaining highlighted, snaps back to the original position and fails to copy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

I found the following comment under Bug Reports (see screenshot). The green cursor is the MacOS copy cursor — the bug is that this should NOT be showing up within Illustrator operations.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2022 Mar 18, 2022

Copy link to clipboard

Copied

Ditched the magic mouse. Bought a logitech. Seems to have stopped but it's
only been an hour. Fingers crossed.🤞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 05, 2022 Apr 05, 2022

Copy link to clipboard

Copied

LATEST

Hi @Carla23616442rbu5 @mvheim 

 

I am glad to inform you that this issue has been fixed in the latest Illustrator update, v26.2.1, released yesterday. I would request you to update and let us know if the issue persists.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines