Scrolling in illustrator is choppy and incredibly frustrating. M1 MacBook Pro

New Here ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

16" MacBook Pro M1, latest macOS 12.3.1. Latest version of CC + illustrator. Never had the Intel version of Illuatrator installed. Scrolling in illustrator is short and choppy. I can only scroll 50px at a time. Happens in any file, even a new blank file. Takes 7-8 scrolls to move across a single a4 artboard. 

In contrast, scrolling in Photoshop is very fluid, fast, and has easing. Like it laways has been.

 

Any ideas?

TOPICS
Performance

Views

140

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 13, 2022 Jun 13, 2022
Hi @DigitalChickster, We are sorry to hear about your experience. I checked you previously had Freeze issues while opening and creating a new document. Are you facing a similar issue? Would you mind checking if GPU performance is turned on in Illustrator preferences (cmd+k) > Performance or not? Also, please try validating fonts and clearing the system font cache. Steps are on this helpx Article (https://helpx.adobe.com/in/fonts/kb/troubleshoot-fonts-illustrator-indesign.html). Let us know h...

Likes

Translate

Translate
Advocate ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

Try activating or deactivating GPU Performance under preferences

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

yes, tried that. as well as rebuilding illus prefs, and installing earlier versions if illus. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Hi @michaelc70798224,

 

We are sorry to hear about your experience. This is not the experience we want you to have. Would you mind sharing a few details like:

  • Does updating to macOS 12.4 and updating the Illustrator v26.3.1 helps?
  • Does this happen on a specific document? Is the issue you have described reproducible on a new document?
  • Are you using multiple external monitors?
  • Please share a screenshot of your whole artboard, including the Control menu & Layers panel.
  • Have you tried resetting Illustrator Preferences (https://helpx.adobe.com/illustrator/using/setting-preferences.html)?
    Disclaimer: Please note that resetting preferences will remove all the custom settings, and Illustrator will launch with default settings.

 

We are here to help. We just need more info.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

Hi. I just updated macOS to the latest, and Illustrator is the latest. Still no improvement. As I said, Photoshop scrolls easily and smoothly. Illustrator scrolls very choppy and and in very very small increments.

Please help!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

Thanks for confirming that. I'd recommend you to connect with our technical support team (https://helpx.adobe.com/contact.html?rghtup=autoOpen). The team here would be able to perform remote troubleshooting and assist you accordingly.

 

If the issue gets resolved, please let us know here so everyone can know how the issue got resolved.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Did this ever get resolved? I'm having the same issue...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

Hi @DigitalChickster,

 

We are sorry to hear about your experience. I checked you previously had Freeze issues while opening and creating a new document. Are you facing a similar issue? Would you mind checking if GPU performance is turned on in Illustrator preferences (cmd+k) > Performance or not? Also, please try validating fonts and clearing the system font cache. Steps are on this helpx Article (https://helpx.adobe.com/in/fonts/kb/troubleshoot-fonts-illustrator-indesign.html).

 

Let us know how it goes.

 

Kindly update the discussion if you still need assistance with it. We'd be happy to help.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

Actually, that's how all this came about. Illustrator was freezing on me... I was unable to use it at all. I spoke with someone with Adobe tech support, and they ended up deleting and reinstalling Illlustrator on my computer. He said to NOT check GPU performance... because that was what was making it freeze. Ever since I did that reinstall, it's been super choppy and laggy. It's really frustrating, because it had been working so well. I will try the other suggestions and will let you know how it goes. Thank you! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

Thanks for confirming and sharing the details, @DigitalChickster. We recently discovered while troubleshooting that the issue is related to fonts, and it is irrespective of Mac device, macOS & Illustrator versions. After you perform the font troubleshooting, then turn on the GPU performance. It will improve the performance and reduce the choppiness and lagginess.

 

Regards,

Anshul Saini

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

LATEST

THANK YOU!!!! This worked perfectly. I had some issue with my Apple Font Book app, but once I got that working, I turned off a lot of fonts... plus I validated the fonts, per your instructions. Now Illustrator is running beautifully (I did turn on GPU performance... and it didn't crash my program). 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines