• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

(v28.5) Can't export knockout group's transparency

Community Beginner ,
May 08, 2024 May 08, 2024

Copy link to clipboard

Copied

I'm trying to export the icon I've made, but can't find any export preset that retains the knockout group transparency. Attached is a screenshot of how it appears in illustrator, an exported PNG, and the .ai file's link (here)

Cole33399348icgg_0-1715177057804.pngPersonalBrand_Logo_Icon.png

 

TOPICS
Import and export

Views

61

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , May 08, 2024 May 08, 2024

Wow! That was weird.

The cause of the issue are the inside groups.

You do not need them. Ungroup the compound paths and apply this directly to them.

Bildschirmfoto 2024-05-08 um 16.38.54.png

Also: For a knockout group, you need no blend mode. Just set opacity to 0%

Bildschirmfoto 2024-05-08 um 16.39.24.png

And for the knockout group: just that. You d o not need the other options.

Bildschirmfoto 2024-05-08 um 16.40.08.png

And then it works.

Votes

Translate

Translate
Adobe
Community Expert ,
May 08, 2024 May 08, 2024

Copy link to clipboard

Copied

Not sure exactly where the problem was, but there were several nested groups with different transparency settings. I simplified it and the export worked fine:

DougARoberts_0-1715179207004.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 08, 2024 May 08, 2024

Copy link to clipboard

Copied

Wow! That was weird.

The cause of the issue are the inside groups.

You do not need them. Ungroup the compound paths and apply this directly to them.

Bildschirmfoto 2024-05-08 um 16.38.54.png

Also: For a knockout group, you need no blend mode. Just set opacity to 0%

Bildschirmfoto 2024-05-08 um 16.39.24.png

And for the knockout group: just that. You d o not need the other options.

Bildschirmfoto 2024-05-08 um 16.40.08.png

And then it works.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2024 May 08, 2024

Copy link to clipboard

Copied

LATEST

This worked, thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines