Highlighted

Acquiring AIDocument suite leads to startup failing with SDK 2020

Explorer ,
Oct 18, 2020

Copy link to clipboard

Copied

I'm writing a plugin which requires to acquire AIDocument suite. It compiles without any problem, but acquiring this specific suite leads to failing at plugin startup with error 1394689636. I've also tried to test one of the sample plugins that includes AIDocument suite (TextFileFormat plugin) and got the same result.

 

All above relates to 2020 SDK builds, lesser builds for previous AI versions working fine.

 

Am I missing something and there's a way to fix this? Porting guide doesn't give a clue.

Or is it just a SDK version bug?

 
 

 

 

The problem was unmatched minor SDK and AI builds. Early releases support 17 version of AIDocument suite and recent — 19 version. It's a shame that such changes are not reflected in the porting guide.

TOPICS
Bug, SDK

Views

80

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Acquiring AIDocument suite leads to startup failing with SDK 2020

Explorer ,
Oct 18, 2020

Copy link to clipboard

Copied

I'm writing a plugin which requires to acquire AIDocument suite. It compiles without any problem, but acquiring this specific suite leads to failing at plugin startup with error 1394689636. I've also tried to test one of the sample plugins that includes AIDocument suite (TextFileFormat plugin) and got the same result.

 

All above relates to 2020 SDK builds, lesser builds for previous AI versions working fine.

 

Am I missing something and there's a way to fix this? Porting guide doesn't give a clue.

Or is it just a SDK version bug?

 
 

 

 

The problem was unmatched minor SDK and AI builds. Early releases support 17 version of AIDocument suite and recent — 19 version. It's a shame that such changes are not reflected in the porting guide.

TOPICS
Bug, SDK

Views

81

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 18, 2020 0
Explorer ,
Oct 19, 2020

Copy link to clipboard

Copied

The problem was unmatched minor SDK and AI builds. Early releases support 17 version of AIDocument suite and recent — 19 version. It's a shame that such changes are not reflected in the porting guide.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 19, 2020 0
Resources