Highlighted

Adobe Illustrator CC 2019 slow & not using eGPU (radeon VII) in Mac OS Catalina

New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi, 

 

I have recently come into some performance issues with Illustrator following updating my mac to Catalina. When panning around on the screen the frame rate is very low, and zoom features similar issues. I have noticed similar latency issues with simple functions, pen tool, artboards etc. I have an eGPU to improve my systems performance I ran activity monitor when working in Illustrator and all of the load is being carried on the Intel Iris Plus Graphics 655 and not the radeon VII.

 

Full system setup is provided below:

MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports)

Processor: 2.7 GHz Quad-Core Intel Core i7

Memory: 16 GB 2133 MHz LPDDR3

dGPU: Intel Iris Plus Graphics 655 1536 MB

Display: Single LG UltraFine Display (5120 X 2880). Laptop in clamshell mode. 

 

I have run several tests on the eGPU in other programs (Heaven Benchmark, Photoshop, Geekbench) and can confirm it is connected and taking load. I have ticked the use external graphic box on mac as well. I have attahced the system info file from the performance section. 

 

 

 

 

Correct answer by withayou | Community Beginner

So, I figured out that there IS an issue with MacOS, Illustrator (and to some degree Photoshop) and eGPU's currently (although not sure if the problem is within OSX, or Adobe, or both). 

I have an external Radeon RX 5700 XT and I had set ALL of my Adobe products to "Prefer external GPU" as I wanted them to take advantage of this powerful eGPU. 

 

Well, just like the original post, my Illustrator doesn't recognize the eGPU (shows the internal GPU in the PERFORMANCE tab) and it has a ton of lag and is just unbelievably slow. 

 

GPU_Issue.jpg

 

So I did a test. I loaded the newest Catalina and newest Illustrator on my 6 year old Macbook Pro. It ran perfectly. This meant that this issue had something to do with my eGPU or my iMac / OSX.

 

So, I unchecked the "Prefer external GPU" on my iMac, restarted Illustrator, and it ran perfectly. 

 

So, even though Illustrator wasn't showing my eGPU in the Performance tab, something was causing a conflict and ruining performance. 

 

So anyone with this issue should test this. Turn off "Prefer external GPU" and restart Illustrator. See if it's fast. There is some issue with Mac OSX, and Adobe, and maybe particular eGPUs.

What I would love to know is what's causing this. Is it something in OSX? Is it Adobe? Is it particular eGPU's that haven't been optimized? If I had time and money I'd simply load other GPU's into my external enclosure and find out, but I have design work to do. The frustrating thing is I bought an iMac with the cheapest GPU specifically because I knew I was going to keep an external one (so I could upgrade whenever). It sucks that I'm now only using that internal GPU on the software I use the most. 

Views

771

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe Illustrator CC 2019 slow & not using eGPU (radeon VII) in Mac OS Catalina

New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi, 

 

I have recently come into some performance issues with Illustrator following updating my mac to Catalina. When panning around on the screen the frame rate is very low, and zoom features similar issues. I have noticed similar latency issues with simple functions, pen tool, artboards etc. I have an eGPU to improve my systems performance I ran activity monitor when working in Illustrator and all of the load is being carried on the Intel Iris Plus Graphics 655 and not the radeon VII.

 

Full system setup is provided below:

MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports)

Processor: 2.7 GHz Quad-Core Intel Core i7

Memory: 16 GB 2133 MHz LPDDR3

dGPU: Intel Iris Plus Graphics 655 1536 MB

Display: Single LG UltraFine Display (5120 X 2880). Laptop in clamshell mode. 

 

I have run several tests on the eGPU in other programs (Heaven Benchmark, Photoshop, Geekbench) and can confirm it is connected and taking load. I have ticked the use external graphic box on mac as well. I have attahced the system info file from the performance section. 

 

 

 

 

Correct answer by withayou | Community Beginner

So, I figured out that there IS an issue with MacOS, Illustrator (and to some degree Photoshop) and eGPU's currently (although not sure if the problem is within OSX, or Adobe, or both). 

I have an external Radeon RX 5700 XT and I had set ALL of my Adobe products to "Prefer external GPU" as I wanted them to take advantage of this powerful eGPU. 

 

Well, just like the original post, my Illustrator doesn't recognize the eGPU (shows the internal GPU in the PERFORMANCE tab) and it has a ton of lag and is just unbelievably slow. 

 

GPU_Issue.jpg

 

So I did a test. I loaded the newest Catalina and newest Illustrator on my 6 year old Macbook Pro. It ran perfectly. This meant that this issue had something to do with my eGPU or my iMac / OSX.

 

So, I unchecked the "Prefer external GPU" on my iMac, restarted Illustrator, and it ran perfectly. 

 

So, even though Illustrator wasn't showing my eGPU in the Performance tab, something was causing a conflict and ruining performance. 

 

So anyone with this issue should test this. Turn off "Prefer external GPU" and restart Illustrator. See if it's fast. There is some issue with Mac OSX, and Adobe, and maybe particular eGPUs.

What I would love to know is what's causing this. Is it something in OSX? Is it Adobe? Is it particular eGPU's that haven't been optimized? If I had time and money I'd simply load other GPU's into my external enclosure and find out, but I have design work to do. The frustrating thing is I bought an iMac with the cheapest GPU specifically because I knew I was going to keep an external one (so I could upgrade whenever). It sucks that I'm now only using that internal GPU on the software I use the most. 

Views

772

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Oct 09, 2019

Copy link to clipboard

Copied

https://helpx.adobe.com/x-productkb/global/fix-macos-64-bit-compatibility-errors.html

"these apps weren't designed or fully tested for Catalina. We recommend that you continue to use the macOS versions noted in the system requirements for each app."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

Got it thanks, so I have to rollback and wait for Adobe to update their software to the new OS requirements.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

It's not about the OS, it's about the graphic card.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

Ok sure so is it an apple thing or illustrator thing, it works in other programs so do you think I need to wait for adobe to release support for Radeon VII in Illustrator

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

Of course it's an Illustrator thing, but it's not about lack of system support, but lack of graphic card support. Nobody can probably tell you when the support will be added. You can alert the engineers here: http://illustrator.uservoicec.om If they are working on it and when it gets a fix they will then notify you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

Ok great thanks Ill shoot them a message.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi Alex,

 

Thanks for reaching out and highlighting this issue. I would request if you can share a few more details like:

 

  • Exact version of Illustrator?
  • Do you see eGPU in the Preferences panel (Illustrator > Preferences > Performance)?
    clipboard_image_2.png
  • You can share this information on https://illustrator.uservoice.com/ as well (as suggested by Monika).

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi Srishti,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

I have attached a copy of my GPU details window below the original file I attached is the system info link from the performance pane.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 09, 2019

Copy link to clipboard

Copied

I am using Illustrator 23.1.1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 05, 2020

Copy link to clipboard

Copied

Hello Adobe, 

 

I'd like to join this thread as well. I have an Apple aproved eGPU encloser and an Apple approved GPU (AMD 5700 XT) and Illustrator seems to only recognize my internal card. Photoshop recognizes the external card (as does Premiere and InDesign). Only Illustrator doesn't. 

Screen grab attached showing the card Illustrator recognizes (the internal) and the menu bar showing the 5700 XT connected. 

 

I'm using the newest verions of Illustrator CC (24.0.3) and the most up-to-date Catalina OSX (10.15.3)

 

Thanks in advance, 

Brad 

 

Screen Shot 2020-02-05 at 8.44.59 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 30, 2020

Copy link to clipboard

Copied

I have the same problem

I'm using the newest version of Illustrator CC (24.1) and the most up-to-date Catalina OSX (10.15.4)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 01, 2020

Copy link to clipboard

Copied

Hi there,

 

We are sorry to hear about this. We'd need a couple of other information to be able to help you with this scenario:

  1. AISniffer file - You will find it within the Illustrator Preferences folder. The location of that folder is in the User library. Users/username/Library/Preferences/Adobe Illustrator #(version Number)Settings > AISniffer
  2. Your system information file - You can generate it from Apple icon > About This Mac > System Report > save it and send it over DM.

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 16, 2020

Copy link to clipboard

Copied

Thanks so much for sharing the details @withayou. I have passed it on to our Product team and they are looking into it. 

 

Regards!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 05, 2020

Copy link to clipboard

Copied

I'm having the same issue with an AMD Radeon RX 580 on 24.2.1. I'd be willing to share the AISniffer file and my System Information File if that will help get this supported in the future. Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 24, 2020

Copy link to clipboard

Copied

So, I figured out that there IS an issue with MacOS, Illustrator (and to some degree Photoshop) and eGPU's currently (although not sure if the problem is within OSX, or Adobe, or both). 

I have an external Radeon RX 5700 XT and I had set ALL of my Adobe products to "Prefer external GPU" as I wanted them to take advantage of this powerful eGPU. 

 

Well, just like the original post, my Illustrator doesn't recognize the eGPU (shows the internal GPU in the PERFORMANCE tab) and it has a ton of lag and is just unbelievably slow. 

 

GPU_Issue.jpg

 

So I did a test. I loaded the newest Catalina and newest Illustrator on my 6 year old Macbook Pro. It ran perfectly. This meant that this issue had something to do with my eGPU or my iMac / OSX.

 

So, I unchecked the "Prefer external GPU" on my iMac, restarted Illustrator, and it ran perfectly. 

 

So, even though Illustrator wasn't showing my eGPU in the Performance tab, something was causing a conflict and ruining performance. 

 

So anyone with this issue should test this. Turn off "Prefer external GPU" and restart Illustrator. See if it's fast. There is some issue with Mac OSX, and Adobe, and maybe particular eGPUs.

What I would love to know is what's causing this. Is it something in OSX? Is it Adobe? Is it particular eGPU's that haven't been optimized? If I had time and money I'd simply load other GPU's into my external enclosure and find out, but I have design work to do. The frustrating thing is I bought an iMac with the cheapest GPU specifically because I knew I was going to keep an external one (so I could upgrade whenever). It sucks that I'm now only using that internal GPU on the software I use the most. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 25, 2020

Copy link to clipboard

Copied

Thank you so much for sharing this here. 

 

Regards!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Add a group