Adobe Illustrator Issues with Microsoft Surface Book 2: Using Surface Pen

New Here ,
Jan 07, 2020 Jan 07, 2020

Copy link to clipboard

Copied

Hi, I was hoping somebody might be able to assist me with these issues.

I have just recently purchased a Microsoft Surface Book 2 (Quad-Core i7-8650U, 4.2GHz, Nvidia GTX1050, 256gb SSD, 8GB Ram), and have also picked up Adobe Illustrator for the first time.

Over the last couple of weeks I have been experiencing frequent issues whilst using the Surface Pen to draw with the Touch Caligraphic brush. There seem to be a few different issues happening here, so I will try to break them up into each individual issue. I am hoping I can get some assisstance with sorting these problems out.

Please note these issues are happening whilst using the Surface Pen, drawing onto the screen of the Surface Book.

1. Occasionally when using the brush at 1pt, the "live" stroke underneath the pen as I am drawing a line will dissapear. The line I am creating will not render/be invisible until I release the pen from the screen, and at that point it will appear. different things seem to fix this issue sporadically, but are never consistent.
Some of the things I have found that occasionally temporarily fix this issue but don't always work are:
- changing the size to larger than Stroke 1pt, drawing a line (which will appear "live"/immediately under the pen), then changing back to Stroke1pt. However sometimes changing the stroke size will have no effect
- changing to the selection tool, then back to the brush tool. However sometimes this will have no effect.
- changing from "essentials" workspace to "touch" workspace, then back. However sometimes this will have no effect.
I have not experienced this issue whilst using the trackpad/mouse to draw a line. Whilst this issue is happening I can use the track pad mouse click and it seems to work perfectly fine. Potentially this is a specific surface pen issue? 

2. Touch Caligraphic brush "stuck" at stroke 47pt or 12pt whilst in "essentials" workspace.
Upon creating a new document on Illustrator and opening it, one of three things seems to happen with the sizing of this brush.
One: The brush will say that the stroke is 1pt in properties, and draws a 1pt line. 
Two: The brush will say that the stroke is 1pt in properties, however draws a very large line. When selecting it in the brushes drop down menu, displays a "47" underneath the brush, which I assume means 47pt.
Three: The brush will say that the stroke is 1pt in properties, however draws a medium thickness line. If I change to "touch" workspace, it will show that it is at 12pt. 

For scenarios two and three, I am only able to change the size via going to the "touch" workspace and dragging the size down, or with the "[" "]" keys. I very well may be misunderstanding how the stroke size works with this brush? Or stroke and brush sizing in general? 

3. Upon changing the size of the brush, the size will not update properly on the "live" stroke. Again referencing to the line that is being immediately drawn underneath the pen before I release it from the screen, which then creates the line. If I am going from a smaller size to a larger size, or a larger size to a smaller size, it will display the previous size "Live" / immediately underneath the pen, however, when releasing the pen from the screen and actually creating the line, it will be created in the newly chosen size. This is espeiallly annoying going from a larger size to a smaller size, as I will not actually be able to see where my brush stroke is, until after the stroke has been created.

The reasoning for utilising this brush mainly has been the use of the "touch" workspace, and this being the default brush there. I do not yet have a wireless keyboard and mouse to use efficiently with the essentials workspace, which I plan on using mostly once I get them. Is there some sort of disconnect with how this brush interacts across different workspaces? These issues are very frequent, and unfortunately becoming quite frustrating and discouraging to use illustrator. 

If anybody has insight into any of these issues or has experienced similar issues on a Surface Book it would be great to hear your input,

Thanks in advance,
Dvard




TOPICS
Bug

Views

169

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

I am having the same problem as No 1 listed above on the Surface Book 3. Any update on this Adobe? It seems to be only when in the Touch Workspace for me. It works OK in Essentials Classic (I haven't tried any others). It was working before, but I haven't used it in Touch mode for a few weeks so maybe one of the recent updates has caused it?

It's a pretty fundamental flaw as it's the main reason I forked out £3K on a Surface Book was for this functionality!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines