Highlighted

AI use the wrong GPU, how to switch it?

Community Beginner ,
Jan 09, 2018

Copy link to clipboard

Copied

Hello  and happy new year everybody,

I have a Lenovo P40 YOGA with a NVIDIA QUADRO m500m but it has also an INTEL HD graphic 520. Illustrator is using the Intel card instead of the NVIDIA. When i go to Edit/Preference/performance i can't switch it.

I have a preview problem with this gpu, the thin strokes are not well displayed . When i switch to CPU preview I don't have this problem. Here a picture of CPU and GPU preview. I have  installed the lastest driver and the Quadro m500m is well recognized by other software (Rhinoceros 3D). Do you know how to solve this problem?
Thank you

CPUPREVIEW.gifGPUPREVIEW.gif

Hi,

I spent 2 days figuring this out for my AMD Radeon HD 8500M.

When using a laptop that has a GPU as well as HD Graphics, the performance is switched using software from the HD Graphics to your GPU.

In my case, AMD uses "AMD Radeon Settings" or "AMD Catalyst Control Center"

In order for Adobe Illustrator to detect my GPU I had to add the application to the "Switchable Graphics" feature within the AMD Radeon Settings application. This application is installed along with your GPU drivers.

Turns out it's not as simple as adding the Illustrator.exe from your installation path.

You have to select the following file and add it to your "switchable graphics" and set it to "High Performance". Worked for me and now AI picks up my AMD Radeon HD 8500M Graphics Card.

\\Program Files\Adobe\Adobe Illustrator CC 2019\Support Files\Contents\Windows\AIGPUSniffer.exe

Hope this spares, anyone else with a similar situation, 2 days of irritation in the future.

Regards,
Mark

Views

9.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AI use the wrong GPU, how to switch it?

Community Beginner ,
Jan 09, 2018

Copy link to clipboard

Copied

Hello  and happy new year everybody,

I have a Lenovo P40 YOGA with a NVIDIA QUADRO m500m but it has also an INTEL HD graphic 520. Illustrator is using the Intel card instead of the NVIDIA. When i go to Edit/Preference/performance i can't switch it.

I have a preview problem with this gpu, the thin strokes are not well displayed . When i switch to CPU preview I don't have this problem. Here a picture of CPU and GPU preview. I have  installed the lastest driver and the Quadro m500m is well recognized by other software (Rhinoceros 3D). Do you know how to solve this problem?
Thank you

CPUPREVIEW.gifGPUPREVIEW.gif

Hi,

I spent 2 days figuring this out for my AMD Radeon HD 8500M.

When using a laptop that has a GPU as well as HD Graphics, the performance is switched using software from the HD Graphics to your GPU.

In my case, AMD uses "AMD Radeon Settings" or "AMD Catalyst Control Center"

In order for Adobe Illustrator to detect my GPU I had to add the application to the "Switchable Graphics" feature within the AMD Radeon Settings application. This application is installed along with your GPU drivers.

Turns out it's not as simple as adding the Illustrator.exe from your installation path.

You have to select the following file and add it to your "switchable graphics" and set it to "High Performance". Worked for me and now AI picks up my AMD Radeon HD 8500M Graphics Card.

\\Program Files\Adobe\Adobe Illustrator CC 2019\Support Files\Contents\Windows\AIGPUSniffer.exe

Hope this spares, anyone else with a similar situation, 2 days of irritation in the future.

Regards,
Mark

Views

9.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 09, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 09, 2018

Copy link to clipboard

Copied

thanks Monika I will check it

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jan 18, 2018

Copy link to clipboard

Copied

Hi Antoinechab,

Did Monika's suggestion solve the GPU issue for you or are you still having trouble? Let us know if you need further assistance.

Best,

Wren

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 18, 2018

Copy link to clipboard

Copied

I'm having a similar problem here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 19, 2018

Copy link to clipboard

Copied

I have installed the new driver for the intel HD520 and it works fine, also with Illustrator. I have now to instal the driver and controller for the QUADRO to be used with AI.
I do that as soon as i have time to do it and I let you know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 06, 2019

Copy link to clipboard

Copied

please try if my solution works for you.

it's listed somewhere in this forum entry

Kind regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 06, 2019

Copy link to clipboard

Copied

Hello there,

(My Laptop is set to German, but I hope you can understand, what the screenshot shows.)

My Dell XPS 15 9570 was also using the Intel Graphics for Illustrator, however I found how to change it:

-go to the Windows 10 settings and search for the Graphics Settings

-then you click "browse" (German: Durchsuchen) and search for the Illustrator programme file

"C:\Program Files\Adobe\Adobe Illustrator CC 2019\Illustrator.exe"

-then, when the AI-Symbol appears in the list (as on the screenshot) you click on it and press "options"

-now the small "Graphics Specifications" window appears and both GPU's are listed.

-pick the better one (not the one with Intel, take the GeForce GTX or Quadro) and press save.

Now Illustrator should be using the Tesla instead of the Hyundai.

I hope I could help, I'm new to Illustrator

Wolf form Austria

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
mara_aa_ LATEST
New Here ,
Apr 13, 2020

Copy link to clipboard

Copied

This worked for me! Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 15, 2019

Copy link to clipboard

Copied

Hi,

I spent 2 days figuring this out for my AMD Radeon HD 8500M.

When using a laptop that has a GPU as well as HD Graphics, the performance is switched using software from the HD Graphics to your GPU.

In my case, AMD uses "AMD Radeon Settings" or "AMD Catalyst Control Center"

In order for Adobe Illustrator to detect my GPU I had to add the application to the "Switchable Graphics" feature within the AMD Radeon Settings application. This application is installed along with your GPU drivers.

Turns out it's not as simple as adding the Illustrator.exe from your installation path.

You have to select the following file and add it to your "switchable graphics" and set it to "High Performance". Worked for me and now AI picks up my AMD Radeon HD 8500M Graphics Card.

\\Program Files\Adobe\Adobe Illustrator CC 2019\Support Files\Contents\Windows\AIGPUSniffer.exe

Hope this spares, anyone else with a similar situation, 2 days of irritation in the future.

Regards,
Mark

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 12, 2019

Copy link to clipboard

Copied

worked for me as our graphic card is same..thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 01, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...