Highlighted

Align stroke to inside option greyed out

Explorer ,
Feb 24, 2017

Copy link to clipboard

Copied

Hi,

I know that this has been discussed in other posts, but there doesn't seem to be a definitive answer for this.

In the attached I'd like to align the white stroke to the inside, but as you can see in the appearance panel that option is not available.

How can this be remedied?

Thanks!

Screen Shot 2017-02-24 at 7.48.46 PM.png

Adobe Community Professional
Correct answer by Kurt Gold | Adobe Community Professional

The reason why you can't choose to align the stroke inside is because you applied the appearance set at the group level. Technically it could or should be possible to use it with strokes at the group level, but at the moment it's better to accept that limitation in a good temper, rather than debating why it doesn't work.

As already mentioned, the common workaround is to use the Offset Path effect instead, but it may be hurtful if you were going to constantly change the stroke weight for some reason. If that applies to your needs, you could go another route.

Prior to applying your appearance sets at the group level, you could take your group and – in the Appearance palette – double click the Contents item to get access to the appearance attributes of the single or probaly compound objects inside the group. Then you may set up your appearances. You will realize that the option to align strokes inside is now available.

TOPICS
Draw and design

Views

33.5K

Likes

Translate

Translate

Report

Report
This conversation has been locked.

Align stroke to inside option greyed out

Explorer ,
Feb 24, 2017

Copy link to clipboard

Copied

Hi,

I know that this has been discussed in other posts, but there doesn't seem to be a definitive answer for this.

In the attached I'd like to align the white stroke to the inside, but as you can see in the appearance panel that option is not available.

How can this be remedied?

Thanks!

Screen Shot 2017-02-24 at 7.48.46 PM.png

Adobe Community Professional
Correct answer by Kurt Gold | Adobe Community Professional

The reason why you can't choose to align the stroke inside is because you applied the appearance set at the group level. Technically it could or should be possible to use it with strokes at the group level, but at the moment it's better to accept that limitation in a good temper, rather than debating why it doesn't work.

As already mentioned, the common workaround is to use the Offset Path effect instead, but it may be hurtful if you were going to constantly change the stroke weight for some reason. If that applies to your needs, you could go another route.

Prior to applying your appearance sets at the group level, you could take your group and – in the Appearance palette – double click the Contents item to get access to the appearance attributes of the single or probaly compound objects inside the group. Then you may set up your appearances. You will realize that the option to align strokes inside is now available.

TOPICS
Draw and design

Views

33.5K

Likes

Translate

Translate

Report

Report
Feb 24, 2017 0
Adobe Community Professional ,
Feb 25, 2017

Copy link to clipboard

Copied

Use the effect > Path > Offset path instead. Negative value moves to the inside

Likes

Translate

Translate

Report

Report
Feb 25, 2017 2
Adobe Community Professional ,
Feb 25, 2017

Copy link to clipboard

Copied

The reason why you can't choose to align the stroke inside is because you applied the appearance set at the group level. Technically it could or should be possible to use it with strokes at the group level, but at the moment it's better to accept that limitation in a good temper, rather than debating why it doesn't work.

As already mentioned, the common workaround is to use the Offset Path effect instead, but it may be hurtful if you were going to constantly change the stroke weight for some reason. If that applies to your needs, you could go another route.

Prior to applying your appearance sets at the group level, you could take your group and – in the Appearance palette – double click the Contents item to get access to the appearance attributes of the single or probaly compound objects inside the group. Then you may set up your appearances. You will realize that the option to align strokes inside is now available.

Likes

Translate

Translate

Report

Report
Feb 25, 2017 1
Engaged ,
Mar 16, 2017

Copy link to clipboard

Copied

I have the same problem. The object is not grouped.

Align Stroke: Inline / Outline is disabled.

Any ideas?

THANK YOU.

Screen Shot 2017-03-17 at 00.18.39.png

Likes

Translate

Translate

Report

Report
Mar 16, 2017 0
Adobe Community Professional ,
Mar 17, 2017

Copy link to clipboard

Copied

yorh.ekin  schrieb

I have the same problem. The object is not grouped.

Align Stroke: Inline / Outline is disabled.

Any ideas?

THANK YOU.

Screen Shot 2017-03-17 at 00.18.39.png

Please show what kind of objects these are? Live text? WHat kind of stroke? Is that even one object? Or more?

Likes

Translate

Translate

Report

Report
Mar 17, 2017 1
Community Beginner ,
Oct 24, 2017

Copy link to clipboard

Copied

I'm going to tell you how to fix this; however, I want to point something out.

"it's better to accept that limitation in a good temper, rather than debating why it doesn't work." is never the right answer. I recognize the author might not work for Adobe and may be a way of commiserating with the person who posted the question.

Something like, “Thanks for the feedback. We recognize this is a problem. We’re working hard to make the experience better.” would be better.

Here’s a work around that worked immediately for me.

  1. Select the object you want to affect.
  2. Use the pathfinder panel and click on Exclude.
  3. Now go to the appearance panel and the align to inside/outside options should be enabled.

Likes

Translate

Translate

Report

Report
Oct 24, 2017 38
Adobe Community Professional ,
Oct 24, 2017

Copy link to clipboard

Copied

josephg44656780  schrieb

"it's better to accept that limitation in a good temper, rather than debating why it doesn't work." is never the right answer. I recognize the author might not work for Adobe and may be a way of commiserating with the person who posted the question.

90% of people here do not work for Adobe. Only those marked "Staff" do.

We are helping in our spare time and Kurt Gold is one of the most insightful Illustrator experts on the planet (at least in this forum).

None of us can or will speak on behalf of Adobe.

What you're telling us here doesn't make a lot of sense, since it doesn't solve the group issue. It doesn't even release the group. On top of that there are reasons for applying appearances at group level.

Likes

Translate

Translate

Report

Report
Oct 24, 2017 1
Community Beginner ,
Oct 24, 2017

Copy link to clipboard

Copied

The original post makes no mention of group issue. The problem states the alignment options are disabled in the appearance panel. The solution I offered does solve this problem of the alignment options being disabled.

Screen Shot 2017-10-24 at 1.15.44 PM.png

Screen Shot 2017-10-24 at 1.15.53 PM.png

Above is an example where the alignment options are disabled.

Screen Shot 2017-10-24 at 1.16.11 PM.png

Above is the pathfinder step.

Screen Shot 2017-10-24 at 1.17.05 PM.png

Immediately after using pathfinder, the align Stroke options are enabled again.

This may not address other individuals' concerns over group levels, but it does address the problem, a problem reported in numerous forums online.

I too am helping in my spare time. I'm sure Kurt Gold is quite insightful. My post clearly identified that Kurt may not work for Adobe.

I hope this is helpful for anyone experiencing this problem. Please do let me know if I have made a mistake in the execution steps.

Likes

Translate

Translate

Report

Report
Oct 24, 2017 10
Adobe Community Professional ,
Oct 24, 2017

Copy link to clipboard

Copied

josephg44656780  schrieb

The original post makes no mention of group issue.

It's in the screenshot.

Likes

Translate

Translate

Report

Report
Oct 24, 2017 0
Community Beginner ,
Nov 06, 2017

Copy link to clipboard

Copied

You're welcome

Likes

Translate

Translate

Report

Report
Nov 06, 2017 3
Explorer ,
Dec 07, 2017

Copy link to clipboard

Copied

Thank you Joseph, this was very helpful and solved my problem (my stroked object was not in a group).

Likes

Translate

Translate

Report

Report
Dec 07, 2017 1
Adobe Community Professional ,
Dec 07, 2017

Copy link to clipboard

Copied

joseph's solution turns a group into a compound path, just to note.

this may or may not be what you want. if you're like the topic creator and have several strokes at group level, it won't be what you want.

Likes

Translate

Translate

Report

Report
Dec 07, 2017 0
New Here ,
Oct 02, 2018

Copy link to clipboard

Copied

Thanks man - sorted. 

Likes

Translate

Translate

Report

Report
Oct 02, 2018 0
New Here ,
Dec 14, 2018

Copy link to clipboard

Copied

This worked for me! thank you!!

Likes

Translate

Translate

Report

Report
Dec 14, 2018 0
Explorer ,
May 23, 2019

Copy link to clipboard

Copied

That does't help. It still does not work.

Likes

Translate

Translate

Report

Report
May 23, 2019 0
Adobe Community Professional ,
May 23, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Mike+Fernbank  schrieb

That does't help. It still does not work.

Please post a screenshot with appearance and layers panel visible.

Likes

Translate

Translate

Report

Report
May 23, 2019 0
New Here ,
Oct 27, 2019

Copy link to clipboard

Copied

Thank you..helped me.

Likes

Translate

Translate

Report

Report
Oct 27, 2019 0
Community Beginner ,
Nov 27, 2019

Copy link to clipboard

Copied

that worked for me, thank you.

Likes

Translate

Translate

Report

Report
Nov 27, 2019 0
Participant ,
Aug 23, 2020

Copy link to clipboard

Copied

Perfect solution. I ran into this several times on compound paths now, hopefully some day I'll actually remember and not waste at least 30 minutes on a minor issue like this one. Thank you!

Likes

Translate

Translate

Report

Report
Aug 23, 2020 0
New Here ,
Mar 22, 2020

Copy link to clipboard

Copied

Changing the brush definition setting to "Basic" has opened up those stroke alignment options for me. When the stroke was set as "5 pt round" the alignment options were greyed out.

Likes

Translate

Translate

Report

Report
Mar 22, 2020 0
Resources