Highlighted

Alignment / Snapping Problems in CS5 Illustrator

Community Beginner ,
Jul 07, 2010

Copy link to clipboard

Copied

I'm experiencing what I considerable a major issue in CS5 where I have points and lines that are, apparently, snapping to some unknown grid or point.

It's most noticeable when I'm working on an illustration, and then I scale it down.. all of a sudden things get wonky.

I'm a longtime illustrator user and am pretty familiar with the ins and outs of these functions... just wondering if something has changed in CS5 or if anyone else has experienced this... and obviously looking for a solution. Thanks!

BJ Heinley

howdy@heinley.com

Screen shot 2010-07-07 at 12.57.54 PM.pngScreen shot 2010-07-07 at 12.58.18 PM.png

Clicking on the Transorm, click the flyout menu and uncheck align new objects to pixel grid works.

Thanks Jesseham

Views

48.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Alignment / Snapping Problems in CS5 Illustrator

Community Beginner ,
Jul 07, 2010

Copy link to clipboard

Copied

I'm experiencing what I considerable a major issue in CS5 where I have points and lines that are, apparently, snapping to some unknown grid or point.

It's most noticeable when I'm working on an illustration, and then I scale it down.. all of a sudden things get wonky.

I'm a longtime illustrator user and am pretty familiar with the ins and outs of these functions... just wondering if something has changed in CS5 or if anyone else has experienced this... and obviously looking for a solution. Thanks!

BJ Heinley

howdy@heinley.com

Screen shot 2010-07-07 at 12.57.54 PM.pngScreen shot 2010-07-07 at 12.58.18 PM.png

Clicking on the Transorm, click the flyout menu and uncheck align new objects to pixel grid works.

Thanks Jesseham

Views

48.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 07, 2010 1
New Here ,
Jul 07, 2010

Copy link to clipboard

Copied

Having the same problem - was trying to align a vertical line with the center point in a circle - the closest I could get the line to the center poitn was approx 1 pixel up and 1 pixel left. I've never experienced a precision problem like this in Adobe products before - very strange. Tried changing keyboard increments and transparency grid resolution ot see if anything would change it. If I make the circle and line larger, it works OK. Also, when scaling things down, they now become slightly out of alignment.

Screen shot 2010-07-07 at 2.46.56 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2010 0
Advisor ,
Jul 07, 2010

Copy link to clipboard

Copied

Is "view -> snap to grid" turned on or is "align new objects to pixel grid" (in the flyout menu of the transform panel) checked?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2010 1
Community Beginner ,
Jul 07, 2010

Copy link to clipboard

Copied


This might have worked ..

--»  Align new objects to pixel grid" (in the flyout menu of the transform panel)

... I'm going to do some further tests this evening, but I just did a quick one and it seemed to do the trick!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2010 0
New Here ,
Jul 10, 2010

Copy link to clipboard

Copied

Clicking on the Transorm, click the flyout menu and uncheck align new objects to pixel grid works.

Thanks Jesseham

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2010 3
Community Beginner ,
Jul 22, 2010

Copy link to clipboard

Copied

THANK YOU, THANK YOU, THANK YOU. This issue was driving me absolutely crazy. THANK YOU!!!!


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2010 0
New Here ,
Jul 27, 2010

Copy link to clipboard

Copied

Turned off align to pixel grid and snap to grid was off - it doesn't fix it. Don't know why it's working for everyone else but it's not for my computer. Smart guides are off too. all snapping is off.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 27, 2010 0
New Here ,
Jul 21, 2010

Copy link to clipboard

Copied

Thank God for this thread because I having the same issue.  Unchecking the "Align to Pixel Grid" fixed my issue.   Thanks Jess...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2010 0
New Here ,
Jul 30, 2010

Copy link to clipboard

Copied

This wasn't solved for me either after turning off the 'Align New Objects to Pixel Grid' or unchecking everything in my smart guides preferences. I am working on a small scale to begin with and this is frustrating the crap out of me because I never had this problem in Illustrator CS3.

Please Help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2010 0
Community Beginner ,
Aug 19, 2010

Copy link to clipboard

Copied

I agree.. how retarded is it that it's checked in the first place! -BJ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2010 0
Community Beginner ,
Aug 19, 2010

Copy link to clipboard

Copied

I’ve still got this issue, and the fly-out menu setting hasn’t worked for me either.

Furthermore, I’ve got another related problem in working at small sizes, when objects aren’t the size they should be, further adding to aligning woes. I tried to align a small circle and square, and not only were they not aligned, they weren’t the right size either.

E.g. I created a 4mm x 4.mm cirle using the elipse tool, and a “square” using the rectangle tool dialog box, which then patently wasn’t square on screen, and bringing up the dialog box it now read 3.88mm x 4.2mm. They wouldn’t align centre to each other either.

Any other suggestions very welcome!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2010 0
Community Beginner ,
Aug 19, 2010

Copy link to clipboard

Copied

You don't use the flyout menu, there's a checkbox in the transform panel which you have to uncheck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2010 3
Community Beginner ,
Aug 19, 2010

Copy link to clipboard

Copied

Ah thanks, psisar, that’s good of you to get back to me so quickly, but the fly-out menu should change the pixel alignment setting for the whole document (like un-checking the tick box in the initial set-up panel when you create a new document).

I think that I see the problem may be that if you change the over-all setting via the fly-out) it doesn’t make the change to all existing objects, only to new ones (which is fair enough, but not something which was obvious to me in the middle of last night). The good thing is, once you have made the change in the fly-out menu, you won’t have to un-tick in the alignment panel any more.

Better yet, un-tick it when you make a new document, and the problem doesn’t arise.

I think having it checked as the default is an error, really: I presume it helps those who use Illustrator in web-work, but it was counter-intuitive for a print based person like me.

But thank you once more for the help - it clarified something which was puzzling me.

Simon

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2010 1
Adobe Employee ,
Aug 19, 2010

Copy link to clipboard

Copied

The setting Align to Pixel Grid is available in 4 places:

1. In the New Document Dialog under Advanced. Here it is on by default ONLY for the Web profile and Flash Catalyst profile

2. In the Transform panel. Here it controls individual selections.

3. In the flyout menu of the transform panel. Here the setting is Align New Objects to Pixel Grid and it only controls newly created objects, NOT anything that is already in the document.

4. In the Symbol Options dialog. Here it sets whether each instance of a symbol will be pixel adjusted.

There is also an option available under the Select menu: Select > Object > Not Aligned to Pixel grid. You can use this to check for alignment after creating content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2010 1
Community Beginner ,
Aug 19, 2010

Copy link to clipboard

Copied

Many thanks for the clarification, davidmacy; I found that the profiles supplied were singularly unhelpful to me - I work as standard in RGB at A4, which I had though pretty normal, but Adobe hadn’t thought to include, so have had to work with a custom set-up, based on the “Basic RGB” one - don’t know how/when I must have checked the box in the set up panel…

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2010 0
Adobe Employee ,
Aug 19, 2010

Copy link to clipboard

Copied

You are welcome.

You may want to create your own Document Startup Profile to add to the list that shows up in the New Document dialog

see

http://blogs.adobe.com/infiniteresolution/2009/05/startup_profiles_a_great_tool.html

for tips on what you can define in Document Startup Profiles. That blog was written before CS5, so now you can add the Align to Pixel setting to the list.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2010 0
Miercs LATEST
New Here ,
Mar 02, 2017

Copy link to clipboard

Copied

Had unchecked 'Align New Objects in Pixel Grid' which didn't work. Unchecking 'Align to Pixel Grid' on the Transform panel under the angle option does work. Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2017 0
New Here ,
Aug 31, 2010

Copy link to clipboard

Copied

This is all very well: I had the same problem with Align to Pixel Grid being checked. But now whenever I create a new object it rechecks the box so I must constantly uncheck it. Anyway to turn it off for the whole document?

Sorry disregard that. didnt read the above posts properly

Message was edited by: MeltingDog

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2010 0
Adobe Employee ,
Sep 01, 2010

Copy link to clipboard

Copied

Please see setting 3 listed in my post of Aug 19, 2010 10:53 AM in this same thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2010 0