Highlighted

Background disappears when saving to PDF

Explorer ,
Sep 10, 2009

Copy link to clipboard

Copied

Mac OS 10.4.11 Acrobat Pro CS4 - Saving an A4 file from Illustrator (or InDesign) with a complete colour background to PDF leaves out the background - see attachment. Even if I remove all the elements in the file and save it still leaves out the background. I have tried several resolution settings in the PDF dialog window, used spot plus CMYK colours and flattened before saving to PDF. Never had this problem with previous version of Illustrator/Acrobat, I have also posted this in the Acrobat Forum as I am unsure which program is the offender.

Most Valuable Participant
Correct answer by Jacob_Bugge | Most Valuable Participant

salochin,

Have you considered reinstalling Acrobat?

Views

25.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Background disappears when saving to PDF

Explorer ,
Sep 10, 2009

Copy link to clipboard

Copied

Mac OS 10.4.11 Acrobat Pro CS4 - Saving an A4 file from Illustrator (or InDesign) with a complete colour background to PDF leaves out the background - see attachment. Even if I remove all the elements in the file and save it still leaves out the background. I have tried several resolution settings in the PDF dialog window, used spot plus CMYK colours and flattened before saving to PDF. Never had this problem with previous version of Illustrator/Acrobat, I have also posted this in the Acrobat Forum as I am unsure which program is the offender.

Most Valuable Participant
Correct answer by Jacob_Bugge | Most Valuable Participant

salochin,

Have you considered reinstalling Acrobat?

Views

25.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Sep 10, 2009

Copy link to clipboard

Copied

salochin,

What if you just create a rectangle with a fill in the back and use that as background?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Sep 10, 2009

Copy link to clipboard

Copied

Is the background on a layer that has been set to not print?

Is the background in a spot color with a long name?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 10, 2009

Copy link to clipboard

Copied

You may need to make the bleed area of the Artboard bigger. What is it currently set to. Make the bleed larger then the object which is bleeding. This is under File>Document Settings>Bleed and View Options. I have had this happen with a couple of files with background images and I just increased the bleed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 10, 2009

Copy link to clipboard

Copied

Jacob - the green background is already an A4 rectangle (210x297mm) the same size as the document.

Luke - The background layer has the print box ticked to allow it to print (see atttachment) and the spot colour is PANTONE 327CVC, shortening the name did not have any effect.

PrepressPro1 - the artboard (document) is set at A4 (210x297mm) with no extra bleed as the background has no bleed. However I then put a bleed of 8mm in the 'Document Setup' even though the document has no (green) background bleed - it is still missing the background in the subsequent saved PDF.

Bit of a bugger.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Sep 10, 2009

Copy link to clipboard

Copied

Is overprint preview turned on in Acrobat?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 10, 2009

Copy link to clipboard

Copied

I have tried all 4 variables in the 'Overprint Preview' drop-down menu in the Acrobat Preferences (see attachment) but the PDF document stubbornly refuses to show the background.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 10, 2009

Copy link to clipboard

Copied

In Acrobat, try Advanced>Print Production>Output Preview and play around with the settings there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 10, 2009

Copy link to clipboard

Copied

File: Open the native AI with Acrobat, tell me what you see.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 10, 2009

Copy link to clipboard

Copied

A few other things to try:

When you open the AI in Acrobat, open the Layers panel on the side. Are any hidden?

If the background is a spot color - in Acrobat, Advanced: Print Production: Output Preview: Does the spot color appear as white in the color list?

Back to AI. Double click on the spot color swatch. type in "PANTONE 327 C", hit enter. Double click swatch again, pull down to "Book Color" in Color Mode. Save as AI, enable PDF compatibility, then open the AI again in Acrobat.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 11, 2009

Copy link to clipboard

Copied

Larry - played around in Advanced>Print Production>Output Preview with no success.

Printer_Rick - opened AI saved with a preview with Acrobat (in AI I do not normally save with preview so it shows just text telling me so) and got the same no show background.

No info shown in Acrobat layers so assume must be hidden.

See attachment 4 for Advanced>Print Production>Output Preview to see the P327 spot colour clearly shown, I thought this may be just for the horizontal stripes rather than the background so removed stripes in AI and saved to PDF again and it still showed the spot colour as being there.

Changed the swatch to Book in AI and assume you mean by 'enable PDF compatibility' to save as a PDF which I did with no change to missing background.


Interestingly if you look at my attachment 5 of a saved PDF of the front cover of this brochure visual you will see that the green P327 background is shown. The only difference is the fact that this background does not cover 100% of the document page.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

Try saving as native Illustrator with "enable PDF compatibility". Then file open the AI with Acrobat.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

In the Illustrator file, do you have a Photoshop image placed that contains a spot color channel?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

salochin48 wrote:

No info shown in Acrobat layers so assume must be hidden.

Native AI with PDF compatibility always displays layers in Acrobat. On the left side of window in Acrobat, control or right click and go to Layers icon. It looks like two pieces of paper stacked.

I fall else fails, maybe you need to save a copy and expand the artwork. I'm not sure what's causing your problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 11, 2009

Copy link to clipboard

Copied

I do not understand the term "enable PDF compatibility" when saving the AI document, where does this show when saving an AI document

The channels in the 2 images used in this 'brochure back cover' have no apparent spot channels - see attachment 6. I also removed the images from the AI file and saved as PDF with the same no show background.

There is nothing showing in the Acrobat layers column in the back (failed background) or front (successfully shown background) covers of the AI files opened in Acrobat.

LAST GASP!

I have opened a new A4 document and put a rectangle (and only a rectangle - no other elements) of the same size and coloured it P327, then changed spot colour to P313, then changed it to a CMYK swatch, then to a RGB swatch, made the rectangle smaller to fit within the document and then bigger than the document. I saved all these changes after each action and not one showed the background, I am running out of options and am having to resort to using Acrobat 7 to get visuals of this particular page to show the background, which it does. Thanks for everyone's help but this maybe an Adobe problem and not a users one - are you monitoring this Adobe?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Sep 11, 2009

Copy link to clipboard

Copied

I have to say I really do not understand what is be discussed here the op has posted several png files and they all show a green spot background?

Why not show us the actual problem file as it actually displays without the background and perhaps post either the pdf or the ai file so we can take a look at it.

Quite frankly I do not actually see a file posted that shows what is happening to the file.

I am certain if the OP says it does not show up then that is so but perhaps if we actually saw the pdf as the problem shows there might be a clue.

Right now everyone is grasping for straws.

Also expand the layers show us the appearance panel the transparency panel something about the file.

Showing us the design does nothing here we need to see the problem.

I cross posted with the OP I see I have no problem with this color and saving to a PDF and having Acrobat 9 display it.Screen shot 2009-09-11 at 7.34.24 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

salochin48 wrote:

I do not understand the term "enable PDF compatibility" when saving the AI document, where does this show when saving an AI document

My terminology may have been confusing. When Save as AI, "Create PDF compatible file" is an option.

This creates a PDF output rider portion for other applications. It is a dual file format. Illustrator layers should be plainly visible when the AI file is opened in Acrobat. You can drag any AI file saved with PDF compatibility onto your Acrobat icon, to view the PDF content portion of the file.

If you do not see in Acrobat what you see in Illustrator - we have an object issue, or a layer issue, or a swatch issue. Try creating a brand new layer in Illustrator, and make a new colored box in this layer. Make sure the layer is set to print.

Also in illustrator go to Window: Separation Preview: Overprint Preview. See if this alters the appearance in Illustrator.

I see you have Acrobat 7. Maybe you could view the file in Adobe Reader version 9, if you have it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

salochin48 wrote:

I am running out of options and am having to resort to using Acrobat 7

Please disregard my reference to Acrobat 7. I think I misunderstood you.

A few more things. What icon is beside the spot swatch in Illy - CMYK, RGB, or Lab?

What happens if you change the spot color to Process?

I'm not sure if you have mentioned. Is your AI file an RGB document, or a CMYK document?

What happens when you go to "Add Used Colors" in the swatch panel in Illustrator?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 11, 2009

Copy link to clipboard

Copied

Wade - Find attached the PDF problem file, should have posted it earlier - blindingly obvious when pointed out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

This PDF looks OK to me in Acrobat and Illustrator. The only issue might be the thick solid rules on the right. They are process while the background is spot color. They won't match when the document is printed.

Preflight flags for low resolution images, also you don't have bleed in the PDF but I'm assuming this is just a quick test output.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

It is simple enough to re-color the solid rules as the Pantone in Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

I don't see where there is any Background missing. The PDF you posted has a Background of PMS 327. So what are you talking about when you say the "Background" is missing in the PDF? We have not idea what your background is supposed to look like, if it is not just a flood of PMS 327. We can't see what you are thinking it should look like in your mind. So please tell us what is, if anything, actually missing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 11, 2009

Copy link to clipboard

Copied

Printer_Rick - I have tried it in Spot, CMYK and RGB with no difference, also nothing happens when I "Add Used Colors" in the swatch panel.

I changed the thick rules/stripes from process to spot, resaved as PDF and they now do not show any P321 colour - stripes or background. Oddly if I reverse the colours from process background to spot stripes I still do not get the background showing.

PrepressPro1 - The background is a flood of P321 and if you look at my first attachment 'Picture 1.png' you will see it as it should be and indeed as it appears when I view it in Acrobat pro 7 but not in Acrobat CS4.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

This must be an issue with your Acrobat 9. Are you updated to 9.1.3?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 11, 2009

Copy link to clipboard

Copied

What version of Acro9? Have you updated to 9.1.3? It views on my machine with Acro9.1.3 as the first .png you posted.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Sep 11, 2009

Copy link to clipboard

Copied

I can see it in Acrobat 8.1.6 and in Acrobat 9.1.3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Sep 11, 2009

Copy link to clipboard

Copied

salochin,

Have you considered reinstalling Acrobat?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Sep 11, 2009

Copy link to clipboard

Copied

here does not seem to be anything wrong and I have yet to see a image

of this file as it is displayed on his screen with the missing

background.

and nor do I recall this being a problem before the update and I

cannot believe that there is no one here or anywhere ese hat has never

encountered this problem if it actually was an

issue.

he OP has to show us the problem in order for this to be believable!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 14, 2009

Copy link to clipboard

Copied

Jacob - Reinstalling Acrobat was the right thing to do, problem resolved, flooded background colour now shows.

Wade - I can assure you that this problem has been believable from my end, in fact its been a pain in the arse for me.

Thanks to every body who contributed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Sep 14, 2009

Copy link to clipboard

Copied

For my part you are welcome, salochin.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Sep 14, 2009

Copy link to clipboard

Copied

Salochin48

there is still nothing wrong with the file and if that was not information that you found valuable I will keep it in mind in the future.

I found out that there are some users out here that I personally can never help you may be one of them. I'll keep it in mind.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 14, 2009

Copy link to clipboard

Copied

Wade - you were not helpful - just abrasive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Sep 14, 2009

Copy link to clipboard

Copied

And now you've convinced me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Sep 24, 2009

Copy link to clipboard

Copied

This is the solution:

Acrobat > Preferences > General > Accessibility...

...at the top: "Replace Document Colors" toggle off...

Worked for me anyway - the symptoms are the same.

I inadvertantly set it this way when trying to find a method by which I could change the background colour from the default grey; then, for one reason or another, forgotten what I'd done.

Hope this helps other people as daft as me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 13, 2010

Copy link to clipboard

Copied

Omigod! Thank you for the answer to this vexacious problem. I had done the same thing—tried to change the canvas color on PDF files. I don't even remember checking that box, but this has been giving me a headache for a couple of months. I broke up background colors into smaller rectangles as a workaround. (Talk about daft!) I can't believe that all this time it was only how _I_ was seeing the PDFs. My clients would have seen them correctly. Thank you, thank you, thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 23, 2014

Copy link to clipboard

Copied

I was having the same problem..so glad I found this! Thank you!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 11, 2018

Copy link to clipboard

Copied

Thank you TommyTwoBrains.  This was the answer to my issue as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 20, 2020

Copy link to clipboard

Copied

My Gooooood thank you!!!

I was so angry because I thought it was an illustrator problem, thanks a lot

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...