Blank Page when exported Rhino drawing file into Illustrator

New Here ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

Hi everyone,

I have been very frustrated on why does my Rhino drawing file not appear at all in Illustrator. I exported the Rhino file as usual, and then opened it as an AI format in Illustrator. But there was nothing there, I tried to adjust the art board to see if I can catch the drawing but there was none. I tried and tried to export the file and open it again in AI to no avail. I am suspecting the reason that because I traced the object from a picture without making any measurements, and then changed the size of the object. But I believe that I have done that in the past and it still worked at that time? I'm very much confused and frustrated, as I no nothing about the cause of it. Just assumption after assumption. Please help. Thank you so much!

Views

24.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Nov 29, 2017 Nov 29, 2017
Well actually, the series of shortcuts I posted are unrelated to artboard-content fitting or any sort of artboard alteration.The 4 shortcuts I recommended are: Ctrl+0 (View > Fit Artboard in Window) Ctrl+ A (Select All) Ctrl+X (Edit > Cut) Ctrl+V (Edit > Paste)The straight default Paste command pastes the clipboard contents, centering them on the artboard. So all this does adjust the zoom level, and move all the objects to the artboard, preserving their relative positions.

Likes

Translate

Translate
Adobe Community Professional ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

"exported as usual" means exactly what?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

choose to export as dwg or as a 'print' as pdf and save to vector so you can choose the output scale 1:10 for example

you can even choose to use the view boundary if it is all on screen at the time of export.

stick a couple of dims on it in Rhino to check the size, its its over 30metres wide it or nowhere near the centre world axis point it will drift off into the ether outside the realms of what illustrator actually wants to show you,

try 'select all' and it will sometimes show up the line items way off the pasteboard, out in the area you can't actually move things to, but you can sometimes grab them from it and drag them back on to the visible area (we are talking about the slug area, not just outside of your chosen dartboard size.).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2017 Nov 28, 2017

Copy link to clipboard

Copied

This error is found when exporting from Rhino to AI with the 'preserving model scale' option checked. The exported .ai template is not actually blank; the objects are just located far beyond the canvas and not easy to simply drag from view. You can detect the objects with .AI Layers. I'm speculating this issue occurs when objects are not in proximity to the Rhino world origin point. I re-locate the CPlane (Rhino command CPlane) before exporting, but still the objects are not visible on the ai canvas (at least when exporting from Rhino for Mac). There's a Rhinoscript shortcut to move the origin point or you can manually drag your objects to the world origin point, but I've found the quickest work-around to simply export a new Rhino file with a new origin before exporting to AI.

In Rhino

1.) Select objects for Export

2.) File> Export with Origin

3.) Place the origin point at an intersection corner along your objects (using Osnaps helps)

4.) Open the new Rhino File

5.) Export as AI file with the preserving model scale option and appropriate scale chosen

This error does not occur when selecting the "snapshot of current view" Rhino export option.  You can always choose that option with known line dimensions and scale the objects accordingly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 28, 2017 Nov 28, 2017

Copy link to clipboard

Copied

knofaldesign  wrote

The exported .ai template is not actually blank; the objects are just located far beyond the canvas and not easy to simply drag from view.

Older thread, but yes, this can happen, especially with exports from 3D apps. A quick fix is to hold down Ctrl/Cmd and type the sequence 0AXV to fit the artboard in the window, select all, cut, and paste, which will land all content at a location centered on the artboard.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2017 Nov 28, 2017

Copy link to clipboard

Copied

Thanks for the additional information, but in most Rhino cases, that AI short key to 'Fit Artboard to Content' will not work. An AI error occurs stating, "Artboard size cannot be bigger than the canvas size." 

[Another approach: Select path using the .ai Layers menu and Object>Artboards>Fit to Selected Art]

There is a previous thread about modifying the canvas size. Since the paths are typically far beyond the canvas, it's much easier to control the location within the original 3D program as I stated above.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 29, 2017 Nov 29, 2017

Copy link to clipboard

Copied

Well actually, the series of shortcuts I posted are unrelated to artboard-content fitting or any sort of artboard alteration.

The 4 shortcuts I recommended are:

  1. Ctrl+0 (View > Fit Artboard in Window)
  2. Ctrl+ A (Select All)
  3. Ctrl+X (Edit > Cut)
  4. Ctrl+V (Edit > Paste)

The straight default Paste command pastes the clipboard contents, centering them on the artboard. So all this does adjust the zoom level, and move all the objects to the artboard, preserving their relative positions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 19, 2017 Dec 19, 2017

Copy link to clipboard

Copied

Finally! Thanks a lot!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 25, 2017 Dec 25, 2017

Copy link to clipboard

Copied

No problem.  You can also manually move the selected objects to the world origin in Rhino before exporting to .ai (Select Objects, Type 'Move', pick a point on/near the objects as the "Point to move from" and type "W0,0,0" in the box adjacent to 'Point to Move to" then export the newly moved objects to AI). The 'best' solution all depends on your own workflow. I prefer exporting the selected objects as a new Rhino 3DM file and controlling my origin point before the export to AI. Happy Holidays!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 19, 2018 Sep 19, 2018

Copy link to clipboard

Copied

LATEST

I also had that problem and then realized that my c plane was moved in top view... had to change it back to world view.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines