Blend Problem in AI 23.0.2

Guide ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

When I take two objects with the same number of points and blend them with "smooth color" I get only ONE step between the objects, rather than the SMOOTH COLOR I asked for.

"SmoothColor".png

This is a new issue with recent updates to AI.  😞

PLEASE FIX THE BLEND TOOL.

Thanks

-- Mac Pro (late 2013), OSX 10.13.6

Views

715

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

Just set it to specified steps and enter any number of steps that's appropriate.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

Yes, this is the workaround for the BUG, but shouldn't the BUG be addressed and fixed?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

I wonder if this is a Mac-specific bug ... ?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

DrStrik9  schrieb

Yes, this is the workaround for the BUG, but shouldn't the BUG be addressed and fixed?

It's not a bug. It always works like that when you blend certain colors or objects, e.g. groups.

And also it's not exactly a workaround. You should always check the number of steps. The smooth options might reate hundreds of objects, which for most designs is way too many.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

I've been using AI since v0.9b and until recently blends have NEVER "worked" this way. And I know very well that the number of blend objects in your "workaround" for this bug should vary to get the best results for blends between various colors. That's what "smooth color" is supposed to solve. But this line of thinking fails to address the issue.

To say it "always works like that" is simply false. It IS a bug, probably in the MacOS version. Denial of the problem doesn't solve it. -- In order to FIX the problem, first the problem must be acknowledged. The bug is clearly demonstrated in my original post. The fact that you have not been able to reproduce the bug doesn't mean it doesn't exist!

WHY is this happening here, after all these years of good blend performance? ... B-U-G.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

Well, maybe I'm wrong about this. I just booted AI again and did the exact same blend that failed before, and it works fine (smooth color).

So it seems what I thought was a bug is some kind of intermittent ghost. ...  😕

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

DrStrik9  schrieb

And I know very well that the number of blend objects in your "workaround" for this bug should vary to get the best results for blends between various colors. That's what "smooth color" is supposed to solve.

Smooth color doesn't adjust the number of steps based on the object size or anything. It works based on color values.

As for blending creating just one step: I have seen that happening in any version I have used (which is from CS2 and up).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

I can't duplicate your problem. It seems to be working just fine for me. Have you tried restarting the computer?

Screen Shot 2019-04-02 at 10.34.20 AM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

This is on a fresh boot. It's been happening this way for days.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

I've been having the same problem.  I have a mac as well.  7/10 times I have the same issue with the smooth blend tool.  

Screen Shot 2021-02-08 at 2.43.17 PM.png

 Here is a screenshot of me blending a light green square to a gradient.  (I have the same issue when blending to a solid colored shape as well.)  If I move the shapes far enough away, it appears to make some extra steps.  I'm not sure what the issue is.

Screen Shot 2021-02-08 at 2.45.38 PM.png

Although restarting my computer/program sometimes works, it often does not.  Is there a fix for this?

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Just open the blend options and enter the number of steps that work for you.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

Yes, I know that adding lots of steps will ultimately create a smooth blend-like appearance.  However, is there a way to use the smooth blend tool—not the one with specified steps.  Sometimes, using the work-around you suggested lags my computer.  Also, if the image is blown up, you will see the individual steps as opposed to the smooth gradient that the smooth blend tool offers.  I know that ultimately I can achieve the desired effect with what you suggested, but I would like to use the intended tool for its intended purpose.  Is there a way to do this—am I doing something wrong?  Or, is this a glitch which has yet to be addressed by Adobe?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

All the "Smooth" option does is trying tocalculate the number of steps necessary. And it might fail doing so. So you enter the necessary steps and that's it.

There will be hundreds of steps anyway, no matter how the get created.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

Ok!  I will do this in the meantime.  It seems like this has been an issue for a few years now.  Can I look forward to this being patched in the future?  Is there a way for me to report this bug to Adobe?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

I don't really see the issue there. Actually the manual control is better most of the time, because you definitely want to control it in a way that it doesn't create too many steps (which it does most of the time when calculating a smooth blend).

 

But if you want to report it, do so over there: http://illustrator.uservoice.com

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines