Boundary box on single text element (not text box) is bigger than the actual text

Community Beginner ,
Dec 10, 2020

Copy link to clipboard

Copied

Screenshot 2020-12-10 at 19.16.29.png

 

Hi there,

I've had this issue for a long time but I've just never got round to trying to fix it. Basically on a single line text element (so not a text box), the bounding box that surronds the text seems to not be in-line with the bottom of actual text. I have tried playing with the line height but as you can see that doesn't seem to make a difference.

 

Any help please?

TOPICS
Bug, Tools

Views

112

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Most Valuable Participant , Dec 10, 2020
pixxxelschubser Most Valuable Participant , Dec 10, 2020
Could it be that your font SF Pro Display does have a long long "g", "p", "j", "q", "y" ???    

Likes

Translate

Translate
Jump to answer Jump to answer
Most Valuable Participant ,
Dec 10, 2020

Copy link to clipboard

Copied

Do you see the problem (and the solution) ?

 

aaa3.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 10, 2020

Copy link to clipboard

Copied

Sorry no? Could you clarify please? If you are implying it is because the line height is set to 24pt then that is not the case. Shows the same bounding box when set to 'Auto' or 0.1. 

Could you please explain

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Dec 10, 2020

Copy link to clipboard

Copied

Sorry.

My mistake. I thought it was the baseline shift.

 

Have you tried another font? Is the behaviour the same?

Do you have a sreenshot with show hidden characters [Ctrl]+[Alt]+[I] enabled ?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 10, 2020

Copy link to clipboard

Copied

Ah that might be it then, hadn't thought it was actually font dependant. Tried it with 3 other fonts and got the same issue with 2 of them but the spacing was just less extreme, but one of them was completely normal. Interesting.

 

Screenshot 2020-12-10 at 21.01.56.pngScreenshot 2020-12-10 at 21.01.48.pngScreenshot 2020-12-10 at 21.01.42.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Dec 10, 2020

Copy link to clipboard

Copied

Obvious, but I'll ask anyway, is there a return at the end of the line?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Dec 10, 2020

Copy link to clipboard

Copied

@Met0D4D 

two souls one thought.

😉

 

That's why I asked for a new screenshot.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 10, 2020

Copy link to clipboard

Copied

Screenshot 2020-12-10 at 21.06.51.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Dec 10, 2020

Copy link to clipboard

Copied

Could it be that your font SF Pro Display does have a long long "g", "p", "j", "q", "y" ???

 

font_unterlaege.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
anguss39553567 AUTHOR LATEST
Community Beginner ,
Dec 10, 2020

Copy link to clipboard

Copied

I think that's it. Those letters seem to fill the box on the other fonts I tested but not the SF Pro one. There must be another character within the font set that is making the box that large. 

 

Thanks for your help!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more