BUG: OpenType superscript broken in Illustrator 25.0.1

Community Beginner ,
Dec 16, 2020

Copy link to clipboard

Copied

Assigning OpenType superscript features or superscript alternate glyphs does not appear to work in in Illustrator 25.0.1 (on MacOS Mojave). 
The menu opens, but nothing happens if you press the shown optional figure styles. Adding them manually from the Glyphs window or by assigning a different position setting in the OpenType settings pane doesn’t work either.

You can however copy text from elsewhere with unicode superscript characters and they will appear correctly. Tested with Adobe Myriad and Fakt Pro, so not a font issue.

Näyttökuva 2020-12-16 kello 14.12.01.png

Correct answer by JonatanH | Community Beginner

Seems I solved the issue: I turned off ”Show Indic options” in the Type menu under Preferences and now OpenType superscript works again. The ”show Indic options” feature seems to be somewhat broken in the English version of Illustrator.

TOPICS
Bug, Type

Views

85

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

BUG: OpenType superscript broken in Illustrator 25.0.1

Community Beginner ,
Dec 16, 2020

Copy link to clipboard

Copied

Assigning OpenType superscript features or superscript alternate glyphs does not appear to work in in Illustrator 25.0.1 (on MacOS Mojave). 
The menu opens, but nothing happens if you press the shown optional figure styles. Adding them manually from the Glyphs window or by assigning a different position setting in the OpenType settings pane doesn’t work either.

You can however copy text from elsewhere with unicode superscript characters and they will appear correctly. Tested with Adobe Myriad and Fakt Pro, so not a font issue.

Näyttökuva 2020-12-16 kello 14.12.01.png

Correct answer by JonatanH | Community Beginner

Seems I solved the issue: I turned off ”Show Indic options” in the Type menu under Preferences and now OpenType superscript works again. The ”show Indic options” feature seems to be somewhat broken in the English version of Illustrator.

TOPICS
Bug, Type

Views

86

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 16, 2020 0
Adobe Community Professional ,
Dec 16, 2020

Copy link to clipboard

Copied

What happens if you set Superscript in from the Chatacter panel menu?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2020 0
Community Beginner ,
Dec 16, 2020

Copy link to clipboard

Copied

That works, but it applies the generated superscript, not the proper character from the font. (Figures look too thin).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2020 0
Adobe Community Professional ,
Dec 16, 2020

Copy link to clipboard

Copied

I tried Myriad Pro and it seems to work fine:

Screenshot 2020-12-16 141836.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2020 0
Community Beginner ,
Dec 18, 2020

Copy link to clipboard

Copied

Myriad Bold, upper applied from the character panel in Illustrator, lower copied unicode superscript 2 U+00B2. The upper version is a scaled down figure, not the proper character. 

Näyttökuva 2020-12-18 kello 18.09.33.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2020 0
Community Beginner ,
Dec 18, 2020

Copy link to clipboard

Copied

Seems I solved the issue: I turned off ”Show Indic options” in the Type menu under Preferences and now OpenType superscript works again. The ”show Indic options” feature seems to be somewhat broken in the English version of Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2020 0
Community Beginner ,
Dec 18, 2020

Copy link to clipboard

Copied

Was able to reproduce the issue by turning ”Show Indic options” back on again. Turning it on did not break the superscript functionality, but when I restarde Illustrator with ”Show Indic options” checked OpenType superscript stopped working again, so it clearly is the cause of this bug. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2020 0
Most Valuable Participant ,
Dec 18, 2020

Copy link to clipboard

Copied

Try to set the Adobe Line Composer ( instead of the Arabic one) for these textframes.

There is no need to change the preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2020 0
Resources