BUG? - Regular font in SVG displayed as Italics

Contributor ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

Dear all,

I am pretty new to Illustrator.

I am colouring some musical scores which need a few notes and symbols coloured to convey specific situations. 

The scores are being created in Avid Sibelius 2021.2 (latest version) and exported as SVG page by page. I then open those SVGs in Illustrator 2021 (as of today no update available) and start the colouring process. 

The font being used for the text is called Academico and should be an open source to download. 

Finally, I am on macOS Big Sur 11.2.1 and this bug I'm about to report seems not to reproduce on Windows. 

 

Please download this SVG and check in Finder that the preview shows all text in Regular or Bold and that there is no Italics (as it should). Then open it in Illustrator and, at least on my system, it shows all Bold correct but all Regular as Italics. The whole experience can be seen in this video

 

Can someone tell me what is happening and why? 

Is there something I am doing wrong?

Thank you very much

TOPICS
Bug, Type

Views

35

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

SVG and Fonts are not the best friends in any case… Also the finder-Mac-Preview is not always the best.

 

Can you maybe export directly as PDF or AI from Avid???

 

Also Illustrator can easily replace Fonts all over the documet (Type menu)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

I can in PDF, yes! 
The curious thing is how this bug is not present on Windows, but just on Mac.

I also reset the fonts via a safe-boot but no luck... 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines