Highlighted

Cannot set specific color in Illustrator

New Here ,
Apr 12, 2019

Copy link to clipboard

Copied

When I try to set specific colors, Illustrator sometimes changes it to a nearby value. For instance, I cannot set the value H=217, S=100, B=42. When I click OK and open the Color Picker again, it has changed to H=214, S=100, B=41. When I set the values, both the "Out of gamut" and the "Out of Web Color" warnings are lit (guessing it has something to do with this).  However, the document is created in color mode RGB and when I look in File -> Document Color Mode, "RGB Color" is checked.

How can I disable this feature?

Views

500

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Cannot set specific color in Illustrator

New Here ,
Apr 12, 2019

Copy link to clipboard

Copied

When I try to set specific colors, Illustrator sometimes changes it to a nearby value. For instance, I cannot set the value H=217, S=100, B=42. When I click OK and open the Color Picker again, it has changed to H=214, S=100, B=41. When I set the values, both the "Out of gamut" and the "Out of Web Color" warnings are lit (guessing it has something to do with this).  However, the document is created in color mode RGB and when I look in File -> Document Color Mode, "RGB Color" is checked.

How can I disable this feature?

Views

501

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 12, 2019 0
Adobe Community Professional ,
Apr 12, 2019

Copy link to clipboard

Copied

HSB is converted to RGB immediately.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2019 1
New Here ,
Apr 12, 2019

Copy link to clipboard

Copied

Not sure what you mean, can you please clarify?

When I re-change the Hue value to 217 again, I can see that the color changes, so the hue 217 is not the same as 214.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2019 0
Adobe Community Professional ,
Apr 12, 2019

Copy link to clipboard

Copied

HSB is a different system than RGB and Illustrator converts your HSB to RGB via color management immediately after you enter close the color picker.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2019 0
New Here ,
Apr 12, 2019

Copy link to clipboard

Copied

Ok, but Illustrator still changes from one color to another (visibly). How can I disable that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2019 0
Adobe Community Professional ,
Apr 12, 2019

Copy link to clipboard

Copied

You can't.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2019 0
New Here ,
Apr 13, 2019

Copy link to clipboard

Copied

Ok, I can't disable it, but why does Illustrator change the color at all? What is so special about H=217, S=100, B=42 that makes it "invalid" as a choice?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2019 0
Adobe Community Professional ,
Apr 13, 2019

Copy link to clipboard

Copied

wgwrtgrtwegrfgeqrf  schrieb

Ok, I can't disable it, but why does Illustrator change the color at all? What is so special about H=217, S=100, B=42 that makes it "invalid" as a choice?

It's out of gamut. You can try and set your RGB working space profile to some larger profile such as Adobe RGB. But then when you export the image for printing or the web it will be converted anyway. I mean you can set any color you want, but if the presentation device can't handle it, it's only theoretical.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2019 0
Participant ,
Apr 12, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2019 1
New Here ,
Apr 13, 2019

Copy link to clipboard

Copied

Illustrator automatically does the conversion and I can see the corresponding RGB values. The problem here is more that Illustrator does not allow me to choose a particular color.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2019 0
Adobe Community Professional ,
Apr 13, 2019

Copy link to clipboard

Copied

It is probably better to use RGB values in an RGB document and use the Color Panel to minimize rounding errors.

Try the color Panel and enter H=217, S=100, B=42

You will notic it immediately change to H=217,01, S=100, B=41,96

Close and when rounded gives the correct values.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 13, 2019 0
New Here ,
Apr 15, 2019

Copy link to clipboard

Copied

I learned somehing new today...

Thanks to both of you, really appreciate your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2019 0
Community Beginner ,
Aug 14, 2020

Copy link to clipboard

Copied

The proper answer should be like:

In order to prevent AI's auto changing user colors we need to switch the document's color mode from CMYK to RGB:

File -> Document Color Mode -> RGB

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2020 0
Adobe Community Professional ,
Aug 14, 2020

Copy link to clipboard

Copied

I don't think that is the proper answer.

In order to prevent AI's auto changing user colors work with RGB colors in an RGB document and CMYK colors in a CMYK document.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2020 0