Change bounding box to fit anchor point instead of shape

New Here ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

I'm having an issue that only seems to have begun recently. Previously, when I scaled a line path, the bounding box for the path would be set according to the anchor points on the line - in other words, if I have a diagonal straight line with two anchor points, the bounding box would have the two anchor points as the two opposite corners in a rectangle.

 

Now, however, it seems that the bounding box is set to conform to the overall shape of the path. In other words, if you change the stroke thickness of the path, the bounding box also changes size. You can see this in the picture I've attached - the blue shows the current bounding box, and red shows what the bounding box should've been set to and what it would have been in the previous settings.

 

The new setting is not great for my uses as I have a lot of line drawings where lines are meant to connect at the anchor points, not at the visual boundaries of the path itself. This means that if I need to scale a path's size proportionally, I will have to set the path stroke to 0 first, otherwise it will scale the line using the edge of the stroke as the reference point, instead of the anchor point like I need.

 

I'm not sure if this was a feature that's always been there that I unknowingly triggered, or if it's something that was changed with one of the most recent updates to Illustrator. What I'm wondering now is if there is some way to change the bounding box settings back to what they previously were. Setting the path stroke to 0, scaling a path, then changing the stroke thickness back to what it was isn't the worst solution, but it will slow things down a fair bit and I would like to avoid that workaround if possible.

TOPICS
Draw and design, How to

Views

72

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

New Here , May 14, 2021 May 14, 2021
UPDATE: I'm going to leave this comment here as my "resolved" flag as I can't edit or delete my posts. For anyone who stumbles across this same issue in the future, my problem turned out to be that Use Preview Bounds was turned on. If you're having the same issue go to Edit > Preferences (or just Ctrl K) and go to the General tab, and make sure that Use Preview Bounds is unchecked.

Likes

Translate

Translate
New Here ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

LATEST

UPDATE: I'm going to leave this comment here as my "resolved" flag as I can't edit or delete my posts. For anyone who stumbles across this same issue in the future, my problem turned out to be that Use Preview Bounds was turned on. If you're having the same issue go to Edit > Preferences (or just Ctrl K) and go to the General tab, and make sure that Use Preview Bounds is unchecked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines