Change language for check spelling

New Here ,
Apr 28, 2009

Copy link to clipboard

Copied

Does somebody knows how to change the language? Because my text is in spanish and I need to check the spelling, but it detects that everything is bad written obviously because it is checking in english... Is there a plug-in to let illustrator to do that? or if it is already included with the normal installation, where can I activate it?

I hope somedody can help me because i'm tired of checking the spelling in another program like Word and then to copy it or rewrite it in illustrator.

Thanks.

Views

36.2K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Community Beginner , Jun 20, 2018
nicolew41455402 Community Beginner , Jun 20, 2018
All language preferences were set to English (USA). I ended up resolving the issue by reseting all the language preferences again, exiting out of all Adobe apps in my dock. Signing out form my adobe account, resigning in and launching Illustrator again. Seemed to have been a bug fixed by a soft restart of the programs.

Likes

Translate

Translate
Jump to answer Jump to answer
Participant ,
Apr 28, 2009

Copy link to clipboard

Copied

I don't know for sure, but I expect at the very least you would require the OS to have Spanish language support and/or Illustrator would have to be a Spanish version. I hope someone can chime in and give you a conclusive answer.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Sep 26, 2016

Copy link to clipboard

Copied

S.D.A. schrieb:

I don't know for sure, but I expect at the very least you would require the OS to have Spanish language support and/or Illustrator would have to be a Spanish version. I hope someone can chime in and give you a conclusive answer.

Completely wrong:

  1. Illustrator chooses the UI language according to the OS if installed.
  2. The UI language has nothing to do with the text language. The text has to be set up with appropriate language settings  in the Character and Paragraph Styles. It would also work to change the language in the Type Panel, but it is not recommended as it would be a manual style override.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Apr 28, 2009

Copy link to clipboard

Copied

Open the character palette (windows -> type -> Character) select show options from the submenu (top right corner of the palette). Select all your text, chose spanish from the drop down box in the character palette. Spanish spell checking is now working

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 26, 2016

Copy link to clipboard

Copied

Yes! Opening the character palette, selecting the appropriate text boxes and changing it to the desired language is the way to go here!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jun 19, 2018

Copy link to clipboard

Copied

None of this worked. Any other solutions?

My overall preference language is English (USA) and my character palette is also set to english (USA) but my dictionary is STILL stuck in Spanish. Any other ideas???

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 19, 2018

Copy link to clipboard

Copied

When you select your text: which language is set in the charaters panel?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jun 19, 2018

Copy link to clipboard

Copied

English (USA) believe it or not... wonder if it's an update glitch

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 19, 2018

Copy link to clipboard

Copied

And is the hyphenation working correctly?

What do you mean "stuck in Spanish"?

You set the Preferences and after you launch Illustrator, it's Spanish again?

If so, it might be an issue with your preferences in general. Are you sure that the privileges are set correctly on your machine? Wich version and system is it?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jun 20, 2018

Copy link to clipboard

Copied

All language preferences were set to English (USA). I ended up resolving the issue by reseting all the language preferences again, exiting out of all Adobe apps in my dock. Signing out form my adobe account, resigning in and launching Illustrator again. Seemed to have been a bug fixed by a soft restart of the programs.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 20, 2018

Copy link to clipboard

Copied

Select the text and  change the language to English in the character palette. The language of you text is set as a text attribute to font size, but makes most sense to set to entire paragraph, and then go back and set individual words if they are in another language.

Screen Shot 2018-06-20 at 10.27.47 AM.png

If you do not see the language at the bottom, click on the elevator buttons to toggle into the expanded mode (1 of 3 modes of this palette)

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jun 20, 2018

Copy link to clipboard

Copied

I did exactly that, SVERAL times. Didn't fix the issue. So I was left with signing out of my Adobe Account and restarting the programs. Then, and only then, did my dictionary go back to checking for words in English.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 03, 2020

Copy link to clipboard

Copied

Thank you for this! The screenshot really helped when I accidentally changed my text block to Hebrew. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Nov 03, 2020

Copy link to clipboard

Copied

Perfect!  For some reason one of my fonts defaulted to Dutch.   I have no idea why.   By going to the charachter panel solved it.  

THANK YOU!!!!!!!!!!!!!!!!!!!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 12, 2017

Copy link to clipboard

Copied

This works for InDesign as well! YAY! Thanks for the tip!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Sep 28, 2011

Copy link to clipboard

Copied

I finally found out how to do this and it's pretty easy. I downloaded the Adobestory program so I can set this from my computer, if this is your case, do this:

1- click on "sign out"

2- then in the upper right corner you can choose the language you want the spelling check to work with. click on it.

3- sign in with the new chosen language and the script writing will be set

downloading the app is no longer possible, so...

if you are using the online adobe story, then you'll have to look for the "language you want" page:

spanish: https://story.adobe.com/es-es/index.html

english: https://story.adobe.com/en-us/

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Sep 26, 2016

Copy link to clipboard

Copied

You should set up correct paragraph and character styles with the correct language.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 28, 2020

Copy link to clipboard

Copied

Thanks!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 20, 2018

Copy link to clipboard

Copied

I have run into an issue with spell checking in InDesign, sometimes it wants to default to German since I am in Germany and it gets annoying.  I always have to switch it back.  I never worked with spell check in Illustrator.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more