Highlighted

Export as PNG/JPG changing dimensions

Community Beginner ,
May 20, 2020

Copy link to clipboard

Copied

I created a document in Illustrator:  5" x 7" and 300ppi.  I added artwork and saved my design.  Then I export as PNG or JPG and the dimensions are completely different!

 

Why are they changing?

How do I stop that from happening?

 

I need my file to be exactly as I set it!

 

Thanks!

Views

611

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Export as PNG/JPG changing dimensions

Community Beginner ,
May 20, 2020

Copy link to clipboard

Copied

I created a document in Illustrator:  5" x 7" and 300ppi.  I added artwork and saved my design.  Then I export as PNG or JPG and the dimensions are completely different!

 

Why are they changing?

How do I stop that from happening?

 

I need my file to be exactly as I set it!

 

Thanks!

Views

612

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 20, 2020 0
Adobe Community Professional ,
May 20, 2020

Copy link to clipboard

Copied

Hi,

Are you artwok is same size as of artboard(5" x 7"). If yes, are you checking the checkbox for artboard while exporting into PNG? See screenshot for the same.

Screenshot 2020-05-21 at 11.43.50 AM.png

 

Also, I would suggest to read other threads similar to this.

https://community.adobe.com/t5/illustrator/illustrator-not-exporting-at-correct-pixel-size/td-p/3697...

 

Let us know if this helps

 

Best regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 20, 2020 0
Community Beginner ,
May 21, 2020

Copy link to clipboard

Copied

Hi, thanks for the reply!

The whole artwork is the size of the artboard and I also check the box "use artboards".

 

Thanks for the link to the other thread but I can't see a solution for me.  I have tried searching other threads and can't find a solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Community Professional ,
May 21, 2020

Copy link to clipboard

Copied

Hi,

Could you please share one png or jpg file, to check the difference in the sizes?

Best regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Community Professional ,
May 21, 2020

Copy link to clipboard

Copied

What are you using to check those dimensions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Community Beginner ,
May 21, 2020

Copy link to clipboard

Copied

After I've exported the file, I use the "get info" and it shows me the dimensions. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Community Beginner ,
May 21, 2020

Copy link to clipboard

Copied

Hi, I created a "test artwork" using my saved template of 5" x 7", 300PPI, CMYK.  The attached file is what I get when I export to PNGtest PNGtest PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Community Professional ,
May 21, 2020

Copy link to clipboard

Copied

In Illustrator you don't set up a file at a specific resolution. Vector files don't have a resolution.

If you want to export at the same pixel dimensions as the artboard is set up, export at 72 ppi.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 1
Community Beginner ,
May 21, 2020

Copy link to clipboard

Copied

Now this is where I get confused!  The client has asked me for a 5" x 7" artwork that will be printed.  So they want 300DPI.  I can't see DPI anywhere - just 300PPI so I chose that.  So will 72PPI be good enough quality to print?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Community Professional ,
May 21, 2020

Copy link to clipboard

Copied

Check your file in Photoshop and you will see that the dimensions are correct at 300 ppi.

Size.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 2
Community Beginner ,
May 21, 2020

Copy link to clipboard

Copied

Thanks for replying.  Your reply has just made me notice that there is a white border around my artwork - that just happens to be the size of the bleed! 

I am fairly new to Illustrator and now feel way out of my depth.  I have been creating artwork for a year now and saving as PDFs no problem so I'm surprised at these issues.

I just don't understand why my dimensions are changing and now why it is adding the bleed as part of the final design!

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Adobe Community Professional ,
May 21, 2020

Copy link to clipboard

Copied

You could try File > Export Selection... with your artwork selected.

That would export without the bleed.

Or get rid of the bleed in File > Document Setup 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0
Most Valuable Participant ,
May 21, 2020

Copy link to clipboard

Copied

KMo,

 

In addition to what charu referred to, the following may be worth the bore.

 

 

This may sound unforgivably outdated and boring, sorry.

 

If you wish to have PNGs (PNG24 (also (little) known as PNG32, it holds 24 bit colour and 8 bit Alpha channel (transparency)), of course) look crisp and clean, it is important to have the images in the exact desired final pixel x pixel size, forget about resolution which may actually lead to wrong sizes and hence blurriness. It is easiest and safest to work at the desired size.

 

A very common unsuitable way is to Export to PNG (remember to use PNG24 and use Transparency for artwork to be in front of different backgrounds) with a medium or high resolution, such as 300PPI.

 

And a common misunderstanding: (almost) 11 out of 10 times, a statement like "I created the document at 300 PPI" means that the value is chosen in Effect>Document Raster Effects Settings; however that only means that the (current) resolution of any raster effects applied to the vector artwork, such as (any kind of) Blur, is set to that value (and only unless/until the value is changed to something else); when zooming in, this resolution can be seen in contrast to and on the background of the vector artwork. So this setting has nothing whatsoever to do with the actual resolution of a raster image created from the (vector) artwork.

 

 

To retain the clean and crisp artwork, a PNG must be created at exactly the pixel x pixel size that it is to be used for, or at sizes that are powers of 2 times as large (2, 4, 8, and so on).

 


For clean and crisp artwork avoid JPEG.

 

It is also important to have the artwork and also the Artboard placed fully within integer/whole pixel X and Y values in the Workspace, which means that the X and Y values at the corners must be integer; this can be ensured by using one of the corner Reference Points in the Transform palette, and then checking that all the values X, Y, W, and H, are integer (the centre Reference Point can only be used if both W and H are even numbers). Otherwise the resulting image will become a bit wider/taller and the extension(s) will be empty and therefore be (partially) transparent/white.

 


Therefore, the safest way is to create the artwork at the final pixel x pixel size and use a corresponding Artboard, then either use the Legacity Save for Web (where you can look in the Image Size window for size confirmation) or Export at 72PPI. In either case, use the relevant optimization (available with both ways); it is also convenient to have 72PPI in the Effect>Document Raster Effect Settings.

 

If you have pure vector artwork, you can relax a bit and have the artwork/Artboard at any size (the Artboard must have the same proportions as the final image), then use the Legacity Save for Web and set either Width or Height in the Image Size and Apply (make sure the other value is also correct).

 

 

The Legacy Save for Web may be an old carthorse, but it knows its way home, even if the driver is drunk and sleeping it off in the hay in the back.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 1
Most Valuable Participant ,
May 21, 2020

Copy link to clipboard

Copied

KMo,

 

My answer above was delayed, and (mostly) outdated in terms of information in the meantime.

 

In addition to what Ton said, you need to set the resolution (300 PPI) in connexion with Exporting.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 1
Community Beginner ,
May 21, 2020

Copy link to clipboard

Copied

Thanks for taking the time to reply

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0