Highlighted

Exporting a pattern in PNG/JPEG format isn't showing

New Here ,
Jul 21, 2020

Copy link to clipboard

Copied

I'm exporting a pattern in JPEG and PNG format from Illustrator and it isn't showing. It looks fine on Illustrator but when exported it crops most of the pattern out. Any idea why this is happening?

 

How it appears in Illustrator:

Screenshot 2020-07-21 at 14.58.37.png

 

How it appears when exported in JPEG or PNG 72ppi format:

Quiz-06.jpg

TOPICS
Bug, Performance

Views

93

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Exporting a pattern in PNG/JPEG format isn't showing

New Here ,
Jul 21, 2020

Copy link to clipboard

Copied

I'm exporting a pattern in JPEG and PNG format from Illustrator and it isn't showing. It looks fine on Illustrator but when exported it crops most of the pattern out. Any idea why this is happening?

 

How it appears in Illustrator:

Screenshot 2020-07-21 at 14.58.37.png

 

How it appears when exported in JPEG or PNG 72ppi format:

Quiz-06.jpg

TOPICS
Bug, Performance

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 21, 2020 0
Adobe Community Professional ,
Jul 21, 2020

Copy link to clipboard

Copied

Is your artboard the same size as your artwork? Maybe it is cropped to the artboard size.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2020 0
New Here ,
Jul 21, 2020

Copy link to clipboard

Copied

The Artboard is the same size as the artwork. For some reason some patterns/artboards are exporting fine but others aren't exporting at all.

 

Artboard size shown here:

Screenshot 2020-07-21 at 15.22.35.png

 

 

I found a workaround - to expand the pattern first before exporting, but I shouldn't have to do this everytime should I? I've never had to do that in the past.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2020 0
Adobe Community Professional ,
Jul 22, 2020

Copy link to clipboard

Copied

No, you should not have to expand the pattern.

Can you share an example Illustrator file with the problem?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2020 0
New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

Hello, here is an example of an ai file I'm having issues with. I tried reinstalling illustrator but it still didn't work for me. Any ideas why this might be happening?

https://drive.google.com/drive/folders/1xHBRtVkOJKt64zZZpe6G6RahDI_7UK69?usp=sharing

 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Community Professional ,
Jul 23, 2020

Copy link to clipboard

Copied

Weird. Export for screens exports it without issues.

When using Save for Web I don't get any pattern in the export.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Community Professional ,
Jul 23, 2020

Copy link to clipboard

Copied

Works fine with Export for Screens or adding the grouped object to the Asset export panel, but behaves strange with Export As...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Community Professional ,
Jul 23, 2020

Copy link to clipboard

Copied

Older versions have problems too with the opacity masked area.

Which Illustrator version are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Community Professional ,
Jul 23, 2020

Copy link to clipboard

Copied

It seems the pattern and the opacity mask together cause the error. If you leave out one of them (and either delete the pattern or the mask from the object), Save for web works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Community Professional ,
Jul 23, 2020

Copy link to clipboard

Copied

Without the Opacity mask, but with 2 fills; a pattern fill and a gradient fill above it set to multiply, all exports work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Resources