Highlighted

Exporting for web

Explorer ,
Jul 21, 2020

Copy link to clipboard

Copied

I've just upgraded from a very old Illustrator to the latest version. In my old version, if I created a graphic and saved it for web Illustrator disregarded the artboard that the graphic was created on and just saved the graphic. In the new Illustrator, the graphic is there but it is surrounded by an enormous white space of the artboard. I went through the tutorial

 https://helpx.adobe.com/illustrator/how-to/export-assets-web-app-design.html

but at the end, it says to click the assets tab to select assets for export, I can't click anything because I have a save dialog box up. Saving a web graphic used to be so simple but not now. What am I doing wrong? Do I have to precisely resize the artboard each time I export to avoid having white space?

Adobe Community Professional
Correct answer by Monika Gause | Adobe Community Professional

In Export for screen you exported based on the artboard. The artboard is larger than the graphic and so you get all this whitespace. If you first drag the artwork into the Export Assets panel, you can export just the graphic.

In Save for web (Legacy) you have to uncheck the option "Use artboards"

TOPICS
How to, Import and export

Views

46

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Exporting for web

Explorer ,
Jul 21, 2020

Copy link to clipboard

Copied

I've just upgraded from a very old Illustrator to the latest version. In my old version, if I created a graphic and saved it for web Illustrator disregarded the artboard that the graphic was created on and just saved the graphic. In the new Illustrator, the graphic is there but it is surrounded by an enormous white space of the artboard. I went through the tutorial

 https://helpx.adobe.com/illustrator/how-to/export-assets-web-app-design.html

but at the end, it says to click the assets tab to select assets for export, I can't click anything because I have a save dialog box up. Saving a web graphic used to be so simple but not now. What am I doing wrong? Do I have to precisely resize the artboard each time I export to avoid having white space?

Adobe Community Professional
Correct answer by Monika Gause | Adobe Community Professional

In Export for screen you exported based on the artboard. The artboard is larger than the graphic and so you get all this whitespace. If you first drag the artwork into the Export Assets panel, you can export just the graphic.

In Save for web (Legacy) you have to uncheck the option "Use artboards"

TOPICS
How to, Import and export

Views

47

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 21, 2020 0
Adobe Community Professional ,
Jul 21, 2020

Copy link to clipboard

Copied

What exactly did you set up in Export for screens? Dragged your objects into the panel to export them object by object? Or do you export artboards?

Please show screenshots and tell us your steps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2020 0
Explorer ,
Jul 21, 2020

Copy link to clipboard

Copied

I just went FILE>NEW>COMMON, I dragged a logo into it from an old Illustrator file. I resized the logo and went EXPORT FOR SCREENS, I also tried EXPORT>SAVE FOR WEB>LEGACY and got the same thing, the logo was there but with a sea of white space of the artboard, this didn't happen in old versions of Illustrator. It just exported the graphic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2020 0
Adobe Community Professional ,
Jul 21, 2020

Copy link to clipboard

Copied

In Export for screen you exported based on the artboard. The artboard is larger than the graphic and so you get all this whitespace. If you first drag the artwork into the Export Assets panel, you can export just the graphic.

In Save for web (Legacy) you have to uncheck the option "Use artboards"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2020 0
Resources