GPU Performance turning off whenever using the Artboard tool in Illustrator 24.0.2 on macOS Catalina

Community Beginner ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

**EDIT 2 - I switched back to macOS Mojave 10.14.6 and it resolved the problem (still using Illustrator 24.0.2)**

Hello all, 

I encoutered a new bug yesterday after upgrading to Catalina and Illustrator v24.0.2 (from Illustrator 2018).
Whenever I click on the Artboard tool on a opened document (no matter the kind of doc, it even happened with a blank page) I have a quick screen flickering and then the "GPU Performance enhancements" is automatically turned off (making Illustrator extremly laggy) with the impossibility to turn it on again in this document (greyed text).

The only way to activate it again is to close and re-open the concerned document and to avoid using the Artboard tool.

 

The weird thing is that the GPU Performance enhancements is only turned off for the document where I used that tool, all the other opened docs still have it activated.

Does anyone encoutered the same problem or have a clue how to fix this ?


I'm on an IMac Pro 2017 / macOS Catalina 10.15.2 / 

Radeon Pro Vega 56 8 Go and I'm using Illustrator v24.0.2.

 

Thank you !


**EDIT - Just tried it with Illustrator 2019 v.23.1.1 and I encountered the same problem

 

{Renamed By MOD}

TOPICS
Performance

Views

214

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 15, 2020 Jan 15, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble that you are facing with Illustrator. I tried reproducing the issue on my end on macOS Catalina and Illustrator 24.0.2 however things worked fine. Will it be possible for you to share a small video of what exactly happening at your end?

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 15, 2020 Jan 15, 2020

Copy link to clipboard

Copied

Here's a video illustrating the problem ! (sorry for the loosy quality but it is a recording of a recording due to a bug in the initial app...)

 

As you can see, the GPU Performance enhancements is active by defaut then I create a new document and can activate/desactivate it via the menu bar and when I select the Artboard tool the GPU is automatically toggled off and unavailable until I close/re-open the file.

 

Don't hesitate if you need any other information or got some clue concerning this issue !

 

Thank you for your time !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 16, 2020 Jan 16, 2020

Copy link to clipboard

Copied

Hey,

 

I edited my post, as said, I switched back to macOS Mojave 10.14.6 and it resolved the problem (still using Illustrator 24.0.2).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 16, 2020 Jan 16, 2020

Copy link to clipboard

Copied

Glad to hear it has been resolved! Feel free to reach out if you run into any other questions or issues in the future. Thanks!   

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard

Copied

GPU performance is a complete mess. In the past, I had the ability to employ a workaround to activate GPU performance, however, now it is permanently greyed out and I have no choice but to run in CPU preview mode. GPU preview offers a large improvement over the traditional CPU mode and it is disappointing, to say the least, that this issue hasn't been resolved. Especially, when this has been a problem for a considerable amount of time. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

I am having this issue as well, it is super irritating, counterproductive and really slows down my workflow to have to constantly be closing and re-opening files simply to change the size of an artboard. I am currently running Mojave 10.14.4. Is there any solution for this other than closing and re-opening the file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

LATEST

Hi Scott,

 

So sorry to hear about this trouble. Could you please share a few more details like:

  • OS and version of Illustrator
  • Has it started happening after recent update? 
  • Does it happen after you turn on outline mode?

 

We're here to help, just need more info.

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines