Highlighted

GPU Preview on Mac version defective?

New Here ,
Jun 16, 2015

Copy link to clipboard

Copied

There seems to be innate strengths and weaknesses between CPU and GPU Preview:

GPU Preview: Image files look smooth; vectors and text look jagged

CPU Preview: Vectors and text look good; images look jagged

This is an inconvenience—something that I would like to see fixed so that constant switching between modes is not required, but it's not necessarily preventing me from getting work done.

However, it's becoming obvious that the GPU Preview mode isn't performing as intended on my system. It will stop rendering graphics when trying to zoom out beyond 20%, and eventually panning/zooming causes the document to stop displaying properly—until the setting is switched to CPU Preview. Going back to GPU Preview will return it to the glitched display image.

I'm running a late 2013 Mac Pro: 2.7 GHz 12-Core Intel Xeon E5, 12GB DDR3, 2x AMD FirePro D700 6144MB.

Are any other Mac users experiencing these same problems?

Most Valuable Participant
Correct answer by Jacob Bugge | Most Valuable Participant

kazuot,

It seems that there is still some work on getting the GPU performance to work properly. As well as enabling in preferences you have to enable in the view menu (preview on CPU or cmd+E)

You may also have a look here, including the Troubleshooting at the bottom; it is crucial thaet the video driver is fully updated:

https://helpx.adobe.com/illustrator/kb/gpu-performance-preview-improvements.html

If you cannot get it to work, it may better to wait until the issue is solved.

You may try disabling the GPU Performance by clicking above the Rocket Icon in the App bar and deselecting the GPU Performance check box.

Views

13.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

GPU Preview on Mac version defective?

New Here ,
Jun 16, 2015

Copy link to clipboard

Copied

There seems to be innate strengths and weaknesses between CPU and GPU Preview:

GPU Preview: Image files look smooth; vectors and text look jagged

CPU Preview: Vectors and text look good; images look jagged

This is an inconvenience—something that I would like to see fixed so that constant switching between modes is not required, but it's not necessarily preventing me from getting work done.

However, it's becoming obvious that the GPU Preview mode isn't performing as intended on my system. It will stop rendering graphics when trying to zoom out beyond 20%, and eventually panning/zooming causes the document to stop displaying properly—until the setting is switched to CPU Preview. Going back to GPU Preview will return it to the glitched display image.

I'm running a late 2013 Mac Pro: 2.7 GHz 12-Core Intel Xeon E5, 12GB DDR3, 2x AMD FirePro D700 6144MB.

Are any other Mac users experiencing these same problems?

Most Valuable Participant
Correct answer by Jacob Bugge | Most Valuable Participant

kazuot,

It seems that there is still some work on getting the GPU performance to work properly. As well as enabling in preferences you have to enable in the view menu (preview on CPU or cmd+E)

You may also have a look here, including the Troubleshooting at the bottom; it is crucial thaet the video driver is fully updated:

https://helpx.adobe.com/illustrator/kb/gpu-performance-preview-improvements.html

If you cannot get it to work, it may better to wait until the issue is solved.

You may try disabling the GPU Performance by clicking above the Rocket Icon in the App bar and deselecting the GPU Performance check box.

Views

13.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 16, 2015 0
Participant ,
Jun 16, 2015

Copy link to clipboard

Copied

Yyyyyep!  Me too.  Adobe released a product that touts its new GPU performance, and you can see the threads coming in about how TERRIBLE it is!  What a failed release.   Every "answer" to problems is answered by Adobe Staff by "turn off GPU preview". Wait?  Turn off the VERY feature you just trumpeted as the great new improvement to this release! 

I am sooooo disappointed that I purchased CC in the last week, after holding out with CS6 since it's inception. I doubt I will renew if this kind of stuff keeps up (I've got other MAJOR bugs with Illustrator that has made it Unusable so much that I still use CS6).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2015 3
Participant ,
Jun 17, 2015

Copy link to clipboard

Copied

Yeah, just noticed this myself once I upgraded to CC 2015. I was like, why are my vector Illustrator files looking like crud on-screen all of a sudden? Then I noticed the GPU/CPU preview options. So I selected CPU instead of GPU and now they look fine.

I have a supported GPU, BTW, that meets the minimum specs, but not quite the recommended specs, as my VRAM is a bit lower than that (late 2011 MacBook Pro, AMD Radeon HD 6770M -- 1024 MB VRAM, OpenGL 4.1).

Illustrator system requirements, from System requirements | Illustrator:

"To use the GPU performance features: Your Mac should have a minimum of 512 MB VRAM (2 GB recommended), and your computer must support OpenGL version 4.0 or greater."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2015 0
Most Valuable Participant ,
Jun 17, 2015

Copy link to clipboard

Copied

kazuot,

It seems that there is still some work on getting the GPU performance to work properly. As well as enabling in preferences you have to enable in the view menu (preview on CPU or cmd+E)

You may also have a look here, including the Troubleshooting at the bottom; it is crucial thaet the video driver is fully updated:

https://helpx.adobe.com/illustrator/kb/gpu-performance-preview-improvements.html

If you cannot get it to work, it may better to wait until the issue is solved.

You may try disabling the GPU Performance by clicking above the Rocket Icon in the App bar and deselecting the GPU Performance check box.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2015 1
Contributor ,
Jun 19, 2015

Copy link to clipboard

Copied

My issue is that GPU Preview stops Illustrator working at all. Raster images become invisible and then the entire app stops working.  Turning off GPU support in Illustrator makes everything work again.

I'm on a 2010 MacPro (5,1), 48GB RAM, 3.33GHz 6 core, GTX680 Mac edition and running off fast SSDs, so well up to the task, hardware-wise.

Premiere Pro is still a mess with Nvidia CUDA too - seems like Adobe has its work cut out dealing with GPUs at the moment.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2015 0
Adobe Community Professional ,
Jun 19, 2015

Copy link to clipboard

Copied

Dominic Witherow schrieb:

I'm on a 2010 MacPro (5,1),

That's a rather old machine so maybe it doesn't fit the specifications for GPU support.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2015 0
Contributor ,
Jun 19, 2015

Copy link to clipboard

Copied

Er, no. As shown in the specs (and as detailed in Adobe's spec requirements), it's more than up to the job.

The problem is with the software.  Whether that is an Adobe or Nvidia software problem is undefined, but it's not a hardware issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2015 2
Participant ,
Jun 23, 2015

Copy link to clipboard

Copied

Same thing on an iMac 5k. Deactivating GPU acceleration (and restarting Illustrator) is the only reliable workaround for me. If it’s activated, some (but not all) documents will not display anything and are totally unresponsive. In some documents it’s just the object border frames that are not displayed (switching to "Preview on CPU" helps with that).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2015 2
New Here ,
Aug 15, 2015

Copy link to clipboard

Copied

I am experiencing this same issue... Only in certain documents that were original composed with the CPU rendering.

Very frustrating.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2015 0
Explorer ,
Jun 19, 2015

Copy link to clipboard

Copied

Yeah, wow. I thought this was going to be useless for me for UI work because whether I have images or not in my file, I need the vector work to render properly, which it really doesn't by default:

GPU:

17IFx+

...that's pretty distracting, to the point of being unusable for anything that requires, you know, vector lines. This snippet combines pieces that are optimized for pixel grid (the box below) as well as pieces that are a bit artifacty because they are more for print (the device key above). But both look a lot better in the default

CPU:

122Nm+

HOWEVER, I did find that I can get the same look as CPU above while running on the GPU if I choose "pixel preview."

So it may not be too bad, except that right now, the pixel preview state gets set back to OFF whenever you toggle between GPU and CPU. I kind of wish the two settings were stored independently.

That shouldn't be too hard to do, and might make the GPU thing a good add for UI work, IF pixel preview doesn't just negate the performance increase.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2015 0