HELP: White lines appearing at edges when I export a 3D object to SVG?

New Here ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

I am trying to make a simple SVG to display on a webpage but when I export the SVG there are tons of white lines at every edge. Does anyone know a fix for this issue or have I done something wrong during create the objects?

bookshelf_white_lines.png

TOPICS
How to, Import and export

Views

223

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 02, 2020 Dec 02, 2020
That's just how the 3D effect works. It creates dozens of objects that are neighboring each other. When this is rendered on screen, then there is antialiasing. Or even worse: when exporting to SVG maybe you set the Decimals setting too low. You might need to take a different approach creating this.

Likes

Translate

Translate
Adobe Community Professional ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

That's just how the 3D effect works. It creates dozens of objects that are neighboring each other. When this is rendered on screen, then there is antialiasing.

Or even worse: when exporting to SVG maybe you set the Decimals setting too low.

 

You might need to take a different approach creating this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

Hi Monika, thanks for getting back.Apologies if this is ignorant but where would I set the decimnals when exporting the SVG? 

 

Also thanks for the advice, I'll have a go at creating this manually without the 3D effect instead! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

LATEST

Depending on which function you use for exporting, the Decimals setting is either in "More options" or in the format options which is hidden under the cog-wheel button.

The higher the value, the more exact the artwork will be.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines