Highlighted

How can I change Illustrator language to English?

Community Beginner ,
Sep 07, 2012

Copy link to clipboard

Copied

I have subscripted to Adobe Cloud and downloaded Photoshop/Illustrator but the default language at that time (in my Adobe Application Manager) was Portuguese so it installed the portuguese version of Photoshop and Illustrator.

Changing the language in Adobe Application Manager preferences and re-downloading Photoshop changed its language but the very same procedure didn't look like to work with Illustrator.

Can I have to setup something else in order to make it work?

I went to the Creative cloud, wheel sign at the upper right corner , chose Settings, the tab Apps, and chose English. Then de-installed the Illustrator, restarted the computer and installed the Illustrator anew. Now its interface is in English.

Topics

How to

Views

288.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How can I change Illustrator language to English?

Community Beginner ,
Sep 07, 2012

Copy link to clipboard

Copied

I have subscripted to Adobe Cloud and downloaded Photoshop/Illustrator but the default language at that time (in my Adobe Application Manager) was Portuguese so it installed the portuguese version of Photoshop and Illustrator.

Changing the language in Adobe Application Manager preferences and re-downloading Photoshop changed its language but the very same procedure didn't look like to work with Illustrator.

Can I have to setup something else in order to make it work?

I went to the Creative cloud, wheel sign at the upper right corner , chose Settings, the tab Apps, and chose English. Then de-installed the Illustrator, restarted the computer and installed the Illustrator anew. Now its interface is in English.

Topics

How to

Views

288.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Sep 07, 2012

Copy link to clipboard

Copied

You might have to reset the preferences also at the bottom of the characcter panel there is a selection for the language, if it is set to Portuguese currently change it to english

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2012

Copy link to clipboard

Copied

@Wade , isn't the language in the character pallete is the spell check language for the document /text ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 08, 2012

Copy link to clipboard

Copied

Wade

I didn't find the panel you've mentioned. What I have done before the download was to set my language to English (North America) as the picture shows. Is there another plane where I should set the language?

adobe.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 08, 2012

Copy link to clipboard

Copied

On the Macintosh I have to change the system language to get the corresponding application language.

I have 2 versions installed using the preferences in the Application Manager; at first English and later Dutch.

When I set the System language in Language and Text in the System Preferences to Dutch and log in again the language changes.

See also: Installing Multiple Languages of a Desktop Application

http://tv.adobe.com/watch/cs6-creative-cloud-feature-tour-for-design/installing-multiple-languages-o...

Ton

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 08, 2012

Copy link to clipboard

Copied

Ton

Changing Mac's language made it work. Thanks

But I think it's a little annoying to always have to change Mac language in order to set Illustrator language. Is there any other way to set it without having to mess with my mac's language?

Best

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 08, 2012

Copy link to clipboard

Copied

Not that i know of.

Looks like a feature request:

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

regards,

Ton

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2012

Copy link to clipboard

Copied

By default the AAM picks the language of the Operating System , which happened at the intial stage and caused this issue.

On changing the language of the AAM preferences and re-installation ideally should have worked and indeed for the PS but not for the Illustrator unfortunatly.

So , what has happened here with the Illustrator is you have 2 laguage pack installed Portugese and English and it is picking the language based on the system locale.

Log in the account (default user account) in which you want the Illustrator to be in English language , uninstall Illustrator and all Cs6 apps ,

Run the Cleaner tool :- www.adobe.com/support/contact/cscleanertool.html

Install the Illustartor with the correct language set in the AAM preferences.

There will be no need to switch the OS language as there would be just English language pack to launch.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 08, 2012

Copy link to clipboard

Copied

That is an interesting way to install a specific language while the OS language is different.

Unfortunately you cannot switch languages then.

I prefer the Photoshop way: install the languages you want with AAM and just switch between them in the Photoshop Preferences. It just requires a Photoshop restart to switch.

I think I will fill in the feature request form myself 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2012

Copy link to clipboard

Copied

Ton Frederiks wrote:

That is an interesting way to install a specific language while the OS language is different.

Unfortunately you cannot switch languages then

You can and that what is happening here with the Illustrator/

When OS language is Portugese then the illustartor language is Portugese becuase Illustrator is installed with the portugese language here first.

but when we re-installed it in English and then switched the OS language to the English , Illustrator was in English.

I agree that the PS preferences provide a flexibilty but there are many apps that doesn't have this feature like Ai, Indesign , Dreamweaver etc. so, you are more then welcome to fill in the feature request form asking for this feature.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2012

Copy link to clipboard

Copied

Check this :-

http://helpx.adobe.com/creative-cloud/kb/creative-cloud-trial-mode.html

So , people with english-only subscription doesn't need the English OS , they can have the OS in different language.

The product need to be installed with the language you want disregard of the OS language.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 10, 2012

Copy link to clipboard

Copied

Manish

Thanks a lot.

Your answer complemented wonderfuly what Ton said and I've done exactly what you said and now I have a Mac in Portuguese and Illustrator in English as I wanted.

So, to sumarize the answer:

1) Uninstall previous and current version of Illustrator.

2) Run CleanerTool to be sure that there isn't any file left behind.

3) Change Adobe Application Manager to the language you want to install Illustrator (in my case, North American English). I changed my Mac language (just in case) to English too.

4) Download and install Illustrator.

5) Change Mac language back to original language.

Thanks again for all support in this forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 09, 2015

Copy link to clipboard

Copied

Okay, so I know this is almost 3 years old, but I struggled a lot with this and finally found a solution for windows:

I'm on a windows 8.1 with adobe cc 2014

  1. Change language in CC and reinstall illustrator as described in the video posted earlier:
    http://tv.adobe.com/watch/cs6-creative-cloud-feature-tour-for-design/installing-multiple-l anguages-...
  2. Move undesired language pack file folders (mine was named da_DK for Danish) from the folders below to a backup location on your computer:
    1. Presets
    2. Extra features
    3. Support files > required > resources

Now when I open illustrator everything is in English!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 03, 2015

Copy link to clipboard

Copied

It's even easier to switch you UI language in Illustrator. Just rename the three folders that frbra1 mentioned to e.g. "en_US" (for the international English UI) or to "de_DE" for German and restart Illustrator - ideally deleting the Preferences by holding down the Shift+Control(Command)+Alt keys.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 03, 2015

Copy link to clipboard

Copied

Interesting, but can you excatly show where those 3 folders are that you want to change to de_DE?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 03, 2015

Copy link to clipboard

Copied

Sure, please see screenshot.

Illustrator-UI-Sprache-umschalten.png

They are named, on an English OS, as follows,a nd are located in the Illustrator application folder:

  1. Presets > en_US
  2. Extra features > en_US
  3. Support files > required > resources > enUS

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 03, 2015

Copy link to clipboard

Copied

Still interestng, but that means you have to open up the application itself and modify it. That is very tricky and I would not recommend it to anyone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 03, 2015

Copy link to clipboard

Copied

No, it does explicitely not mean that have to open up the application itself. It just means that you have to rename three folders. (Is that tricky?) If you're unsure, backup these three folders beforehand. It's fast, it's easy, and it does the trick. (What's really weird is that Adobe doesn't offer a menu command to switch the UI language. I'm not sure if this is a design error or if this just has been forgotten during design.)

The only thing you probably need are appropriate privileges to rename folders within your application folder.

Of course everyone is completely free in recommending whatever she/he wants.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 03, 2015

Copy link to clipboard

Copied

I see, on the Windows platform these folders are visible. On the Mac you don't see them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 04, 2015

Copy link to clipboard

Copied

Oh, I see - but it shouldn't be a problem to make them visible by standard Mac OS means. I realized that even your own "Library" folder is not visible by default in OS X.10 - very strange.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 25, 2016

Copy link to clipboard

Copied

It worked, Danke schoen!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 19, 2017

Copy link to clipboard

Copied

unfortunately this ain't working anymore...illustrator won't start after changing that folders on Mac

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 19, 2017

Copy link to clipboard

Copied

chrisf91281271  schrieb

unfortunately this ain't working anymore...illustrator won't start after changing that folders on Mac

Actually it never worked.

You have to either:

- install only one language of Illustrator

- change the system language to whatever language you want to run Illustrator in.

Changing folder names might have worked in other Adobe apps, but Illustrator works differently.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 20, 2017

Copy link to clipboard

Copied

Changing the folders' languages doesn't work on CC. The program does start but everything from within those folders becomes unaccessible. Basically Illustrator becomes unusable for a lot of things.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 20, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 21, 2017

Copy link to clipboard

Copied

frbra1

it worked on Mac,

CC 2018

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 20, 2017

Copy link to clipboard

Copied

You can also change the language easily on the fly;

File > Document Setup > Type   will lead you to a language drop-down menu that will allow you to change the document's default language easily

2.png1.png

3.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 21, 2017

Copy link to clipboard

Copied

angusgg  schrieb

You can also change the language easily on the fly;

File > Document Setup > Type   will lead you to a language drop-down menu that will allow you to change the document's default language easily

That doesn't change the document's language (let alone the application language which this thread is about). It only changes the language setting that is applied to text. Those influence the spell- and grammar checking.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 31, 2017

Copy link to clipboard

Copied

Thank you very much, you just save my life )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 09, 2017

Copy link to clipboard

Copied

I went to the Creative cloud, wheel sign at the upper right corner , chose Settings, the tab Apps, and chose English. Then de-installed the Illustrator, restarted the computer and installed the Illustrator anew. Now its interface is in English.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...