Highlighted

How do I link graphics in Illustrator (not embed)

Participant ,
Jul 14, 2010

Copy link to clipboard

Copied

If I copy paste a graphic, it embeds it. If I go to file "Place" it seems to also embed graphics in my illustrator docs.  The file size is already up to 100+MB.  How do you "link" graphics in your illustrator file to keep the file size small?

Adobe Community Professional
Correct answer by Scott_Falkner | Adobe Community Professional

When you use File > Place, make sure you click on the Link button at the bottom of the window.


Illustrator files can get very large, even when working with linked images. If you saved your file using the default options, you left Create PDF Compatible File on. This makes Illustrator save an embedded high resolution PDF of your file, and PDFs can only contain embedded images. You cannot edit the PDF portion of the file, it is used to provide cross-application compatibility with InDesign, Photoshop, Acrobat, or other programs that can read PDF but not Illustrator’s proprietary file format. If you are placing many high resolution images, you are going to see your file get quite large, even though the images re linked, at least as far as the editable Illustrator portion of the file is concerned.


If you do  not intend to access the Illustrator file using any program except Illustrator, you can save considerable space by turning the Create PDF Compatible File option off when you Save or Save As. I have seen files drop from over 200 MB to under 1 MB.

Views

50.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How do I link graphics in Illustrator (not embed)

Participant ,
Jul 14, 2010

Copy link to clipboard

Copied

If I copy paste a graphic, it embeds it. If I go to file "Place" it seems to also embed graphics in my illustrator docs.  The file size is already up to 100+MB.  How do you "link" graphics in your illustrator file to keep the file size small?

Adobe Community Professional
Correct answer by Scott_Falkner | Adobe Community Professional

When you use File > Place, make sure you click on the Link button at the bottom of the window.


Illustrator files can get very large, even when working with linked images. If you saved your file using the default options, you left Create PDF Compatible File on. This makes Illustrator save an embedded high resolution PDF of your file, and PDFs can only contain embedded images. You cannot edit the PDF portion of the file, it is used to provide cross-application compatibility with InDesign, Photoshop, Acrobat, or other programs that can read PDF but not Illustrator’s proprietary file format. If you are placing many high resolution images, you are going to see your file get quite large, even though the images re linked, at least as far as the editable Illustrator portion of the file is concerned.


If you do  not intend to access the Illustrator file using any program except Illustrator, you can save considerable space by turning the Create PDF Compatible File option off when you Save or Save As. I have seen files drop from over 200 MB to under 1 MB.

Views

50.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mentor ,
Jul 14, 2010

Copy link to clipboard

Copied

I think the Place dialog box gives you an option to place a checkmark next to Link but I can't troubleshoot for you right now unfortunately.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 14, 2010

Copy link to clipboard

Copied

When you use File > Place, make sure you click on the Link button at the bottom of the window.


Illustrator files can get very large, even when working with linked images. If you saved your file using the default options, you left Create PDF Compatible File on. This makes Illustrator save an embedded high resolution PDF of your file, and PDFs can only contain embedded images. You cannot edit the PDF portion of the file, it is used to provide cross-application compatibility with InDesign, Photoshop, Acrobat, or other programs that can read PDF but not Illustrator’s proprietary file format. If you are placing many high resolution images, you are going to see your file get quite large, even though the images re linked, at least as far as the editable Illustrator portion of the file is concerned.


If you do  not intend to access the Illustrator file using any program except Illustrator, you can save considerable space by turning the Create PDF Compatible File option off when you Save or Save As. I have seen files drop from over 200 MB to under 1 MB.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jul 15, 2010

Copy link to clipboard

Copied

Thanks both of you.  Scott, your last paragraph seems to be the solution.  My file went from about 150+MB to 4 MB.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
RothAnim LATEST
Community Beginner ,
Jan 28, 2014

Copy link to clipboard

Copied

This fixed my problem too.

I used image links to update files over multiple revisions, but it stopped working recently. I must have accidentally turned off that link check-box, so it was embedding all my files by default. Checking that box and relinking my files fixed the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...