How do I stop white patches from appearing after using an effect in Illustrator?

Community Beginner ,
Aug 20, 2020

Copy link to clipboard

Copied

Every time I create a shape then apply an effect to it, the gaps where the effects have taken place are filled in by white and no matter what I try, I just can't seem to get rid of them. All I want is to create an effect on a shape (e.g. Spatter) with the result of having transparent edges and not white ones, does anyone know how to resolve/fix/do this?

Adobe Community Professional
Correct answer by Barbara Ash | Adobe Community Professional

Sorry, I realized after posting that you are applying a Photoshop effect within Illustrator. Therefore, the vector shape is being converted to a raster image.

A way around that is after applying the effect, select the object and choose Object > Rasterize. Then use the Image Trace command in the Properties panel. Open the Image Trace Panel and expand the Advanced section and put a checkmark on Ignore White. Back in the Properties panel, click on Expand. 

That will get you back to a vector shape. Of course, it will no longer be an effect. Since it will not be editable as an effect make sure it looks the way you want before following this procedure.

TOPICS
Draw and design, How to, Tools

Views

60

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How do I stop white patches from appearing after using an effect in Illustrator?

Community Beginner ,
Aug 20, 2020

Copy link to clipboard

Copied

Every time I create a shape then apply an effect to it, the gaps where the effects have taken place are filled in by white and no matter what I try, I just can't seem to get rid of them. All I want is to create an effect on a shape (e.g. Spatter) with the result of having transparent edges and not white ones, does anyone know how to resolve/fix/do this?

Adobe Community Professional
Correct answer by Barbara Ash | Adobe Community Professional

Sorry, I realized after posting that you are applying a Photoshop effect within Illustrator. Therefore, the vector shape is being converted to a raster image.

A way around that is after applying the effect, select the object and choose Object > Rasterize. Then use the Image Trace command in the Properties panel. Open the Image Trace Panel and expand the Advanced section and put a checkmark on Ignore White. Back in the Properties panel, click on Expand. 

That will get you back to a vector shape. Of course, it will no longer be an effect. Since it will not be editable as an effect make sure it looks the way you want before following this procedure.

TOPICS
Draw and design, How to, Tools

Views

61

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 20, 2020 0
Adobe Community Professional ,
Aug 20, 2020

Copy link to clipboard

Copied

It's because you are applying a Photoshop effect within Illustrator and the vector shape is being converted to an image.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 1
Community Beginner ,
Aug 20, 2020

Copy link to clipboard

Copied

Really? I am using Illustrator so that's weird. Here is another screenshot where the white edges appear with the effect:Adobe Screenshot Help.JPG

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
Adobe Community Professional ,
Aug 20, 2020

Copy link to clipboard

Copied

Sorry, I realized after posting that you are applying a Photoshop effect within Illustrator. Therefore, the vector shape is being converted to a raster image.

A way around that is after applying the effect, select the object and choose Object > Rasterize. Then use the Image Trace command in the Properties panel. Open the Image Trace Panel and expand the Advanced section and put a checkmark on Ignore White. Back in the Properties panel, click on Expand. 

That will get you back to a vector shape. Of course, it will no longer be an effect. Since it will not be editable as an effect make sure it looks the way you want before following this procedure.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 1
Community Beginner ,
Aug 20, 2020

Copy link to clipboard

Copied

After following this and fiddling around with a few settings, I'm happy to say it worked, thank you so much, Babara, you've been great!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
Adobe Community Professional ,
Aug 20, 2020

Copy link to clipboard

Copied

That's gratifying -- I'm so glad it worked for you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
Resources