how to build a sdk with previous version support.

Explorer ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

I've been developing a plugin using the 2020 SDK ( illustrator sdk).

However I'll want my plugin to be compatible with 2018 and 2019 as well.

The question is, the 2020 sdk tobe compatible all old versions ?
or else i need to include previous version suits ?

Thanks in advance

 

 

Murali.M
TOPICS
SDK

Views

90

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

Sorry Guys,
The question is ....
How to build a plugins with previous version support.

Murali.M

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

I have not done much Illustrator SDK plugin development, but the basic rule is to create multiple builds targeting the SDK version for which you want to create the plugin. So to create a plugin for 2018 you should compile it using the 2018 SDK and so on.

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

@Manan Joshi  thanks for your reply.
I believe It's possible.

I using a plugin (a Esko plugin). It's support three version of illustrators (2018, 2019 and 2020).
That's why I am asking the questin. 

Murali.M

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

LATEST

Guys,

Maybe below conversation is help full us. 

https://community.adobe.com/t5/illustrator/illustrator-cc-2019-not-loading-plugin/m-p/10138442 

But I need to know, how to include older version sutes ?

Murali.M

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines