How to remove white background from transparent Illustrator graphic?

Community Beginner ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

To get the publication to print accurately, I did a work-around to get the below-mentioned graphic to print without a white background. But I would like to know how to prevent/fix this in the future & not have to sacrifice the image's transparency/layers. This graphic is part of a larger printed piece, client submitted packaged InDesign file. All links' (Illustrator & PhotoShop) transparency backgrounds work when the publication pages are exported from InDesign - except this one: this AI graphic is text with gaussian blur and outer glow applied. (This graphic, along with a number of others on the printed piece, are exported out of InDesign as separate files to maintain page position for variable fields during printing.) This is the only graphic within the publication that exports with solid white where it should be transparent. I checked the AI document for transparency, I tried options of saving AI file as pdf, eps, and svg, exporting as png: they all placed in InDesign as visually transparent. But when the InDesign exported pdf (PDF/X-4) of this graphic is imported into the variable data end program the transparency is gone; this end program shows how things will print. I have attached pics of the AI graphic & its Transparency Preview, the InDesign view & its Transparency Preview, and the end-program view showing the appearance of white. 

TOPICS
Bug, How to, Import and export, Performance, Print and publish

Views

597

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 04, 2021 May 04, 2021
Is it transparent when you open it in Acrobat? If it is, then the issue is with the variable data end program.

Likes

Translate

Translate
Adobe Community Professional ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Is it transparent when you open it in Acrobat?

If it is, then the issue is with the variable data end program.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Acrobat's Flattener Preview highlights the graphic portion that was originally built in AI - the section that's showing up with white background in my end-program, but the remaining graphics (built in InDesign) on the pdf are not highlighted - and they show up with transparent background in end-program. This one's got me really stumped, especially for such a simple graphic and considering there are much more complicated AI graphics placed on the document that worked just fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Instead of the Flattener preview (which shows areas with percentages of opacity and blend modes) try Preferences > Page Display > Page Content and Information> Show transparency grid which shows the areas the have a fill of none (none shows as white in Illustrator)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Thanks for that tip Ton, learned something new! Using that route, the entire background does show up transparent - like it's supposed to. And goes back to what Monica mentioned, that the issue is with the end program: the combination of vector art with raster effects is triggering the program to flatten the graphic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

LATEST

If you need to flatten, make sure that the intended background is part of the flattening.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Realized that the AI graphic's stylize raster effects (gaussian blur/outer glow) combined with the vector type is causing a flattening of the entire graphic. So now the question is: is it possible to keep the graphic from flattening before and/or after it's placed in InDesign, and then when the page is exported from InDesign?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines