How to switch from Arabic type setting to English

New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

Hi there,

suddenly and with no apparent reasons - my default type settings in illustrator 2020 are Arabic (RTL and Hindi digits ect etc) as per images attached

 

Screen Shot 2020-04-10 at 12.01.14 PM.pngScreen Shot 2020-04-10 at 12.02.46 PM.png

 

I'm living and working in UAE - but my language has always been set as English UK in the settng panel preferences and never had an issue before. Now i have to set manually the text tool everytime i want to use it - super annoying!

 

Does anyone know how to set English as default 

 

Thanks,

 

Max

 

TOPICS
How to, Tools, Type

Views

1.0K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

2 Correct Answers

Adobe Community Professional , Apr 10, 2020
Zaid Al Hilali Adobe Community Professional , Apr 10, 2020
In Adobe InDesign, we change application defaults by simply closing any open documents, change the font to Gill Sans, change paragraph directions, dictionary language, and any other formatting. From there on, any new document you create in InDesign will remember your new defaults that suit Latin language users, but this is only in InDesign. In Illustrator however it is a longer issue, to my knowledge you need to change your file profile. For instance, if you use the "Print" profile, you will hav...

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional , Apr 10, 2020
Anna Lander Adobe Community Professional , Apr 10, 2020
Check Preferences > Hyphenation > Default Language  

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Apr 10, 2020

Copy link to clipboard

Copied

Check Preferences > Hyphenation > Default Language

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

HI Anna,

thanks a lot for you reply - unfortunately i did already and nothing changed.

 

Screen Shot 2020-04-10 at 1.25.51 PM.png

 

Hyphenation is set to English UK - but the default font still Adobe Arabic and the default type tool is set to Right to Left

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 10, 2020

Copy link to clipboard

Copied

In Adobe InDesign, we change application defaults by simply closing any open documents, change the font to Gill Sans, change paragraph directions, dictionary language, and any other formatting. From there on, any new document you create in InDesign will remember your new defaults that suit Latin language users, but this is only in InDesign.

In Illustrator however it is a longer issue, to my knowledge you need to change your file profile. For instance, if you use the "Print" profile, you will have to change all defaults in a new document, name this new document as Print.ai to replace the one that comes "out of the box" with Illustrator.

Check this link of how to change Illustrator defaults on your Mac or Windows machine. I also prepared a video a few years ago which may help you perform this task.

 

 

Another thing, if you don't use Arabic at all, you may as well remove existing Illustrator version, and download an International English version instead.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

Hi Zaid,

thanks a lot i will follow your guide which seems very well done and clear.

I'm only surprise that there is no an easier way to set new type preferences and most importantly - why it happend to me all of the sudden.

 

Thanks,

 

Max

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Sep 11, 2020

Copy link to clipboard

Copied

Hi,

 

this solved my issue. AI is really weird: you ahve to change all default type settings in order to have Illustrator open documents in the right way. My defaults were for Arabic: any document written in 100% English were automatically converted into hindi figures and weird text for repalced fonts.

 

AI should be more clever than that and automatically detect language and preserve their setting. say I have a paragraph in Arabic, another one in English: opening that document should be transparent.

 

Otherwise, this post was really helpful. Thanks,

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more